TOPIC: WT 1.40 bug in statistic ?

WT 1.40 bug in statistic ? 1 year 6 months ago #1

WT 1.40 shows me now in the statistics 9.265 Media objects. I had with the earlier WT version only 7.423 Media objects. Is this a bug of WT 1.40?
Last Edit: 1 year 6 months ago by Jackie.
The administrator has disabled public write access.

WT 1.40 bug in statistic ? 1 year 6 months ago #2

  • ToyGuy
  • ToyGuy's Avatar
  • OFFLINE
  • Moderator
  • Live like it's Christmas every day - Santa Stephen
  • Posts: 5182
Are you sure? The STATS module simply counts the number of MEDIA objects within the database.
Have you looked at the DB via a tool like PHPMYADMIN to see its count?
Santa Stephen the Fabled Santa
Latest webtrees at MyArnolds.com
Hosted by webtreesonline.com, a division of GeneHosts LLC
MacOS 10.6.8, Apache 2.2+, PHP 5.4.16, MySQL 5.5.28
Last Edit: 1 year 6 months ago by Jackie.
The administrator has disabled public write access.

WT 1.40 bug in statistic ? 1 year 6 months ago #3

Thanks for the hint with the database. I looked into the database and found the problem. It has old entries with a incorrect path to media files. I had these media-path before one year. Locally on my computer and in the GEDCOM all paths are correct. If I manually delete these entries from the database, I think the WT statistic is right again.
Last Edit: 1 year 6 months ago by Jackie.
The administrator has disabled public write access.

WT 1.40 bug in statistic ? 1 year 6 months ago #4

otmar.mayr wrote:
Thanks for the hint with the database. I looked into the database and found the problem. It has old entries with a incorrect path to media files. I had these media-path before one year. Locally on my computer and in the GEDCOM all paths are correct. If I manually delete these entries from the database, I think the WT statistic is right again.

The problem still exists.

I searched just for JPGs with my FTP-client on my large webtrees installation and found currently 14.302 JPG's in the media folder. If the half part are thumbnails, then I have about 7.150 photos. WT 1.40 shows my currently 9.266 photos. The earlier WT version did show 7.423 Media objects. It seems WT 1.40 has a bug with the count of media files. Can someone agree?
The administrator has disabled public write access.

WT 1.40 bug in statistic ? 1 year 6 months ago #5

  • ToyGuy
  • ToyGuy's Avatar
  • OFFLINE
  • Moderator
  • Live like it's Christmas every day - Santa Stephen
  • Posts: 5182
Looks pretty close to me:
Media-Count.jpg
Santa Stephen the Fabled Santa
Latest webtrees at MyArnolds.com
Hosted by webtreesonline.com, a division of GeneHosts LLC
MacOS 10.6.8, Apache 2.2+, PHP 5.4.16, MySQL 5.5.28
Last Edit: 1 year 6 months ago by ToyGuy.
The administrator has disabled public write access.

WT 1.40 bug in statistic ? 1 year 6 months ago #6

  • kiwi
  • kiwi's Avatar
  • OFFLINE
  • Platinum
  • Posts: 5519
Perhaps there is the common confusion between "media object" and "media files".

Objects are 0-level references in the GEDCOM data . Files are the physical media items stored in the data/media folder and sub-folders.

The stats are counting objects, not files.

EDIT: files can be any type of media, not just .jpg. (.pdf, .tif, .png, .jpeg, ..............). So counting JPGs might not be correct.
Nigel

www.our-families.info

Hosted at:
Follow me at:
Last Edit: 1 year 6 months ago by kiwi.
The administrator has disabled public write access.

WT 1.40 bug in statistic ? 1 year 6 months ago #7

  • ToyGuy
  • ToyGuy's Avatar
  • OFFLINE
  • Moderator
  • Live like it's Christmas every day - Santa Stephen
  • Posts: 5182
Media-Count2.jpg
Santa Stephen the Fabled Santa
Latest webtrees at MyArnolds.com
Hosted by webtreesonline.com, a division of GeneHosts LLC
MacOS 10.6.8, Apache 2.2+, PHP 5.4.16, MySQL 5.5.28
The administrator has disabled public write access.
Moderators: makitso
Powered by Kunena Forum