This Help forum is for issues relates to the latest release (1.0). For issues related to beta or svn version please use their own Help forum.
When requesting help please provide as much information as possible. Explain what version of webtrees, PHP and MYSQL you are using. If possible provide a URL to your site so we can see the problem first-hand.
Tip: Think about putting these details in your signature, so it appears in the footer of ALL your messages
  • Page:
  • 1

TOPIC:

Email - correct settings 10 years 3 months ago #1

  • Magenta
  • Magenta's Avatar Topic Author
  • Visitor
  • Visitor
My setup:
Latest stable release of webtrees
PHP 5.2.12
SQL 5.0.91

I've sent a number of test email messages by clicking the link (For technical support or genealogy questions, please contact (my name)) at the bottom of the webtrees page, and never get anything in my inbox. Could you please tell me what I'm doing wrong?


These are my settings:
Gedcom administration > config > webtrees reply address = (my handle)@gmail.com
Site administration > config > messages > use PHP to send messsages
User administration > site administrator > preferred contact method > webtrees sends emails with no storage
User administration > site administration > email address > (my handle)@gmail.com (ie, same as above)

I can't find any other email configuration options besides the above.

Thanks
Maz

Please Log in or Create an account to join the conversation.

Re: Email - correct settings 10 years 3 months ago #2

  • kiwi
  • kiwi's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 4986
Gmail can be very picky about processing emails from other systems. You may not have noticed during setup, but there is a note then about that:

webtrees needs to send emails, such as password reminders and site notifications. To do this, it can use this server's built in PHP mail facility (which is not always available) or an external SMTP (mail-relay) service, for which you will need to provide the connection details.

To use a Google mail account, use the following settings: server=smtp.gmail.com, port=587, security=tls, username=xxxxx@gmail.com, password=[your gmail password]')

If you do not know these settings, leave the default values. They may work. You can change them later.


Try setting webtrees to use SMTP, with the above settings.

If still no luck, try changing SMTP from 587 to 465, as I've known of at least one case where that worked.
Nigel

www.our-families.info

Hosted at:
Follow me at:

Please Log in or Create an account to join the conversation.

Re: Email - correct settings 10 years 3 months ago #3

  • Magenta
  • Magenta's Avatar Topic Author
  • Visitor
  • Visitor
Thanks for your quick response Kiwi. I got it working by using these settings:

Gedcom admin > config > webtrees reply address = (my handle)@gmail.com
Site admin > config > Messages = Use SMTP to send messages
Site admin > config > Server = smtp.gmail.com
Site admin > config > port = 465
Site admin > config > use simple mail headers = yes
Site admin > config > use password = yes
Site admin > config > username = (my handle)@gmail.com
Site admin > config > password = (my gmail password)
Site admin > config > security = TLS
Site admin > config > from email address > (my name), Administrator, (my site name)
Site admin > config > sender email address = gmail.com
User admin > site administrator > preferred contact method = mailto link
User admin > site administrator > email address = (my handle)@gmail.com

(I've also got gmail configured to forward messages to my local inbox and delete from gmail server).

Thanks again
Maz

Please Log in or Create an account to join the conversation.

Re: Email - correct settings 10 years 3 months ago #4

  • kiwi
  • kiwi's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 4986
Glad that's OK, and thanks for posting your successful settings. Hopefully that might help someone else one day. Enjoy your webtrees :-)
Nigel

www.our-families.info

Hosted at:
Follow me at:

Please Log in or Create an account to join the conversation.

Re: Email - correct settings 10 years 2 months ago #5

  • whoami
  • whoami's Avatar
  • Visitor
  • Visitor
hi, I just tried to install webtree and I followed the working settings for using email as smtp. This is the error I get:

Language string failed to load: tls Message was not sent
Mailer error: Language string failed to load: tls
Language string failed to load: tls Message was not sent
Mailer error: Language string failed to load: tls


Any ideas?

Using 1.0.6

Please Log in or Create an account to join the conversation.

Re: Email - correct settings 10 years 2 months ago #6

  • Jackie
  • Jackie's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 4755
Hi,

I am not an expert but perhaps your server does not have a TLS licence... perhaps another licence ?

Please Log in or Create an account to join the conversation.

Last edit: by Jackie.

Re: Email - correct settings 10 years 2 months ago #7

  • whoami
  • whoami's Avatar
  • Visitor
  • Visitor
hey Jackie. TLS is encryption of the connection and isn't a license (en.wikipedia.org/wiki/TLS).

Please Log in or Create an account to join the conversation.

Re: Email - correct settings 10 years 2 months ago #8

  • Jackie
  • Jackie's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 4755
Hi,

thanks for correcting me.

edit : we call them "certificat TLS" in French, wrong translation.

Please Log in or Create an account to join the conversation.

Last edit: by Jackie.
Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 

Re: Email - correct settings 10 years 2 months ago #9

  • whoami
  • whoami's Avatar
  • Visitor
  • Visitor
no worries. thanks for trying :)

Please Log in or Create an account to join the conversation.

Re: Email - correct settings 10 years 2 months ago #10

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 14515
@whoami.

You didn't give us many clues to work with.

What settings did you use?
What mailserver (your own, your web-host's, a public one such as googlemail?)
Is the error intermittent, or does it happen every time? Was it working once, and then stopped, or has it never worked?
etc.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Re: Email - correct settings 10 years 2 months ago #11

  • whoami
  • whoami's Avatar
  • Visitor
  • Visitor

@whoami.

You didn't give us many clues to work with.

What settings did you use?
What mailserver (your own, your web-host's, a public one such as googlemail?)
Is the error intermittent, or does it happen every time? Was it working once, and then stopped, or has it never worked?
etc.


As I said in my post, I am using the same settings that worked for Magenta. The only difference is I'm using my own login/password.

The error happens every time, and it has never worked. I installed webtrees for the first time yesterday. The settings did used to work for phpgedview however.

Please Log in or Create an account to join the conversation.

Re: Email - correct settings 10 years 2 months ago #12

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 14515
webtrees (and phpGedView) both use the same phpmailer library.

The code is attempting to connect via TLS.

It fails, and generates the error 'tls' - which is not defined :-)

This library has some debug. In the file library/phpmailer/class.smtp.php at line 92 is this

$this->do_debug = 0;

Change it to

$this->do_debug = 2;

Then try again. You might see additional error messages on the screen.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Re: Email - correct settings 10 years 2 months ago #13

  • whoami
  • whoami's Avatar
  • Visitor
  • Visitor
No luck. I also tried to send from the user admin interface, and I got this

Language string failed to load: tls Message was not sent
Mailer error: Language string failed to load: tls
Message successfully sent to User


I confirmed the message didn't get sent btw.

Please Log in or Create an account to join the conversation.

Last edit: by whoami.

Re: Email - correct settings 10 years 2 months ago #14

  • kiwi
  • kiwi's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 4986
fisharebest won't be around for at least 8 hours now. I'm no expert in email seup, but can answer part of that last post.

I also tried to send from the user admin interface

Thats logical. Phpmailer is used wherever smtp emails are sent from webtrees. The screen you use will never make a difference.

Does "No luck" mean there were no further debug messages; or you had no luck finding and changing the file "library/phpmailer/class.smtp.php"; or there were debug messages but they didn't solve the problem, in which case what were they?

Have you tried different SMTP port settings? Just because Magenta found that 465 worked doesn't mean it will for you. As per earlier posts here, try 587.

Have you tried any security setting other than TLS? Do you KNOW this is the one you need.

Try this link to see if it has any tips that might help: techblissonline.com/gmail-smtp/
Nigel

www.our-families.info

Hosted at:
Follow me at:

Please Log in or Create an account to join the conversation.

Re: Email - correct settings 10 years 2 months ago #15

  • whoami
  • whoami's Avatar
  • Visitor
  • Visitor
I changed it to 587 and it worked. Thanks. It's a strange error for whatever issues there were with the connection I think, but there we go.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum