This Help forum is for issues relates to the latest release (1.1.x). For issues related to beta or svn version please use their own Help forum.
When requesting help please provide as much information as possible. Explain what version of webtrees, PHP and MYSQL you are using. If possible provide a URL to your site so we can see the problem first-hand.
Tip: Think about putting these details in your signature, so it appears in the footer of ALL your messages
  • Page:
  • 1

TOPIC: CAnnot upload GEDCOM file

CAnnot upload GEDCOM file 8 years 11 months ago #1

  • hlein
  • hlein's Avatar Topic Author
  • Visitor
  • Visitor
Hi,

I want to replace the existing tree with a new GEDCOM file. I select "Stammbäume" and clock on "Hochladen" (Upload). I select the new GEDCOM file and click on "Speichern". A warning comes abou about hte difference of filename and treename. I accept it with ok.

Now, the warning disappears and nothing happens any more. On the server, I can't see CPU traffic (there should be some mysql, ...) and the GEDCOM file never appears in webtrees/data.


Note: If I load the GEDCOM file to webtrees/data by FTP, I can import it afterwards.

Regards
Helmut

Please Log in or Create an account to join the conversation.

Re: CAnnot upload GEDCOM file 8 years 11 months ago #2

What is the size of the GEDCOM file? Could it be too large to be accepted for a PHP upload?
Vytautas

webtrees 1.7.9 (MODS: vytux_cousins, vytux_gallery3, vytux_pages, fancy_imagebar, fancy_treeview, Ancestral fan chart)
PHP 7.1.2, MySQL 5.7.17 x86_64 GPL, Nginx (mainline)
ged.vytux.com
Help translate Vytux Modules at translate.vytux.com/

Please Log in or Create an account to join the conversation.

Re: CAnnot upload GEDCOM file 8 years 11 months ago #3

  • hlein
  • hlein's Avatar Topic Author
  • Visitor
  • Visitor
The size is less than 2,5 MB, containing about 10.000 individuals. This should not be too large (my optinion).

Please Log in or Create an account to join the conversation.

Re: CAnnot upload GEDCOM file 8 years 11 months ago #4

  • hlein
  • hlein's Avatar Topic Author
  • Visitor
  • Visitor
Hi,

I just tried with a 10k file - it seems to work (mysql traffic and the browser image is different from before).

If the file size is the reason, the limit should be mentioned somewhere and an error message should be issued to inform the user (just logging it somewhere on the server - if this should be the case - is not enough because the standard user has no access to the server administration).

Regards
Helmut

Please Log in or Create an account to join the conversation.

Re: CAnnot upload GEDCOM file 8 years 11 months ago #5

  • hlein
  • hlein's Avatar Topic Author
  • Visitor
  • Visitor
Hi,

I just made another attempt:
I zipped the GEDCOM file which reduced the size from 2.484.212 to 360.083. I then tried to upload the zip file. It starts with "Lade Daten aus GEDCOM" (Loading data from GEDCOM) but stops at 0.0%. with the message "Ungültige GEDCOM Datei - keine Kopfdaten gefunden" (Invalid GEDCOM file - no head data found).

Regards
Helmut

Please Log in or Create an account to join the conversation.

Last edit: by hlein.

Re: CAnnot upload GEDCOM file 8 years 11 months ago #6

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 12895
From the admin page, choose the "PHP Information" link

What value do you have for "post_max_size" and "upload_max_filesize".

Your server will not let you upload files larger than this. Common defaults for these values are 8MB and 2MB.

Can you (or your host) increase them?

If not, then you should upload the file to the /data directory using FTP, and select the "import" option.

import/export - read/write to file on server
upload/download - read/write to file on client
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Re: CAnnot upload GEDCOM file 8 years 11 months ago #7

  • hlein
  • hlein's Avatar Topic Author
  • Visitor
  • Visitor
Thanks Greg,

the upload_max_size is set to 2 MB (both local and master value).

So, there remains only the improvement request that the user should be informed when the upload is not possible.

Regards
Helmut

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum