Please do NOT post requests for help here. Use the Help forum for that.

TOPIC: [SOLVED] PHP versions

PHP versions 2 months 2 weeks ago #1

  • tezywezy
  • tezywezy's Avatar
  • Offline
  • Junior
  • Tony
  • Posts: 107
while checking my main site in preperation for the new update I get this anomoly
Im useing php 7.0.29 & all seems well





but when I switch to 7.1 & 7.2 I get this, the right hand panels disappear



checked themes & all give same results

only happens on individuals pages
webtrees 1.7.9
huckle-parker.info
PHP 7.0.29
Mysql 5.6.20
Last Edit: 2 months 2 weeks ago by tezywezy. Reason: extra info
The administrator has disabled public write access.

PHP versions 2 months 2 weeks ago #2

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 10395
webtrees 1.7.9 was written before PHP 7.1 was released.

There are a small number of incompatibilities.

I recommend you stay with PHP 7.0 for the time being.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

PHP versions 2 months 2 weeks ago #3

  • tezywezy
  • tezywezy's Avatar
  • Offline
  • Junior
  • Tony
  • Posts: 107
thanks for very quick reply, will wait
webtrees 1.7.9
huckle-parker.info
PHP 7.0.29
Mysql 5.6.20
The administrator has disabled public write access.

[SOLVED] PHP versions 2 months 2 weeks ago #4

  • tezywezy
  • tezywezy's Avatar
  • Offline
  • Junior
  • Tony
  • Posts: 107
Problem solved.
webtrees 1.7.9
huckle-parker.info
PHP 7.0.29
Mysql 5.6.20
The administrator has disabled public write access.

[SOLVED] PHP versions 2 months 2 weeks ago #5

  • kcshaw
  • kcshaw's Avatar
  • Offline
  • New
  • Posts: 3
FWIW, I have not noticed that problem on 1.7.9 with PHP 7.1.

For a time I did use PHP 7.2, and the only problem I recall finding was the inability of webtrees to generate PDF reports -- that issue was not limited just to Webtrees, however. While some things have evidently changed in PHP with regard to that, it may just be something I'm missing on the server side. At any rate, I went back to 7.0 which seemed fine, then tried 7.1 which also seems to be working fine for me. Assuming there are quirks, they have not been visible to me thus far; I'm also basically the only user so there is not much traffic, tho I do enter/update or review a few things most days. YMMV.
The administrator has disabled public write access.
Moderators: makitso
Powered by Kunena Forum