Please do NOT post requests for help here. Use the Help forum for that.

TOPIC: webtrees 2.0.0-alpha

webtrees 2.0.0-alpha 2 months 5 days ago #1

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 10500
The second alpha release is now available.

As well as a number of bug-fixes, it now supports auto-upgrades. So, you'll be able to upgrade to subsequent 2.0 releases automatically.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

webtrees 2.0.0-alpha 1 month 3 weeks ago #2

  • cyclonewolfok
  • cyclonewolfok's Avatar
  • Offline
  • New
  • Posts: 1
I tried to install it twice and it runs smooth but at some moment near conclusion i get this :

SQLSTATE[HY000]: General error: 1709 Index column size too large. The maximum column size is 767 bytes.

What can I do to solve that ? Thanks for your help
The administrator has disabled public write access.

webtrees 2.0.0-alpha 1 month 3 weeks ago #3

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 10500
OK, we need to find out which MySQL statement is causing this error.

Is there any other information in the error message?

What version of MySQL?

Have you made any changes, such as forcing a change from 3-byte to 4-byte UTF?

Do you know how to enable the MySQL query log and look in the MySQL log file? (i.e. SET GLOBAL general_log := 1;)

Failing that, then after you the installation fails, can you create a dump of the database (e.g. using phpmyadmin or mysqldump) and send it it me? I'll then try to work out how far the installation had got, and what the next statement would have been.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

webtrees 2.0.0-alpha 4 weeks 2 days ago #4

  • ungeahnt
  • ungeahnt's Avatar
  • Offline
  • New
  • Posts: 20
Hi,

I've tried to install a test system with wt V2.0.0 alpha3 and received the same error (after entering the db credentials like 'db host', 'db name', ... credentials for the 'administrator account'):

SQLSTATE[HY000]: General error: 1709 Index column size too large. The maximum column size is 767 bytes.

fisharebest wrote:
Is there any other information in the error message?
What version of MySQL?
-> Server configuration: hoster Strato / php 7.0 and 7.2 (both tested) / mysql V5.6.41

fisharebest wrote:
Have you made any changes, such as forcing a change from 3-byte to 4-byte UTF?
-> Not that I know of. How could I check this? Do you mean the 'general settings' / 'Server connection collation' in phpmyadmin? -> selected is 'UTF8mb4_unicode_ci'

fisharebest wrote:
Do you know how to enable the MySQL query log and look in the MySQL log file? (i.e. SET GLOBAL general_log := 1;)
It looks like that logging could not be activated (-> message in phpmyadmin: "no access", SUPER user rights needed)

fisharebest wrote:
can you create a dump of the database (e.g. using phpmyadmin or mysqldump) and send it it me?
If it's still helpful I could send a dump.

I've found this blog where a (similar) problem is described with hoster Strato and symfony. The author describes a solution with a modified charset configuration. But I've no idea where these values must be entered (at least for testing). Others state that the problem is caused by the 'old' mysql version 5.6 and with a newer Version this problem is solved (but I could not update).

Thanks for help
webtrees V1.7.11 | PHP Version 7.2.10 | MySQL 5.6.41
Strato Webhosting SunOS 5.10 i86pc
Schmidt ⚭ Schwab (Sudetenland) | Hauer ⚭ Bühler (Bayern / BW) | Маринов ⚭ Шаламанова (BG)
Last Edit: 4 weeks 2 days ago by ungeahnt.
The administrator has disabled public write access.

webtrees 2.0.0-alpha 4 weeks 2 days ago #5

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 10500
I'm afraid I will have no time to help with this until the end of next week.

It is, as far as I can tell, a server configuration issue.

You could contact your web host's technical support.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

webtrees 2.0.0-alpha 3 weeks 1 day ago #6

  • ungeahnt
  • ungeahnt's Avatar
  • Offline
  • New
  • Posts: 20
Hi,

the hoster's support told me to change the database 'coding'.

So I've tested different collation in phpMyAdmin (in various configurations; but without success):

1) phpMyAdmin -> click on server -> general settings -> Server connection collation: utf8mb4_unicode_ci
-> (tested also: utf8_unicode_ci, utf8mb4_bin, utf8_bin)

2) phpMyAdmin -> click on database -> operations -> Collation: latin1_german1_ci
-> (tested also: utf8_unicode_ci, utf8mb4_unicode_ci)

What's the recommended collation for wt V2? My wt V1.7. runs with utf8mb4_unicode_ci (server) / latin1_german1_ci (database)

What else I could change? The sql query logging could not be activated.

BTW: inbetween I've installed wt V2 on a xampp-server without this problem. Collation is: utf8mb4_unicode_ci and utf8mb4_general_ci.
But in the future wt V2 should run on my hosters webspace, of course.
webtrees V1.7.11 | PHP Version 7.2.10 | MySQL 5.6.41
Strato Webhosting SunOS 5.10 i86pc
Schmidt ⚭ Schwab (Sudetenland) | Hauer ⚭ Bühler (Bayern / BW) | Маринов ⚭ Шаламанова (BG)
The administrator has disabled public write access.

webtrees 2.0.0-alpha 3 weeks 1 day ago #7

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 10500
> My wt V1.7. runs with utf8mb4_unicode_ci (server) / latin1_german1_ci (database)

These are default settings. They are only used when the client/application does not specify a collation.

webtrees *does* specify a collation. It specifies utf8_unicode_ci everywhere.

If you look at one of the tables in webtrees, you should see that the columns have utf8_unicode_ci, and the table-default is also utf8_unicode_ci;

e.g.
mysql> show create table wt_individuals;

CREATE TABLE `wt_individuals` (
  `i_id` varchar(20) CHARACTER SET utf8 COLLATE utf8_unicode_ci NOT NULL,
  `i_file` int(11) NOT NULL,
  `i_rin` varchar(20) CHARACTER SET utf8 COLLATE utf8_unicode_ci NOT NULL,
  `i_sex` enum('U','M','F') CHARACTER SET utf8 COLLATE utf8_unicode_ci NOT NULL,
  `i_gedcom` longtext CHARACTER SET utf8 COLLATE utf8_unicode_ci NOT NULL,
  PRIMARY KEY (`i_id`,`i_file`),
  UNIQUE KEY `wt_individuals_ix1` (`i_file`,`i_id`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci

Show me the output from "show create table wt_individuals;" on your server.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

webtrees 2.0.0-alpha 3 weeks 1 day ago #8

  • ungeahnt
  • ungeahnt's Avatar
  • Offline
  • New
  • Posts: 20
webtrees *does* specify a collation. It specifies utf8_unicode_ci everywhere.
yes, you are right. All tables on both installations (wtV1.7 + wtV2) shows utf8_unicode_ci collation.

Below you see the output as requested:

output from server wt V2:
wt_individuals	CREATE TABLE `wt_individuals` (
  `i_id` varchar(20) COLLATE utf8_unicode_ci NOT NULL,
  `i_file` int(11) NOT NULL,
  `i_rin` varchar(20) COLLATE utf8_unicode_ci NOT NULL,
  `i_sex` enum('U','M','F') COLLATE utf8_unicode_ci NOT NULL,
  `i_gedcom` longtext COLLATE utf8_unicode_ci NOT NULL,
  PRIMARY KEY (`i_id`,`i_file`),
  UNIQUE KEY `wt_individuals_ix1` (`i_file`,`i_id`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci


output from server wt V1.7 (the working one):
wt_individuals	CREATE TABLE `wt_individuals` (
  `i_id` varchar(20) COLLATE utf8_unicode_ci NOT NULL,
  `i_file` int(11) NOT NULL,
  `i_rin` varchar(20) COLLATE utf8_unicode_ci NOT NULL,
  `i_sex` enum('U','M','F') COLLATE utf8_unicode_ci NOT NULL,
  `i_gedcom` longtext COLLATE utf8_unicode_ci NOT NULL,
  PRIMARY KEY (`i_id`,`i_file`),
  UNIQUE KEY `wt_individuals_ix1` (`i_file`,`i_id`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci

Hope it's helpful. Thanks a lot for the support!

Another point: Both installation runs on the same server. The main tree (V1.7) is "proavitus.de" (with SSL) and wtV2 I've tried to install to the subdomain "dev.proavitus.de" (without SSL). In phpmyAdmin of wtV2 there is a message in red shown: "Server connection: SSL is not being used"
-> Could this cause the problem?
webtrees V1.7.11 | PHP Version 7.2.10 | MySQL 5.6.41
Strato Webhosting SunOS 5.10 i86pc
Schmidt ⚭ Schwab (Sudetenland) | Hauer ⚭ Bühler (Bayern / BW) | Маринов ⚭ Шаламанова (BG)
The administrator has disabled public write access.
Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 

webtrees 2.0.0-alpha 3 weeks 1 day ago #9

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 10500
> Failing that, then after you the installation fails, can you create a dump of the database (e.g. using phpmyadmin or mysqldump) and send it it me?
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

webtrees 2.0.0-alpha 2 weeks 2 days ago #10

  • ungeahnt
  • ungeahnt's Avatar
  • Offline
  • New
  • Posts: 20
Hi,

additional to the dump that I've sent to Greg:

I've exported from my local wtV2-xampp installation a mysql-dump and imported it to the 'problem-server' dev.proavitus.de. With this dump all tables were created and wtV2 is running without problems (as far as I could see at the moment).

This workaround allows me to do some tests, but the setup-problem still exists (at least on this Strato-server). Is it ok, to copy the dump from one database to another (same wt Version assumed)?
webtrees V1.7.11 | PHP Version 7.2.10 | MySQL 5.6.41
Strato Webhosting SunOS 5.10 i86pc
Schmidt ⚭ Schwab (Sudetenland) | Hauer ⚭ Bühler (Bayern / BW) | Маринов ⚭ Шаламанова (BG)
The administrator has disabled public write access.

webtrees 2.0.0-alpha 2 weeks 2 days ago #11

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 10500
> additional to the dump that I've sent to Greg

Oops - sorry for not replying to that email.

MySQL databases can be configured to allow long indexes (max 3072 bytes)
or short indexes (max 767 bytes).

Yours is configured with the lower limit.

I've created the following issue, so it doesn't get forgotten.

github.com/fisharebest/webtrees/issues/2009

> Is it ok, to copy the dump from one database to another (same wt Version assumed)?

Yes. This is the recommended way to move from one server to another.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

webtrees 2.0.0-alpha 2 weeks 2 days ago #12

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 10500
> Is it ok, to copy the dump from one database to another

Of course, this won't work for you.

The dump will try to create a "long" index - which will fail.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

webtrees 2.0.0-alpha 2 weeks 1 day ago #13

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 10500
For the next alpha release (alpha.4) the minimum version of PHP will be raised from 7.0 to 7.1

PHP 7.0 reaches "end of life" on 3 December 2018.

webtrees 1.7 currently supports PHP 5.3 - 7.2, and will continue to be supported for the foreseeable future.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
Last Edit: 2 weeks 1 day ago by fisharebest. Reason: Wrong PHP version
The administrator has disabled public write access.

webtrees 2.0.0-alpha 5 days 9 hours ago #14

  • topcat0131
  • topcat0131's Avatar
  • Offline
  • New
  • Posts: 8
I am using WebTrees 2.0.0-Alpha-3, but I got there through the path of the Webtrees-Master download [it is v2.0.0, not sure what alpha] but it loaded OK [didn't look pretty] and gedcom loaded fine. Then upgraded to alpha-3 by saving [overlaying] the alpha-3 in the web folder. Went straight to user screen [no setup], running fine [except still cannot get media to show, all that shows is 500 gif].
The administrator has disabled public write access.
Moderators: makitso
Powered by Kunena Forum