Please do NOT post requests for help here. Use the Help forum for that.
  • Page:
  • 1
  • 2

TOPIC: [SOLVED] Running webtrees under WAMPSERVER64

Running webtrees under WAMPSERVER64 1 month 1 week ago #1

  • MegastarMagus
  • MegastarMagus's Avatar
  • Offline
  • New
  • Posts: 14
Hi,

My question is "How to run an instance of webtrees under a WAMPSERVER64 instance?".

While I am computer-literate, I am NOT "SERVER-literate" in as much as I have used WAMP once before to create a WordPress site but I do not know how to tweak the settings in WAMP to make a different program (such as webtrees) work as required.

My first time using WAMP there was a set of step-by-step instructions on how to set up the WP instance under WAMP (what to turn on, turn off, ignore, etc.).


Is there a similar set of instructions to run webtrees under WAMP?

I would be most grateful to be pointed in the right direction!!!

Thank you!

MegastarMagus

I've attached an image of my current WAMP installation details.
Attachments:
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #2

  • bertkoor
  • bertkoor's Avatar
  • Offline
  • Gold
  • Greetings from Utrecht, Holland
  • Posts: 1462
When wamp is running, what do you see if you browse to localhost or 127.0.0.1? I would expect a placeholder page with "it works"
Try to figure out what the port is wamp listens to. Often the default port 80 is unaccessible under windows. Next favorite is 8080.

In the folder where wamp is installed, do you see a subfolder named www? That's where I expect an index.html (containing "it works")
You can copy the webtrees php scripts there, after deleting the default pages.
stamboom.BertKoor.nl runs on webtrees v1.7.9
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #3

  • MegastarMagus
  • MegastarMagus's Avatar
  • Offline
  • New
  • Posts: 14
Hi bertkoor!

In Browser with localhost (also 127.0.0.1) in URL address - with WAMP running:

says "local server - all services running" - also refer first image localhost

I do not see a message - "it works" - anywhere.

I have not loaded webtrees into anything yet as I do not know how to set wamp up (which is my question - how do you set wamp up for a webtrees installation?).


Sorry - I do not know how to figure out what port wamp listens to right now - I will have to research that...

Is your statement "That's where I expect an index.html (containing "it works")" based on having webtrees ready to load into the www subfolder? At the moment, there is no single index.html file in the folder where wamp is installed - there are index.html files for the WP instance I created a few years ago as I alluded to in my initial posting.

As I say - computer literate not "server-literate"! Sorry - learning curve here!!!

Thanks for your patience!

MegastarMagus
Attachments:
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #4

  • bertkoor
  • bertkoor's Avatar
  • Offline
  • Gold
  • Greetings from Utrecht, Holland
  • Posts: 1462
Maybe you should not expect the text "it works" literally. It's just that I recall something along that when testing with XAMPP instead of WAMP. But you should see some proof of the software working from your browser.

Next issue to tackle is to find where to put the scripts. Usually Apache uses a folder called htdocs, I read elsewhere Wamp defaults to c:/wamp/www
stamboom.BertKoor.nl runs on webtrees v1.7.9
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #5

  • fisharebest
  • fisharebest's Avatar
  • Online
  • Administrator
  • Posts: 10569
This page has an article describing how to install Wordpress using WAMP.

www.makeuseof.com/tag/how-to-set-up-your-own-wampserver/

If you simply replace "wordpress" with "webtrees", then the instructions should apply.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #6

  • MegastarMagus
  • MegastarMagus's Avatar
  • Offline
  • New
  • Posts: 14
Thanks, fisharebest - I will do the substitution in the process (webtrees for wordpress) and see how I go. Thank you for the link, too... I had forgotten I had found that back in the day I did the WP testing.... too long ago to remember the details of what I did back then!!!

Wish me luck!
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #7

  • MegastarMagus
  • MegastarMagus's Avatar
  • Offline
  • New
  • Posts: 14
YAY!!!

Thank you so much fisharebest - I have successfully loaded the webtrees program and I am able to see the "front page" of my new site under WAMP.

However - now the problem is that I am unable to find a GEDCOM small enough to load into the program.

As an example - my third try is a file sized 2543kb and I (still) get the error message " The uploaded file exceeds the allowed size. "

While my research tree on FTM has 33000+ individuals, I am trying to upload only 8 generations of my tree with no facts, media, or other data - just the names.


Any suggestions as to why I am unable to import a GEDCOM?


MegastarMagus
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #8

  • fisharebest
  • fisharebest's Avatar
  • Online
  • Administrator
  • Posts: 10569
Find your PHP.INI file.

There are two settings while control the maximum file upload size.

They are called (something like) post_max and file_upload, and default to 2M and 8M.

Set them both to something larger than your GEDCOM, then restart WAMP for the new settings to take effect.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.
Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 

Running webtrees under WAMPSERVER64 1 month 1 week ago #9

  • MegastarMagus
  • MegastarMagus's Avatar
  • Offline
  • New
  • Posts: 14
Ok - I've had a search of my webtrees folder under WAMP and then my WAMP Folder and have found PHP.INI under Apache in the WAMP folder.

The programming data says (line 667):
; Maximum size of POST data that PHP will accept.
; Its value may be 0 to disable the limit. It is ignored if POST data reading
; is disabled through enable_post_data_reading.
; php.net/post-max-size
post_max_size = 8M

So... I'm reading this to say that post_max-size should be set to 0, rather than say, 50mb, which is the size of the GEDCOM containing all direct-line generations of my ancestry.

I will try with
  1. setting to 50
  2. setting to 0

And get back to you!!!

Thanks for the response fisharebest!
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #10

  • MegastarMagus
  • MegastarMagus's Avatar
  • Offline
  • New
  • Posts: 14
Well, if I was confused before, I am even more so after rereading the program data.

I tried setting post_max_size
  • to 50mb and that did not work - I still received the "file too big" error.
  • to 0mb and that did not work - I still received the "file too big" error.
  • to 0 and that did not work - I still received the "file too big" error.

I then looked at my WAMP installation under bin/apache and I find I have two Apache instances:
  • apache2.4.9
  • apache2.4.27

So, now my question is - which one should I be using?

If I need a newer version, where do I find that, or do I just download another instance of WAMP and go through the entire process again???


Thanks in advance!

MegastarMagus
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #11

  • bertkoor
  • bertkoor's Avatar
  • Offline
  • Gold
  • Greetings from Utrecht, Holland
  • Posts: 1462
MegastarMagus wrote:
I then looked at my WAMP installation under bin/apache and I find I have two Apache instances:
  • apache2.4.9
  • apache2.4.27

So, now my question is - which one should I be using?

The screenshot you posted says 2.4.27 is the one you're using, so you could safely delete 2.4.9.

In webtrees go to the top menu - My Pages - Control Panel. Then menu item Website - Server information.
There you can find the value of post_max_size that's actually in use. Also have a look at the value of memory_limit.
stamboom.BertKoor.nl runs on webtrees v1.7.9
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #12

  • MegastarMagus
  • MegastarMagus's Avatar
  • Offline
  • New
  • Posts: 14
Thanks, bertkoor - I have removed the older Apache version (apache2.4.9), and restarted WAMP - with no problems.

I've made sure that the php.ini file that I am editing for post_max_size is the correct one.

Looking at My Pages - Control Panel - Website - Server information, the settings now show:
  • max_execution_time 120
  • max_file_uploads 20
  • max_input_nesting_level 64
  • max_input_time 60
  • max_input_vars 2500
  • memory_limit 128M
  • open_basedir no value
  • output_buffering 4096
  • output_encoding no value
  • output_handler no value
  • post_max_size 100M

The programming code for memory_limit says the max is 128M which is what is currently set.


I'm going to try the post_max_size set to 100M and see whether that works.
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #13

  • fisharebest
  • fisharebest's Avatar
  • Online
  • Administrator
  • Posts: 10569
As per my earlier post, there are two settings, and you must update BOTH of them.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #14

  • bertkoor
  • bertkoor's Avatar
  • Offline
  • Gold
  • Greetings from Utrecht, Holland
  • Posts: 1462
fisharebest wrote:
As per my earlier post, there are two settings, and you must update BOTH of them.

So that would be variables post_max_size and upload_max_filesize
stamboom.BertKoor.nl runs on webtrees v1.7.9
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #15

  • MegastarMagus
  • MegastarMagus's Avatar
  • Offline
  • New
  • Posts: 14
Sometimes I can not see the woods for the trees, fisharebest!!! Pity I missed the upload_max_filesize message!

Have now updated upload_max_filesize and I am trialing an upload of a 46gb GEDCOM - it seems to be working!


Sorry I missed the upload_max_filesize parameter, fisharebest!
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #16

  • MegastarMagus
  • MegastarMagus's Avatar
  • Offline
  • New
  • Posts: 14
Well, I've definitely moved forward.

Once I updated the upload_max_filesize the uploads happened rather fast.

I moved gradually up my GEDCOM extracts 10gens, 20gens, but there was a fail on 30gens:
Fatal error: Uncaught TypeError: substr() expects parameter 3 to be integer, boolean given in D:\wamp64\www\webtrees\app\Individual.php:1253 Stack trace: #0 D:\wamp64\www\webtrees\app\Individual.php(1253): substr('"Black William"', 0, false) #1 D:\wamp64\www\webtrees\app\GedcomRecord.php(600): Fisharebest\Webtrees\Individual->addName('NAME', '"Black William"', '1 NAME "Black W...') #2 D:\wamp64\www\webtrees\app\Individual.php(1324): Fisharebest\Webtrees\GedcomRecord->extractNamesFromFacts(1, 'NAME', Array) #3 D:\wamp64\www\webtrees\app\GedcomRecord.php(633): Fisharebest\Webtrees\Individual->extractNames() #4 D:\wamp64\www\webtrees\app\Functions\FunctionsImport.php(1007): Fisharebest\Webtrees\GedcomRecord->getAllNames() #5 D:\wamp64\www\webtrees\app\Functions\FunctionsImport.php(671): Fisharebest\Webtrees\Functions\FunctionsImport::updateNames('I14065', 1, Object(Fisharebest\Webtrees\Individual)) #6 D:\wamp64\www\webtrees\app\Http\Controllers\GedcomFileController.php(215): Fisharebest\Webtrees\Functions\FunctionsImport::im in D:\wamp64\www\webtrees\app\Individual.php on line 1253


Hope its fixable!!!
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #17

  • bertkoor
  • bertkoor's Avatar
  • Offline
  • Gold
  • Greetings from Utrecht, Holland
  • Posts: 1462
It looks like you found a bug. The name "Black William" does not contain slashes to separate given names from the surname.
You can work around this by editing the GEDCOM file for this record:
1 NAME Black William //

or alternatively:
1 NAME Black William
2 GIVN William
stamboom.BertKoor.nl runs on webtrees v1.7.9
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #18

  • fisharebest
  • fisharebest's Avatar
  • Online
  • Administrator
  • Posts: 10569
I see you are using the 2.0.0-alpha release.

(Thanks. The more people who test/use this, the better!).

One of the changes in 2.0 is that we enable lots of "strict" checks everywhere.
This catches lots of cases where the code previously worked - but sometimes for the wrong reason.

In your case, it is caused by this record:

1 NAME "Black William"

I think it is caused by having the entire name within quotes.

I've created a issue for this on the tracker github.com/fisharebest/webtrees/issues/2020 and will fix it as soon as I can.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #19

  • fisharebest
  • fisharebest's Avatar
  • Online
  • Administrator
  • Posts: 10569
This turns out to be a simple fix.

It's a one-line edit to one of the files. See here for details.

github.com/fisharebest/webtrees/commit/7...36a71eda9ca708172a70
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Running webtrees under WAMPSERVER64 1 month 1 week ago #20

  • MegastarMagus
  • MegastarMagus's Avatar
  • Offline
  • New
  • Posts: 14
Well, I am relieved to know it was "my fault"!


OK - I've edited the GEDCOM to place slashes instead of quotation marks.



However, a new wrinkle is that I appear to be stuck in a loop where the Control Panel/Manage family trees will not clear the error message regarding Black William.

I have logged out, and back in, but every time I select Manage family trees the error message reappears.
I have also tried changing browsers (Chrome as default, Firefox) and shutting down Wamp and restarting it...

Any clues?

It is as though the program is still trying to load that last GEDCOM and is stuck on that error...
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: makitso
Powered by Kunena Forum