I have developed a range of add-ons for webtrees available only from my kiwitrees.net web site: kiwitrees.net/simpl-add-ons/. For any queries related to those items contact me direct from that site.
  • Page:
  • 1

TOPIC:

Fatal errors - Only heading shown. 7 years 5 months ago #1

  • JohnGrahamSlee
  • JohnGrahamSlee's Avatar Topic Author
  • Visitor
  • Visitor
Upgraded to webtrees 1.5.0 from 1.4.3 but only heading bar is shown. Getting Error:
AH01215: PHP Fatal error: Call to undefined function safe_GET() in /home/sites/nbepiphany.co.uk/public_html/sleebooth.co.uk/modules_v3/simpl_menu2/module.php on line 88
AH01215: PHP Fatal error: Call to a member function getClientIp() on a non-object in /home/sites/nbepiphany.co.uk/public_html/sleebooth.co.uk/includes/session.php(303) : runtime-created function on line 1

Repeated download but with same result

Running under PHP 5.3.27

Downloaded 1.4.4 and all OK again but want to upgrade to 1.5.0 after all the team's hard work

Please Log in or Create an account to join the conversation.

Last edit: by JohnGrahamSlee. Reason: edited to report 1.4.4 works OK

Fatal errors - Only heading shown. 7 years 5 months ago #2

  • nigelo
  • nigelo's Avatar
  • Visitor
  • Visitor
John, you are running my simpl_menu2 add-on. So..

1 - Upgrade instructions say to always disable modifications and add-ons before upgrading

2 - As per blog article I wrote months ago at kiwitrees.net, I will not be upgrading any add-ons to work with 1.5.0 (nor any of my own sites).

Please Log in or Create an account to join the conversation.

Fatal errors - Only heading shown. 7 years 5 months ago #3

  • JohnGrahamSlee
  • JohnGrahamSlee's Avatar Topic Author
  • Visitor
  • Visitor
Thanks for the quick, clear response. By following your instruction to disable simple_menu, I have been able to upgrade to 1.5.0.
(A shame that you have dropped support for your add-ons but I can understand - though not necessarily agree with - your standpoint.)

Please Log in or Create an account to join the conversation.

Fatal errors - Only heading shown. 7 years 5 months ago #4

  • nigelo
  • nigelo's Avatar
  • Visitor
  • Visitor
I haven't dropped support for my add-ons. Far from it. I am upgrading them as well as adding more new ones.

Please Log in or Create an account to join the conversation.

Fatal errors - Only heading shown. 7 years 5 months ago #5

  • Shemwell
  • Shemwell's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 206
I upgraded to webtrees 1.5 and much to my dismay I had to remove all of my beloved simpl_add-ons that I've grown to really like and have used for quite some time, so I uploaded 1.44 and now they work fine.

I understand the simpl_add-ons will not be upgraded to work with webtrees 1.5.0.... bummer.

In the forums I found the proposed time line for webtrees 2.0...

KosherJava wrote back in Feb:
"The (very) approximate timescales are
1.4.0 - December - changes to DB structure, rewrite of media libraries, rewrite of relationship calculations
1.4.x - January-April - bugfix releases and end of support for PHP5.2.
1.5.0 - May-June - rewrite some of the code to use PHP5.3 features.
Version 2.0 will be a complete rewrite. It is likely to be a completely different product, rather than an upgrade."

I really like the simpl_add-ons, especially the latest, Simpl_research module, so I was wondering if I should just stick with 1.4.4 and hopefully the add-ons would be upgraded to work with version 2.0, or are the changes in 1.5 substantial enough to outweigh the loss of some really fine add-ons until 2.0 is released?. How's 2.0 coming along?
Barry

Please Log in or Create an account to join the conversation.

Last edit: by Shemwell.

Fatal errors - Only heading shown. 7 years 5 months ago #6

  • nigelo
  • nigelo's Avatar
  • Visitor
  • Visitor

Shemwell wrote:

Version 2.0 will be a complete rewrite. It is likely to be a completely different product, rather than an upgrade.


I really like the simpl_add-ons, especially the latest, Simpl_research module, so I was wondering if I should just stick with 1.4.4 and hopefully the add-ons would be upgraded to work with version 2.0, or are the changes in 1.5 substantial enough to outweigh the loss of some really fine add-ons until 2.0 is released?. How's 2.0 coming along?"


Greg wrote that 12 months ago. That was at a time when he had enthused me with the idea of a completely new product. We had extensive discussions about what it might look like. Since then there appears to have been absolutely nothing done in that direction (the code sits untouched at github.com/fisharebest/webtrees2 ), and I am no longer "in the loop" for any discussions about such possibilities. I am therefore working on my add-ons in the assumption that the 1.4 series is as good as it is going to get (I don't like what I've seen of 1.5 and have chosen not to be involved in it's development). I now find it more satisfying to maintain my own version of webtrees, which is similar to, perhaps (IMHO) a little better than, 1.4.4.

Please Log in or Create an account to join the conversation.

Last edit: by nigelo.

Fatal errors - Only heading shown. 7 years 5 months ago #7

  • Shemwell
  • Shemwell's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 206
"my own version of webtrees"..... If all the add-ons are compatible, I'm game. Can I give it a shot?, if so where can I download it.

Thanks....
Barry

Please Log in or Create an account to join the conversation.

Fatal errors - Only heading shown. 7 years 5 months ago #8

  • nigelo
  • nigelo's Avatar
  • Visitor
  • Visitor
Contact me offline.

Please Log in or Create an account to join the conversation.

Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 

Fatal errors - Only heading shown. 7 years 5 months ago #9

  • aslanukva
  • aslanukva's Avatar
  • Visitor
  • Visitor
Remowe old modules

Please Log in or Create an account to join the conversation.

Fatal errors - Only heading shown. 7 years 5 months ago #10

  • Archie
  • Archie's Avatar
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 264
I did not remove the old modules :-(
and now I have the same problem:

nuestroarbol.org/arbol/index.php

1) How can I remove the modules a this point? (but I am not sure I can live without the add-on, they are too nice :-)

2) I have a full backup of the previous version, will a replace all files work to go back?
webtrees 1.7.16
@:-)
www.nuestroarbol.org

Please Log in or Create an account to join the conversation.

Fatal errors - Only heading shown. 7 years 5 months ago #11

  • nigelo
  • nigelo's Avatar
  • Visitor
  • Visitor
To delete the modules, just delete their folders from the /modules_v3/ folder. Then once you can get into the Admin pages again you can tidy up their references in the Modules section there.

To revert to an earlier version, delete all files except the /data/ folder and contents, then put back the old files. You need to delete then replace rather than copy as there might be some new files that could cause problems with the old code. That should be all, but I don't know if 1.5 will have changed the database at all, so to be safe replace that with your 1.4.3 backup of that as well.

Contact me at kiwitrees.net if you need to know more about the future of my add-ons.

Please Log in or Create an account to join the conversation.

Fatal errors - Only heading shown. 7 years 5 months ago #12

  • WGroleau
  • WGroleau's Avatar
  • Offline
  • Elite Member
  • Elite Member
  • Posts: 1658

To revert to an earlier version, delete all files except the /data/ folder and contents, then put back the old files.

The new version did not make any database changes?
--
Wes Groleau
UniGen.us/

Please Log in or Create an account to join the conversation.

Fatal errors - Only heading shown. 7 years 5 months ago #13

  • nigelo
  • nigelo's Avatar
  • Visitor
  • Visitor

WGroleau wrote: The new version did not make any database changes?


Dont know. Thats why I said:

That should be all, but I don't know if 1.5 will have changed the database at all, so to be safe replace that with your 1.4.3 backup of that as well.

Please Log in or Create an account to join the conversation.

Fatal errors - Only heading shown. 7 years 5 months ago #14

  • WGroleau
  • WGroleau's Avatar
  • Offline
  • Elite Member
  • Elite Member
  • Posts: 1658
Ha. Guess I too need to read more carefully!
--
Wes Groleau
UniGen.us/

Please Log in or Create an account to join the conversation.

Fatal errors - Only heading shown. 7 years 5 months ago #15

  • Archie
  • Archie's Avatar
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 264
Dear All, thank you for all your answers. I will not have to work on my tree until next weekend. Therefore I have time to evaluate the options.

1) Moving to 1.5.0, which seems to be the path adopted by this site (which I consider the official webtrees), also I wouldn't like to get stuck with an old version. With this I lose the add-ons
2) Going back to 1.4.3, and wait until the future is more clear. I did request my server to be upgraded to PHP 5.3 but I guess it will work.
3) Going back to 1.4.3 and upgrade to the 1.4.4 of this site.
4) Going back to 1.4.3 and upgrade to the non-official version.

I kindly ask your help to evaluate the pros and cons of my choices.
Archie

14 November 2013: Just an update to my own questions: I choose option 3, I restored my backup (no need to database restore as I never used 1.5.0) and I upgraded to 1.4.4. Now I am waiting to see how 1.5.0 goes and hope there is a reconciliation between parties in order to get the beloved add-ons compatible to the newer version.
webtrees 1.7.16
@:-)
www.nuestroarbol.org

Please Log in or Create an account to join the conversation.

Last edit: by Archie.

Fatal errors - Only heading shown. 7 years 3 months ago #16

  • Bogie
  • Bogie's Avatar
  • Offline
  • Premium Member
  • Premium Member
  • Life is good!
  • Posts: 544
When I upgraded to 1.5.1 I received the same error messages although not having installed any old Simpl module.
But I had the Fancy Tree View module 1.0.7 installed.
Deleting the corresponding folder resolved the described problem.
Reinstalling the current FTV also worked.
Up and running now.
Bogie
webtrees 2.0.16 | PHP 7.4.14 | MariaDB 10.5.4 | Apache on Ubuntu 12.5

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum