For issues related to the current stable release please use it's own Help forum.
IMPORTANT:Please read this before using an git or nightly build version: wiki.webtrees.net/en/GIT

Before asking for help please read "How to request help" by clicking on that tab above here.

TOPIC: Unable to connect using this username and password

Unable to connect using this username and password 2 months 3 days ago #1

  • rickkumar
  • rickkumar's Avatar
  • Offline
  • New
  • Posts: 1
Hi. I cannot connect to database. I'm receiving the following msg:

Unable to connect using this username and password. Your server gave the following error.
SQLSTATE[HY000] [1698] Access denied for user 'root'@'localhost'
Check the settings and try again.

But username and password is OK. I tried it on CLI and successfully loggged in. I also tried to change localhost to socket (/var/run/mysqld/mysqld.sock), and I'm receiving the same error message.
MariaDB: 10.1.26-MariaDB-0+deb9u1 Debian 9.1
PHP 7.0.27
latest GIThub version, commit 21d3012

Any idea?Xvideos Xnxx Chaturbate
Last Edit: 2 months 2 days ago by rickkumar.
The administrator has disabled public write access.

Unable to connect using this username and password 2 months 3 days ago #2

  • PeBu
  • PeBu's Avatar
  • Offline
  • New
  • Posts: 9
Maybe the problem is your PHP version, I think you need at least PHP version 7.1
The administrator has disabled public write access.

Unable to connect using this username and password 2 months 3 days ago #3

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 11102
> PHP 7.0.27

As PeBu says, the latest code requires PHP 7.1 or higher

> But username and password is OK. I tried it on CLI and successfully loggged in

I don't know about MariaDB, but the later versions of MySQL *only* allow root to connect from the CLI.
It can't be used for network/socket connections.

What "hostname" did you use for the connection details? "localhost"? "127.0.0.1"? etc.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Unable to connect using this username and password 2 months 2 days ago #4

  • xmlf
  • xmlf's Avatar
  • Offline
  • New
  • Posts: 37
Don't use root connect database.
It is not safe, you can create a new user, connect to the database with a new user.
When creating a new user, be aware that the account's permission comes from the option.
The administrator has disabled public write access.
Powered by Kunena Forum