For issues related to the current stable release please use it's own Help forum.
IMPORTANT:Please read this before using an git or nightly build version: wiki.webtrees.net/en/GIT

Before asking for help please read "How to request help" by clicking on that tab above here.

TOPIC: [SOLVED] Provider updated to php 7 without warning

Provider updated to php 7 without warning 1 month 3 weeks ago #1

  • Capt_Frodo
  • Capt_Frodo's Avatar
  • Offline
  • New
  • Posts: 20
My provider upgraded to PHP7 and I am not able to get into my site to use the webtrees upgrader. (HTTP error 500)

Is there a simple way out of this?

Thanks
The administrator has disabled public write access.

Provider updated to php 7 without warning 1 month 3 weeks ago #2

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 11118
Upgrade manually.

Very easy. 3 steps

1) Download the the .ZIP file for 1.7.14 from github.com/fisharebest/webtrees/releases

2) Unzip the file on your computer.

3) Copy the files to your server using FTP. Overwrite the existing files.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

[SOLVED] Provider updated to php 7 without warning 1 month 3 weeks ago #3

  • Capt_Frodo
  • Capt_Frodo's Avatar
  • Offline
  • New
  • Posts: 20
Problem solved.
The administrator has disabled public write access.

[SOLVED] Provider updated to php 7 without warning 1 month 3 weeks ago #4

  • Capt_Frodo
  • Capt_Frodo's Avatar
  • Offline
  • New
  • Posts: 20
Not quite solved.

Setup Wizard started and I was entering the required fields.

Got to the page for creating the database.

An unexpected database error occurred.

SQLSTATE[42S01]: Base table or view already exists: 1050 Table '"jmarti2_mysql57"."wt_gedcom"' already exists (SQL: create table `wt_gedcom` (`ge...

What now?

Thanks
The administrator has disabled public write access.

[SOLVED] Provider updated to php 7 without warning 1 month 3 weeks ago #5

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 11118
The setup wizard will create the config file (data/config.ini.php) and then create the database.

The error suggests that you do not have a config file, but you do have a populated database.

Not sure how you got into this state. Your options would be:

* If you haven't created any genealogy data, just delete all the database tables and start again.

* If you have created genealogy data that you want to keep, create a config file using the template here: webtrees.github.io/faq/config-ini-php
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.
Powered by Kunena Forum