Before asking for help please read "How to request help" by clicking on that tab above here.
  • Page:
  • 1

TOPIC: [SOLVED] Add-on / Modules compatible for 2.0+

Add-on / Modules compatible for 2.0+ 7 months 1 week ago #1

  • kevyNC
  • kevyNC's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 50
Is there a list of which modules are compatible with webtrees 2.0+?
Also where there are located? It seems most modules/add-on/Themes are only for 1.7x and older
Trying to plan if i need to build reports/modules from scratch

Thanks, Kevin

Please Log in or Create an account to join the conversation.

Add-on / Modules compatible for 2.0+ 7 months 1 week ago #2

  • fisharebest
  • fisharebest's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 12895
Modules written for 1.7 will not work with 2.0. The code is totally different.

Since the code is still changing (slightly), I expect module authors to wait for the final 2.0 release before they work on updated versions.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

[SOLVED] Add-on / Modules compatible for 2.0+ 7 months 1 week ago #3

  • kevyNC
  • kevyNC's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 50
Problem solved.

Please Log in or Create an account to join the conversation.

Add-on / Modules compatible for 2.0+ 7 months 1 week ago #4

  • kevyNC
  • kevyNC's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 50
Thank you. That makes sense -- is there an ETA for when 2.0 when be completed?

Please Log in or Create an account to join the conversation.

Add-on / Modules compatible for 2.0+ 7 months 1 week ago #5

fisharebest wrote: Modules written for 1.7 will not work with 2.0. The code is totally different.

Since the code is still changing (slightly), I expect module authors to wait for the final 2.0 release before they work on updated versions.


My modules are available for 2.x already. I have updated descriptions in the Add-Ons section to indicate this. Is this still the preferred place to list custom modules?
Richard

webtrees 2.0.4 at cissee.de/webtrees2
Custom modules for 1.7.x and 2.x (Extended Relationships, Gov4Webtrees, Shared Places, Compact Themes Adjuster) available at cissee.de

Please Log in or Create an account to join the conversation.

Add-on / Modules compatible for 2.0+ 7 months 1 week ago #6

  • kevyNC
  • kevyNC's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 50
Thanks Richard.

I guess I am little confused when modules say 1.7.x+, if there are truly compatible (at the current time) with 2.0+. Also, if all modules should go in the v4 path or would some still go in the v3 path folder.

Please Log in or Create an account to join the conversation.

Add-on / Modules compatible for 2.0+ 7 months 1 week ago #7

kevyNC wrote: I guess I am little confused when modules say 1.7.x+, if there are truly compatible (at the current time) with 2.0+

Very likely not, unless it's stated explicitly.
As Greg mentioned, modules have to be re-implemented completely for 2.x. The '+' usually only indicates a minimally required (or tested) version.

kevyNC wrote: Also, if all modules should go in the v4 path or would some still go in the v3 path folder.

There is no v3 path in webtrees 2.x, so all 2.x modules go into the v4 path (Putting 1.x modules there won't work unless they somehow support both versions from a single codebase, which again is unlikely).
Richard

webtrees 2.0.4 at cissee.de/webtrees2
Custom modules for 1.7.x and 2.x (Extended Relationships, Gov4Webtrees, Shared Places, Compact Themes Adjuster) available at cissee.de

Please Log in or Create an account to join the conversation.

Last edit: by ric2015.
  • Page:
  • 1
Powered by Kunena Forum