Whilst small files can be uploaded to forum posts, if you have a custom theme or module to contribute please add it on the "Add-ons" page.
  • Page:
  • 1
  • 2

TOPIC: Upgrading

Upgrading 1 month 1 day ago #21

  • tthdoc
  • tthdoc's Avatar
  • Offline
  • New
  • Posts: 21
Thanks, I'll check with them. I also see (found out by accident) that you have the webtrees theme as responsive, and the justblack is not. So it looks lousy on the phone. So I have started over and will use a copy of the webtrees theme as a template and go from there. I did find one issue that maybe you can help me with. You have the header logo webtrees on the left side of the page. I can change it to center on the page by removing float:left and adding margin: 0 auto, and when I look at it on the phone, it is centered on the top of the page. But the custom logo I want to use is the same height, but yours is about 250px width, and mine is about 700px width. So it looks fine on the desktop, but is off the screen on the phone. Is there a way to specify a different logo to use for the header when looking at it on the phone? Or to scale the existing logo when on the phone?

Thanks,
Doc
The administrator has disabled public write access.

Upgrading 1 month 1 day ago #22

  • fisharebest
  • fisharebest's Avatar
  • Online
  • Administrator
  • Posts: 11612
> Is there a way to specify a different logo to use for the header when looking at it on the phone?

Yes. The term you need to google for is "CSS media queries".

You can use different styling on screens with different sizes.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Upgrading 4 weeks 6 hours ago #23

  • tthdoc
  • tthdoc's Avatar
  • Offline
  • New
  • Posts: 21
Thanks Greg. Just one more question. On the statistics page are some pie charts and graphs. How can you change the text colors in these as they appear to be generated images.

Thanks again for all your help,
Doc
The administrator has disabled public write access.

Upgrading 4 weeks 1 hour ago #24

  • fisharebest
  • fisharebest's Avatar
  • Online
  • Administrator
  • Posts: 11612
These are mostly set in app/Stats.php. Look for "googleapi" and the "chco" (chart colour) parameter.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Upgrading 1 week 7 hours ago #25

  • tthdoc
  • tthdoc's Avatar
  • Offline
  • New
  • Posts: 21
Greg,

I finally have all the modifications done and was able to have them take care of the mod security issue. I was able to search and replace /???/ with //, and also did a search on /HARRIS/ and /HARRIS / and found the offending one, but I have a different issue. Here is what the beginning of the surnames show: @N.N., ADLER, BUCKNER.. etc. I tried to do a search and replace on @N.N with no results. Any idea what is causing this first entry?

Thanks,
Doc
The administrator has disabled public write access.

Upgrading 5 days 16 hours ago #26

  • fisharebest
  • fisharebest's Avatar
  • Online
  • Administrator
  • Posts: 11612
> Here is what the beginning of the surnames show: @N.N., ADLER, BUCKNER.. etc

Show where???

@N.N. is used internally to indicate an unknown surname. It gets displayed as "unknown" or "…"

It is used to distinguish between an individual who does not have a surname and an individual
who does have a surname, but it is unknown.

It shouldn't be displayed anywhere.

Maybe trying exporting your tree to a GEDCOM file, and re-importing it.
This will re-build all the search indexes.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Upgrading 5 days 10 hours ago #27

  • tthdoc
  • tthdoc's Avatar
  • Offline
  • New
  • Posts: 21
> Show where???

At the bottom of the statistics box on the main page and My Page. Where is says most common surnames, it says @N.N., Adler, Buckner .. etc.

> Maybe trying exporting your tree to a GEDCOM file, and re-importing it.

I exported the GEDCOM and then reimported it with no change.

I have attached a pic of the page showing what I am seeing.
Attachments:
The administrator has disabled public write access.

Upgrading 4 days 19 hours ago #28

  • tthdoc
  • tthdoc's Avatar
  • Offline
  • New
  • Posts: 21
Greg,

I found the problem and a solution. Apparently it occurred when the /???/ was changed. So I did a search replace for just SURN ??? and found alot of entries. For example, I found a match for I0121 and the raw gedcom showed 1 NAME ROSE //, and also showed 2 SURN ???. When I go to the individual page for I0121, it shows as Surname @N.N. (???). I don't know the reason the @N.N. is showing, as you might know more about that, but I just did a search/replace for 2 SURN ???, which should show everyone who had a name as 1 NAME FirstName /???/ that was changed, and just replace the 2 SURN ??? with blank (so get rid of the 2 SURN field). Now I know for the future not to put ??? in the surname field and just leave it blank.

Doc
Attachments:
Last Edit: 4 days 19 hours ago by tthdoc.
The administrator has disabled public write access.
Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 
  • Page:
  • 1
  • 2
Powered by Kunena Forum