This Help forum is for issues relates to webtrees 1.7. For issues related to webtrees 2.0, please use that forum.
Before asking for help please read "How to request help" by clicking on that tab above here."
  • Page:
  • 1

TOPIC:

New install - stuck on gedcom file import 1 week 4 days ago #1

  • davec
  • davec's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 11
I've installed webtrees on my Centos 8 server running nginx. I had some trouble with SELinux, but I've disabled that now.
I have created a couple of user accounts and one family tree.
I tried uploading a gedcom file (only 900k), but it stuck a 0%. Now, whenever I logon, I am presented with the upload page, still stuck at 0% and none of the links work. The page just flashes up 'calculating' near the upload bar, the returns to 0%. I have even rebooted the server, but it still does the same.

Any ideas how I can get out of this?

Please Log in or Create an account to join the conversation.

New install - stuck on gedcom file import 1 week 4 days ago #2

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13603
> but it stuck a 0%

I guess it is waiting for a server response, which either gives an error or times-out.

See webtrees.net/faq/xhr/ for instructions on how to see more details

But if you don't care about this, and just want to terminate the import process, you need to delete all rows from the table wt_gedcom_chunk.
This table contains the queue of data to import.

If that fails, update the entry in the table wt_gedcom_setting for "imported" to "1"
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

New install - stuck on gedcom file import 1 week 4 days ago #3

  • davec
  • davec's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 11
Well, I did that (had to delete all rows and set imported to "1") and it cleared the error, but it just happened again when I tried to reload it again.
The xhr output showed no errors.

Please Log in or Create an account to join the conversation.

New install - stuck on gedcom file import 1 week 3 days ago #4

  • davec
  • davec's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 11
I started again.
New install of CentOS 8, SELinux disabled, nginx, mariadb, php-fpm all installed. Webtrees installed and I can upload a gedcom file. However, adding users gives me a JSON error:
DataTables warning: table id=DataTables_Table_0 - Invalid JSON response. For more information about this error, please see datatables.net/tn/1
The XHR response is empty - "The request has no response data available."
I tried again with a new install from scratch, this time using MySQL instead of mariadb - same problem.
In case this helps, I'm running webtrees 1.7.17, MySQL 8.0.21 and PHP 7.2.24.

Please Log in or Create an account to join the conversation.

Last edit: by davec. Reason: adding component version numbers

New install - stuck on gedcom file import 1 week 3 days ago #5

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13603
> The XHR response is empty

What is the HTTP status code for this response? 500?

Are there any error messages in the webserver error log or the webtrees error log?
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

New install - stuck on gedcom file import 1 week 3 days ago #6

  • davec
  • davec's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 11
nginx access log from clicking on 'User Administration':
192.168.1.88 - - [18/Oct/2020:18:17:40 +0100] "GET /webtrees/admin_users.php HTTP/1.1" 200 12621 " webtrees.local/webtrees/admin.php " "Mozilla/5.0 (X11; CrOS x86_64 13421.53.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.77 Safari/537.36" "-"
192.168.1.88 - - [18/Oct/2020:18:17:40 +0100] "POST /webtrees/admin_users.php?action=load_json HTTP/1.1" 200 5 " webtrees.local/webtrees/admin_users.php " "Mozilla/5.0 (X11; CrOS x86_64 13421.53.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.77 Safari/537.36" "-"
192.168.1.88 - - [18/Oct/2020:18:17:40 +0100] "POST /webtrees/admin_users.php?action=load_json HTTP/1.1" 200 5 " webtrees.local/webtrees/admin_users.php " "Mozilla/5.0 (X11; CrOS x86_64 13421.53.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.77 Safari/537.36" "-"

Nothing in the nginx error log for these calls.

I can't view the webtree error log from the web site UI as it gives me the same error.

I found this in the wt_log table:
error | /usr/share/nginx/html/webtrees/admin_users.php:251 Call to undefined function Fisharebest\Webtrees\json_encode()

Please Log in or Create an account to join the conversation.

Last edit: by davec. Reason: add wt_log entry (second update for typo!)

New install - stuck on gedcom file import 1 week 3 days ago #7

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13603
> I can't view the webtree error log from the web site UI as it gives me the same error.

Look directly in the database? The table wt_log
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

New install - stuck on gedcom file import 1 week 3 days ago #8

  • davec
  • davec's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 11
Sorry, I added this to the last reply:

I found this in the wt_log table:
error | /usr/share/nginx/html/webtrees/admin_users.php:251 Call to undefined function Fisharebest\Webtrees\json_encode()

Please Log in or Create an account to join the conversation.

Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 

New install - stuck on gedcom file import 1 week 3 days ago #9

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13603
> error | /usr/share/nginx/html/webtrees/admin_users.php:251 Call to undefined function Fisharebest\Webtrees\json_encode()

Sorry - should have read the rest of the message before replying.

Version of PHP? What PHP libraries are installed? I think you are missing a library, and I think it is different on different PHP versions. (Can't check right now).
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

New install - stuck on gedcom file import 1 week 3 days ago #10

  • davec
  • davec's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 11
I'm running webtrees 1.7.17, MySQL 8.0.21 and PHP 7.2.24.

Please Log in or Create an account to join the conversation.

New install - stuck on gedcom file import 1 week 3 days ago #11

  • davec
  • davec's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 11
I found it - installed php-json and my user admin page is now working.

Thanks again for your help fisharebest

Please Log in or Create an account to join the conversation.

Last edit: by davec.
  • Page:
  • 1
Powered by Kunena Forum