Before asking for help please read "How to request help" by clicking on that tab above here.
  • Page:
  • 1

TOPIC:

Default language 5 months 2 weeks ago #1

  • danfour
  • danfour's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 2
I do a fresh install of webtrees.

I set Arabic language as default in the GEDCOM config page.

When I'm logged the language is Arabic, but when I logged out the language is changed to English.

There is no possibility to set Arabic as default language to non logged users.

Please Log in or Create an account to join the conversation.

Default language 5 months 2 weeks ago #2

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13196
webtrees will use the default language set in your browser.

You can see this in webtrees.
Control panel -> Server information -> $_SERVER 'HTTP_ACCEPT_LANGUAGE'

> when I logged out the language is changed to English.

I guess that your browser is set to prefer English...

What value do you have for HTTP_ACCEPT_LANGUAGE?

> There is no possibility to set Arabic as default language to non logged users.

Correct. Every user gets the language that they choose.

The default is only used by search engines, such as google.
Search engines do not use HTTP_ACCEPT_LANGUAGE.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Last edit: by fisharebest.

Default language 5 months 2 weeks ago #3

  • danfour
  • danfour's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 2
HTTP_ACCEPT_LANGUAGE fr-FR,fr;q=0.9,en-US;q=0.8,en;q=0.7,ar;q=0.6
Attachments:

Please Log in or Create an account to join the conversation.

Default language 5 months 2 weeks ago #4

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13196
I guess your browser has selected 5 languages, in this order.

fr-FR
fr
en-US
en
ar

French is the highest priority
Arabic is the lowest priority
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Default language 2 weeks 2 days ago #5

Hello Greg,

Any solution to force the default language?
I have same problem like danfour.

Chrome:
HTTP_ACCEPT_LANGUAGE en-US,en;q=0.9,hu-HU;q=0.8,hu;q=0.7
IE:
HTTP_ACCEPT_LANGUAGE hu-HU

I understand that it is a browser setting "problem", but I hope we have an option to make the desired language as default anyway.

Thank you in advance.


Forget it, sorry.

Please Log in or Create an account to join the conversation.

Last edit: by RegElek.
  • Page:
  • 1
Powered by Kunena Forum