Before asking for help please read "How to request help" by clicking on that tab above here.

TOPIC: [SOLVED] Add media

Add media 2 weeks 2 days ago #1

  • mobrid
  • mobrid's Avatar
  • Offline
  • New
  • Posts: 17
I just installed version 1.7.16 and have imported data via GEDCOM import. I have unsuccessfully tried to add JPG files to existing rows, but it keeps coming back with a blank screen. I transferred some JPG files using the webtrees admin function. I then tried to link the media files but it cannot find them no matter if I add the path name or not. I have looked through the "documentation" and there is nothing telling me how to accomplish this task. Does anyone have any helpful hints?
The administrator has disabled public write access.

Add media 2 weeks 1 day ago #2

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 12560
> it keeps coming back with a blank screen.

See webtrees.net/faq/500/

> I then tried to link the media files but it cannot find them no matter

Tell us exactly what you did. Maybe post some screen shots. It is probably something obvious - but hard to guess without knowing what you are seeing/doing.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Add media 2 weeks 1 day ago #3

  • mobrid
  • mobrid's Avatar
  • Offline
  • New
  • Posts: 17
How can I embed the screenshot into my reply?
The administrator has disabled public write access.

Add media 2 weeks 1 day ago #4

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 12560
When you reply to a message, you should see an option to upload a file, and then insert it in your message.

Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Add media 2 weeks 1 day ago #5

  • mobrid
  • mobrid's Avatar
  • Offline
  • New
  • Posts: 17
That's the problem, I've been using Quick Reply and that option doesn't appear.

Here's what I've done.

Install 1.7.16
Import GEDCOM file
Clicked My Pages, then selected Control Panel
Clicked Media and selected Upload Media
Verified the media loaded using File Manager on the goDaddy cPanel, /home/q07kxoz0hgin/public_html/data/media



Clicked My Page
Displayed my father's record
Clicked the Media tab
Clicked Add a Media Object
This is the screen that is displayed:


So I close it and click Link to an existing media object
Enter CharlesBridges.jpg into the box and click link
This is what is returned:



No matter what I enter into the filename box I get the same result.
The administrator has disabled public write access.

Add media 2 weeks 22 hours ago #6

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 12560
A "media file" is just the .JPEG file on disk

A "media object" is an entry in your genealogy data. It includes a title, notes, etc., plus of course the name of the media file.

So, here you need to add a new media object (not link to an existing one).

When you add a new media object, you should be given the choice of uploading a file,
or selecting one that you previously copied to the server using FTP.

Your screenshot shows that "Add media" page with a blank page.

Is that *before* you enter any information, or *afterwards*?

Note - a blank page indicates that a fatal server error occured, and that your server is configured not to display the errors.
If you control your server configuration, (e.g. using a PHP.INI file or a .HTACCESS file), then set display_errors=On
Even when not displayed, fatal errors should be written to a log file on the server. If you have access to this, then
knowing the error message would help enormously.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Add media 2 weeks 3 hours ago #7

  • mobrid
  • mobrid's Avatar
  • Offline
  • New
  • Posts: 17
It is before I have any opportunity to enter anything! I click "add media" and a new tab that is completely blank (except for url) opens. I don't know how I can be any more explicit about that.

I tried modifying. htaccess to display all php errors, and nothing is logged. I tried to modify php.ini to display all errors and nothing is logged. Even before modifying. htaccess and php.ini nothing was logged. I then intentionally misspelled the entries to display errors and an error line was logged saying I misspelled it. So I know I'm entering it in the correct t file. Nothing I have tried has resu5in being able to add pictures to any existing person. I haven't tried creating a new fake person and adding a media file to it but that is my last possible experiment.
The administrator has disabled public write access.

Add media 2 weeks 3 hours ago #8

  • mobrid
  • mobrid's Avatar
  • Offline
  • New
  • Posts: 17
It is before I have any opportunity to enter anything! I click "add media" and a new tab that is completely blank (except for url) opens. I don't know how I can be any more explicit about that.

I tried modifying. htaccess to display all php errors, and nothing is logged. I tried to modify php.ini to display all errors and nothing is logged. Even before modifying. htaccess and php.ini nothing was logged. I then intentionally misspelled the entries to display errors and an error line was logged saying I misspelled it. So I know I'm entering it in the correct t file. Nothing I have tried has resu5in being able to add pictures to any existing person. I haven't tried creating a new fake person and adding a media file to it but that is my last possible experiment..

Until then, here is the generated html

The administrator has disabled public write access.
Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 

Add media 1 week 5 days ago #9

  • mobrid
  • mobrid's Avatar
  • Offline
  • New
  • Posts: 17
Changing to PHP version 7.3 made everything work!
The administrator has disabled public write access.

[SOLVED] Add media 1 week 5 days ago #10

  • mobrid
  • mobrid's Avatar
  • Offline
  • New
  • Posts: 17
Problem solved.
The administrator has disabled public write access.
Powered by Kunena Forum