Before asking for help please read "How to request help" by clicking on that tab above here.
  • Page:
  • 1

TOPIC: unable to upload media objects

unable to upload media objects 1 month 1 week ago #1

  • df23
  • df23's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 7
I have just upgraded to v2.0.3 and i am now unable to upload media objects. When i click on the SAVE button nothing happens, there is no error message displayed.

When running v1.7.16 my media folder was outside of /data so was configured as ../media. I have changed this to /media and moved the folder to be under data. Existing media items are displayed correctly.

Does anyone have any ideas on what the issue may be?

thanks
Dave

Please Log in or Create an account to join the conversation.

unable to upload media objects 1 month 1 week ago #2

  • fisharebest
  • fisharebest's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 12929
Are there any error messages in the webtrees error log?

Control panel -> Website -> Website logs
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

unable to upload media objects 1 month 1 week ago #3

  • df23
  • df23's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 7
The only ones i can see since i changed the media folder location are
Cannot create thumbnail Impossible to create the root directory "data/thumbnail-cache/62933a2951ef01f4eafd9bdf4d3cd2f0/filename.jpg".
and
Site preference "next_xref" set to "3" (also logged with "2")

The timestamps don't seem to match when i was attempting to upload a new media item.
I have tried to upload jpg, png and mp4
I am logged in as administrator

thanks
Dave

Please Log in or Create an account to join the conversation.

unable to upload media objects 1 month 1 week ago #4

  • fisharebest
  • fisharebest's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 12929
None of those messages seem relevant.

It is possible that when you click "save", a request is sent to the server, which gives an error response.

There are instructions here for finding error messages in such responses.
webtrees.net/faq/xhr/

Can you see if there is anything here?
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

unable to upload media objects 1 month 1 week ago #5

  • df23
  • df23's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 7
I see a
200 GET followed by 403 POST both on file /index.php?route=/tree/dgf3.GED/create-media-object
i have checked the permissions on folders
data = 0750
data/media = 0755
data/media/thumbs = 0755

Please Log in or Create an account to join the conversation.

unable to upload media objects 1 month 1 week ago #6

  • fisharebest
  • fisharebest's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 12929
The "200 GET" is when the form loads into the window.
The "403 POST" is when you save the form - and 403 means access denied.

There is no obvious reason why the code would send a 403 response.

There is, presumably, something different/unusual about your site/setup/config/server/etc.

Are you uploading a file, or choosing an existing file? Do both options give the same error?
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

unable to upload media objects 1 month 1 week ago #7

  • df23
  • df23's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 7
I have just tried using an existing media item and that works fine (of course this is done on a different screen to the add media).
I have also deleted all the cookies in case there was some hang over from before i moved the media folder but that has not made any difference. As i said, it was working fine on v1.7.16 and the existing items continue to be displayed so looks to be a difference in add media function in v2 that is triggering it somehow.

Dave

Please Log in or Create an account to join the conversation.

unable to upload media objects 1 month 1 week ago #8

  • df23
  • df23's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 7
I have also checked the ownership and security on the files to be uploaded and that is no different to files that i have previously uploaded successfully, owned by me and permission is -rwxrwxr-x

Please Log in or Create an account to join the conversation.

Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 

unable to upload media objects 1 month 1 week ago #9

  • df23
  • df23's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 7
The file i am trying to upload is one i have downloaded from a website so i tried to create the media item from the website URL and that failed with the same error.
However if i upload the file into data/media and then create the media item from the server that worked successfully

Dave

Please Log in or Create an account to join the conversation.

unable to upload media objects 1 month 1 week ago #10

  • fisharebest
  • fisharebest's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 12929
> I have just tried using an existing media item and that works fine (of course this is done on a different screen to the add media).

It should be the *same* page.

The create-media-object form gives you both options.
Change the first input field to select a file on the server.





I am trying to find out whether your problem exists in the "upload" part of the code, or the "create" part of the code.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by fisharebest.

unable to upload media objects 1 month 1 week ago #11

The upload media page has been less than friendly to new users. It is recommended to change the page style to wordpress, using tab to distinguish whether to upload or select media library.

Wang Family Website of Suining County, China
https://www.snwsjz.com
A family tree website that is customized, more humanized and convenient for users.
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by xmlf.

unable to upload media objects 1 month 1 week ago #12

  • df23
  • df23's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 7
Thanks Greg

FYI on that screen i have left everything as default, so file to be in the root media folder and using the filename (which has no spaces in it). I have not set any permissions (leaving blank). Only thing i have entered after selecting the source and identifying the file to upload is the Title.

Dave

Please Log in or Create an account to join the conversation.

unable to upload media objects 2 weeks 4 days ago #13

Hello - I am also experiencing this issue as described in the thread... XHR shows 403 forbidden errors. Folder permissions are 777 on /data, and 755 on both /data/media and /data/media/thumbs. Should I start a new thread, or can I add any additional information that would be helpful?

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum