Before asking for help please read "How to request help" by clicking on that tab above here.
  • Page:
  • 1
  • 2

TOPIC: cURL error when upgrading to new version 2.0.4

cURL error when upgrading to new version 2.0.4 5 days 8 hours ago #21

>This is a direct link between two data-centres that are (relatively) close geographically.

How do you mean?
Isn't it a request from my server in my corner of the world, to wherever the github datacentre is?

Please Log in or Create an account to join the conversation.

cURL error when upgrading to new version 2.0.4 5 days 8 hours ago #22

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 12924
> Isn't it a request from my server in my corner of the world, to wherever the github datacentre is?

Nope. GitHub use amazon S3 for content distribution.

If you do a command-line fetch on the download URL, you'll see that you are redirected to an amazon AWS url. It knows your IP address, and so will direct you to whichever amazon data centre is nearest you.

--edit

Here's what happens when I try to download the file. US-east isn't actually my closest datacentre - but it is probably the closest one with a copy of the file.

$ wget github.com/fisharebest/webtrees/releases...4/webtrees-2.0.4.zip
--2020-05-22 16:22:39-- github.com/fisharebest/webtrees/releases...4/webtrees-2.0.4.zip
Resolving github.com (github.com)... 140.82.118.4
Connecting to github.com (github.com)|140.82.118.4|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: github-production-release-asset-2e65be.s...ation%2Foctet-stream [following]
--2020-05-22 16:22:39-- github-production-release-asset-2e65be.s...ation%2Foctet-stream
Resolving github-production-release-asset-2e65be.s3.amazonaws.com (github-production-release-asset-2e65be.s3.amazonaws.com)... 52.216.84.80
Connecting to github-production-release-asset-2e65be.s3.amazonaws.com (github-production-release-asset-2e65be.s3.amazonaws.com)|52.216.84.80|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 30263235 (29M) [application/octet-stream]
Saving to: 'webtrees-2.0.4.zip'

webtrees-2.0.4.zip 100%[=========================================================================>] 28.86M 16.4MB/s in 1.8s

2020-05-22 16:22:41 (16.4 MB/s) - 'webtrees-2.0.4.zip' saved [30263235/30263235]

Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Last edit: by fisharebest.

cURL error when upgrading to new version 2.0.4 5 days 8 hours ago #23

Well, the numbers are what they are, and I have really good internet otherwise. I don't know, but I'm sure I'm not the only one.
I wasn't even the OP in this thread. I'm sure an easy way to download it via other means and upload to webtrees would not go amiss.

Last thing, could you please help with my last question:

So I made the changes above, and everything worked.
Went to revert after it all worked, and realized that I was the dumb who forgot to note the original values :/
Does
php.ini
max_execution_time = 60

www.conf
;request_terminate_timeout = 30
*note the ; preceding the line

Seem like they are reasonable defaults for me to use? I'm pretty sure that's what they originally were.

Please Log in or Create an account to join the conversation.

cURL error when upgrading to new version 2.0.4 5 days 8 hours ago #24

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 12924
> Well, the numbers are what they are, and I have really good internet otherwise.

This is nothing to do with *your* internet connection.
It is the connection between your server and another server.

(Unless your server is at your house, in which case, you upgrade by simply copying the files...)

60 seconds is a reasonable PHP time limit.

I generally go for 55 - so that any time-out messages are sent back via nginx (which has a 60 second timeout).

> *note the ; preceding the line

The semicolon indicates that the line is a comment - and presumably the default.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

cURL error when upgrading to new version 2.0.4 5 days 8 hours ago #25

The server is at my house.
I could have loaded them manually, but I wasn't sure where or how to make those database changes mentioned way earlier.

>via nginx (which has a 60 second timeout).

Where does this setting live?

Please Log in or Create an account to join the conversation.

cURL error when upgrading to new version 2.0.4 5 days 8 hours ago #26

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 12924
Either /etc/nginx/nginx.conf or your vhost definition.
This was covered in the link you posted, titled "504 gateway time"
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

cURL error when upgrading to new version 2.0.4 5 days 8 hours ago #27

Oh, you're talking about one of
proxy_connect_timeout 600;
proxy_send_timeout 600;
proxy_read_timeout 600;
send_timeout 600;

Right. They weren't there originally, I added them in, so didn't know what the defaults were or should have been.
So now that I've removed them again, it's back to 60 seconds? Ok, thank you

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Powered by Kunena Forum