Before asking for help please read "How to request help" by clicking on that tab above here.

TOPIC:

Spinning wheel forever 1 month 1 week ago #1

  • Dave
  • Dave's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 24
Just upgraded to WT 2.0.4. Without logging in, when I open the main page, or when I click the Family Tree icon, I get a spinning wheel and the page info never shows up. Happens on any browser. If I log in, this doesn't occur and the info shows up quickly.

Apache/2.4.29 (Ubuntu 18.04)
MYSQL 5.7.30-0ubuntu0.18.04.1
PHP version: 7.4.6
Attachments:

Please Log in or Create an account to join the conversation.

Spinning wheel forever 1 month 1 week ago #2

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13196
webtrees is loading a block of data into this space.

If the spinner does not go away, then either:

a) the code that generates it gave a fatal error (non-fatal errors should be displayed).
b) the code timed out. When you log in as admin, you bypass all of the privacy checks, which can be slow.

If you'd posted the URL of your site, I'd have been able to quickly investigate and give more information.
If you are unable to share the URL, then the instructions at webtrees.net/faq/xhr/ might help you.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Spinning wheel forever 1 month 1 week ago #3

  • Dave
  • Dave's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 24
Thanks for the reply... Website is:
dlr.dns1.us/webtrees/

Please Log in or Create an account to join the conversation.

Spinning wheel forever 1 month 1 week ago #4

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13196
Have a look in the webtrees log (Control panel -> Website logs).
Have a look in your webserver (Apache) error logs.
Any interesting/relevant messages there?

What sort of block is it?

You say the block loads when logged in as an administrator.
Does it work as a regular user?
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Spinning wheel forever 1 month 1 week ago #5

Greg, I wonder if this might be related to what we are looking at - if he can get the server information page that might be revealing.
John Elvin

Please Log in or Create an account to join the conversation.

Spinning wheel forever 1 month 1 week ago #6

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13196
My gut feeling is that this is a different problem.

His site works fine when logged in. Visitors require additional processing for privacy calculations.

Your site has the same problems when logged in/out.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Spinning wheel forever 1 month 1 week ago #7

  • Dave
  • Dave's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 24
Everything works fine logged in as any user. When logging out, the page displays the spinner.Nothing out of the ordinary in the Webserver log, just the Auth records.I've attached today's entries from the Apache log.

File Attachment:

File Name: log.txt
File Size:36 KB
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by makitso.

Spinning wheel forever 1 month 1 week ago #8

  • Dave
  • Dave's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 24
Any news on this?
Could it be a PHP issue somewhere? What are the required PHP extensions? Any specific PHP settings?

Please Log in or Create an account to join the conversation.

Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 

Spinning wheel forever 1 month 1 week ago #9

What should be in the block where you have the spinning wheel?
John Elvin

Please Log in or Create an account to join the conversation.

Spinning wheel forever 1 month 1 week ago #10

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13196
It's for the statistics block.

Interestingly, it loaded for me - after 32 minutes!
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Spinning wheel forever 1 month 1 week ago #11

I didn't time it but can confirm it came up eventually.

@Dave I presume that when you say it comes up when you are logged in, you are logging in as administrator or as a manager. Have you any users configured where they don't have permission to view living individuals, because if Greg is correct logging as a user like that would be similarly slow. With over 10,000 individuals that is going to take some time to process.
John Elvin

Please Log in or Create an account to join the conversation.

Spinning wheel forever 1 month 1 week ago #12

  • Dave
  • Dave's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 24
My account is the only Admin account. One other is a Manager. All others are Members... They are all family members and have unrestricted access to the whole tree. Regardless of which one of those accounts that logs in, the page info is displayed almost immediately.

I have set up a Test account which is a Visitor, restricted to 2 generations of my ancestors. When logging in with that account, I get "You do not have permission to view this page". Any account that is set as Visitor gets that same warning.
As a side note, when I created that account, I never received a confirmation email...

Please Log in or Create an account to join the conversation.

Spinning wheel forever 1 month 1 week ago #13

If you did that by using the Masquerade as this user option that is normal as it leaves you on the same admin page which obviously you don't now have permission to view. Having got the error you need to click on My Page.
John Elvin

Please Log in or Create an account to join the conversation.

Spinning wheel forever 1 month 1 week ago #14

  • Dave
  • Dave's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 24
I did not use Masquerade. Logged out of one account, logged in to the other.

Please Log in or Create an account to join the conversation.

Spinning wheel forever 4 weeks 15 hours ago #15

  • Dave
  • Dave's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 24
Updated to WT 2.0.5 and the spinning wheel is still there...

Please Log in or Create an account to join the conversation.

Spinning wheel forever 3 weeks 5 days ago #16

  • Dave
  • Dave's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 24
Actually, the pages displayed after logging in, regardless of the account, don't have the Statistics block. So, when not logged in, or when going to the Family Tree page when logged in, the spinner is there because the Statistics block is present.

Please Log in or Create an account to join the conversation.

Spinning wheel forever 3 weeks 5 days ago #17

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13196
If we assume that there is an SQL query from this block that is running for an extended period, then it should be easy to find.

While the page is loading, run this SQL command using phpMyAdmin or similar:

SHOW FULL PROCESSLIST;

This will tell you the SQL that is being executed, and the time it has spent running.

If you can identify this long-running query, post it here?
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Spinning wheel forever 3 weeks 5 days ago #18

  • Dave
  • Dave's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 24
Ran the command in phpmyadmin. I ran it multiple times while the wheel spun... Same results each time. Results attached.

File Attachment:

File Name: list.txt
File Size:1 KB
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by makitso.

Spinning wheel forever 3 weeks 5 days ago #19

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13196
@Dave - I can't see the attachment. Maybe an issue with the forum software.

If this is text, copy/paste it into your message.
If it is a screendump, make sure the file has an extension (.jpg, .png, etc.)
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Spinning wheel forever 3 weeks 5 days ago #20

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13196
The statistics block has options to hide/show each of the statistics.

Can you disable them all. Does this block show?
If yes, then enable them one at a time. Which one causes the problem?
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum