Before asking for help please read "How to request help" by clicking on that tab above here.
  • Page:
  • 1

TOPIC:

error report 3 weeks 6 days ago #1

  • rsbarreiro
  • rsbarreiro's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 32
When I enter the family guide of a person who has many relatives with photos. An error occurs with some thumbnails. Even reloading the page the error persists. the error accuses the parameter "max_user_connections" (see attached print), however, I am the only person accessing the page (according to google analytics, the statistics on my provider and also because I have not yet released the page to the family) ...

My provider is "Hostinger" ... I have already seen the thumbnail faq page and I have both GD and Imagick enabled, php version 7.3.
From what I saw in the server settings panel that parameter "max_user_connections" is set to 20 and I am not allowed to increase ...

In google searches I found a Laravel documentation page that says that the number equivalent to the number of processor cores is enough for infinite users ... I believe that somewhere it is necessary to reuse the connection, or close it, or just "empty" cursors. I'm a programmer but I don't have knowledge in PHP (just the basics) and even less in MySQL (I'm more familiar with Oracle).

* translated by Google
Attachments:

Please Log in or Create an account to join the conversation.

error report 3 weeks 6 days ago #2

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13196
> From what I saw in the server settings panel that parameter "max_user_connections" is set to 20

max_user_connections is a MySQL parameter.

Do you have access to your database, e.g. using phpMyAdmin?
Can you run this SQL query, which will display current value of this setting.
show variables like 'max_user_connections';

> I believe that somewhere it is necessary to reuse the connection, or close it, or just "empty" cursors.

webtrees makes only one database connection per request.

But you can have many requests in parallel.
For example, in your screendump, the page will be fetching all the thumbnail images in parallel.
Your browser will usually limit to 6 parallel connections.
Perhaps your database only allows 5 connections?
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

error report 3 weeks 5 days ago #3

  • rsbarreiro
  • rsbarreiro's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 32
as i said before, i am not allowed to change the value of the attribute "max_user_connections" which is set to 20 (see the image of my phpMyAdmin editing attempt - the image is in Portuguese, the error text was "Access is denied. You need the SUPER privilege for this operation ") ...

I looked in my provider's faq and got the following returns:
www.hostinger.com/how-to/how-many-mysql-...low-at-the-same-time (it says 15 but is 20, the faq can be old)
www.hostinger.com/how-to/i-get-user-xxx-...-connections-message ...

* translated by Google
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by rsbarreiro.

error report 3 weeks 5 days ago #4

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13196
When you get this error, run this command to see the connections:

SHOW PROCESSLIST;

If there are 20 processes, you should see them here.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Last edit: by fisharebest.

error report 3 weeks 5 days ago #5

  • rsbarreiro
  • rsbarreiro's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 32

fisharebest wrote: When you get this error, run this command to see the connections:

SHOW PROCESSLIST;

If there are 20 processes, you should see them here.


This command shows the current user's connections. But the user I have access to within phpMyAdmin is not the user I have access to within the PHP application (some strange rule from the provider). I don't have access to the configuration file to modify the user connected to phpMyAdmin (and I haven't found a way to change the user connected via query on the web). So, when I execute the command I see only the execution call itself ...

I'll take the question to the provider's support to see if there is any way to increase the parameter "max_user_connections" or at least let me enter phpMyAdmin with the same connection user used in webtrees to be able to track what is running ...

Then I update here with what they answer ...

Thanks for the helpfulness and patience ;-)

*translated by Google

Please Log in or Create an account to join the conversation.

solved 2 weeks 4 days ago #6

  • rsbarreiro
  • rsbarreiro's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 32
my provider did not help at all.
but after the 2.0.6 update the error stopped occurring.
some vesta modules are showing an error, but I think it's only a matter of time before they release a new version ...

*translated by Google

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum