Before asking for help please read "How to request help" by clicking on that tab above here.
  • Page:
  • 1

TOPIC:

PlaceLinks 1 week 3 days ago #1

  • apatani
  • apatani's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 4
I am not sure how or when (during one of the upgrades?) links of individuals to places disappeared from the wt_placelinks table in the database. I found this by trying to understand why records of some individuals were not showing up in the place hierarchy and associated maps. I was able to restore the links by doing a searching for the place name and replacing them with the same character string in the control panel..

I am not sure how many other links are broken for other individuals in my family tree.I assume exporting and re-importing the GEDCOM would fix this but is their any other way of identifying what links may be broken? I have a pretty large family tree and it was just by chance that I found the issue with this one place.It would be nice if there was some way to auto check and fix issues like this.

Thanks. Needless to say, I think Webtrees is terrific and I greatly appreciate the effort you folks are putting into its development.

Please Log in or Create an account to join the conversation.

PlaceLinks 1 week 3 days ago #2

  • bertkoor
  • bertkoor's Avatar
  • Offline
  • Gold
  • Gold
  • Greetings from Utrecht, Holland
  • Posts: 1934
I have no idea how it could have happened. Basically it shouldn't. But there is an easy fix: export to GEDCOM and import it again. That will surely rebuild all derived data structures and indices like this one.
stamboom.BertKoor.nl runs on webtrees v1.7.13

Please Log in or Create an account to join the conversation.

PlaceLinks 1 week 3 days ago #3

  • apatani
  • apatani's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 4
Thanks. That was easy and a good way to fix the links..

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum