Before asking for help please read "How to request help" by clicking on that tab above here.
  • Page:
  • 1
  • 2

TOPIC:

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 1 day ago #1

  • cornell
  • cornell's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 16
Apparently, I'm still at 1.3.2. Which is to say that I've a zip with that version in the name, and my site, running PHP 7.0 and above does not play well with 1.3.2. The php files are no younger than 2012. I'd ask, is there a way to look at the files and determine the version, perhaps a file that says what it is?

I know, I've been bad, not upgrading as I should.

So, what is the highest version to which I can upgrade from 1.3.2, in one "step"?

And what's the best way to protect my data during the upgrade?

Please Log in or Create an account to join the conversation.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 1 day ago #2

  • bertkoor
  • bertkoor's Avatar
  • Offline
  • Platinum
  • Platinum
  • Greetings from Utrecht, Holland
  • Posts: 2110
To check which version you're at, open a webtrees page of your site in a browser and press F12 to view the raw html. At the bottom there's a comment section stating the version.

Since you're on PHP7.0 you could upgrade to the latest 1.7.x.
If you never added any customizations (theme, modules, translations) it's likely to go flawless.
Up to 1.3 there was a Media Firewall. You should probably disable that first.
webtrees.net/upgrade/media-firewall/

The handling of media was the biggest hurdle I can remember, otherwise upgrades always went smooth.

Protect your data by:
1. make a GEDCOM export (most of your work is in there)
2. make a SQL database backup (containing the GEDCOM data as well plus all settings & user administration)
3. copy folders like "data" and "media" (containing things not stored in the database)
stamboom.BertKoor.nl runs on webtrees v1.7.13

Please Log in or Create an account to join the conversation.

Last edit: by bertkoor.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 1 day ago #3

  • cornell
  • cornell's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 16

bertkoor wrote: To check which version you're at, open a webtrees page of your site in a browser and press F12 to view the raw html. At the bottom there's a comment section stating the version.

Since you're on PHP7.0 you could upgrade to the latest 1.7.x.
If you never added any customizations (theme, modules, translations) it's likely to go flawless.
Up to 1.3 there was a Media Firewall. You should probably disable that first.
webtrees.net/upgrade/media-firewall/

The handling of media was the biggest hurdle I can remember, otherwise upgrades always went smooth.

Protect your data by:
1. make a GEDCOM export (most of your work is in there)
2. make a SQL database backup (containing the GEDCOM data as well plus all settings & user administration)
3. copy folders like "data" and "media" (containing things not stored in the database)



Thank you for your response, but I'm unable to access webtrees. The PHP version is too high. When I go to the page, I get an HTTP 500, that the server can't deal with the page. I don't even get the webtrees error page.

The lowest PHP I can get is 7.0.33. Perhaps I can do a "flawless" upgrade to 1.7.x, and from there get it operational enough to export a GEDCOM.

I can't use any webtree browser functions, only basic file functions on the server, through an admin page. So I can copy files and directories, basic edits, and of course, view contents. I can't use MySQL on the server, at least not that I've figured out yet. Though I may be able to use it locally and connect to the remote database on the server, if I can figure out how to get there from here.

It strikes me that databases are simply one form of one or more files. Could one do file copies to a safe place, and, if needed, copy them back, would MySQL find them again and consider them a database?

=======
Ah, hoster has responded with how to access MySQL database, using phpMyAdmin, using my regular administrative credentials. He's included a link to it on the site. So that leaves only the problem of exporting a GEDCOM.

I observe there is a file GEDCOM in the directories, is that automatically kept current, could I just copy it?

Please Log in or Create an account to join the conversation.

Last edit: by cornell.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 1 day ago #4

  • cornell
  • cornell's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 16
Ah, hoster has responded with how to access MySQL database, using phpMyAdmin, using my regular administrative credentials. He's included a link to it on the site. So that leaves only the problem of exporting a GEDCOM.

I observe there is a file GEDCOM in the directories, is that automatically kept current, could I just copy it?

(Don't see how to delete a post)

Please Log in or Create an account to join the conversation.

Last edit: by cornell.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 1 day ago #5

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13716
> is that automatically kept current

No.

Assuming your 1.3.2 site is still functioning, use the "export" option in the control panel to update the file.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 21 hours ago #6

  • cornell
  • cornell's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 16
Ok, upgraded... sort of, to 1.7.17. I've done a backup of the database, via phpMyAdmin, and copied the whole directory to a backup location. I've also associated the directory with PHP 7.0.33.

So, when I go to my site, I get:
  • SQLSTATE[22007]: Invalid datetime format: 1292 Incorrect datetime value: '0000-00-00 00:00:00' for column 'created' at row 23
It suggests I check data/config.ini.php, which does have the correct credentials and all (with the possible exception of dbport, I don't know how to confirm that. However, it seems from the error message that I'm getting to the database, it's just not liking what it's finding.

I'm guessing that some table has an attribute "created" which contains zeroes. Great help, how many tables are there and how many have an attribute "created"?

Well, scampering down the list of tables, in phpMyAdmin, the first one I find with a "created" attribute is wt_message. And the 25th row has zeroes. So I changed it to something legitimate, retried and... same error. Different line. Cool! Queried the table found 5 others, changed them and tried again. And there be whales here, oops, webtree here!

I'm on the landing page, but the pictures aren't there. So I figure the media items weren't in the new version. There's a media directory in the backup, and a datamedia in the new. Checking datamedia, it seems to have the jpg's.

So I try going to other pages... no joy, every page I try results in "You do not have permission to view this page". Then I notice the "sign in". I'm not logged in, no wonder I've no permission.

So, I hit the Sign In link and get... "You do not have permission to view this page". Don't have permission to even try to sign in? Methinks that's a problem. Am I the one signed in in "Who is online", while not actually signed in, is there some data in limbo?

I note that on the landing page for the family, I see "Who is online" "1 signed in user". I note News items. And I note Statistics... Number of individuals, percent male, female, earliest birth, latest birth (2011 This information is private...)

So, I'm guessing ... I don't know... I've access to the database, but not finding some things... no permission to sign in... is a puzzle.

So, can't login, no media and I don't have permission to access any but the landing page, including sign in. Other than that, Mrs Lincoln, how did you enjoy the play?

Sorry, getting late, getting tired. Any help would be appreciated.

Please Log in or Create an account to join the conversation.

Last edit: by cornell.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 21 hours ago #7

  • cornell
  • cornell's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 16
Actually, I can get some info. The default person is my great grandfather, and I can get his info. And his son's. But his grandson, my deceased father doesn't seem to be in the son's family.

Please Log in or Create an account to join the conversation.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 14 hours ago #8

fisharebest wrote: Assuming your 1.3.2 site is still functioning, use the "export" option in the control panel to update the file.

@cornell: I guess you couldn't access the ControlPanel in wt1.3 and therefore couldn't update the GEDCOM file. Is that correct?

Additionally I'm not sure I understand your following steps correctly:
You have
1) backed up the old database via phpmyAdmin
2) backed up the old wt files in your webspace.
3) uploaded the setup files of wt V1.7.17 to your webspace

Now you try to access the old database with wtV1.7.17?
I suspect that this does not work.

So my suggestion would be to create a local test installation on the PC (e.g. XAMPP) with the old PHP/MySQL versions and with your wt1.3 backups (webspace files and mysql backup).

This way you can create a up-to-date GEDCOM backup and then import it into a new wt2 on your webspace.

Alternatively you could try to update the local wt1.3 to the latest wt version step by step and then integrate it into the webspace.


Old versions of XAMPP can be found here:
sourceforge.net/projects/xampp/files/XAMPP%20Windows/
Dieter
Schmidt ⚭ Schwab (Sudetenland) | Hauer ⚭ Bühler (Bayern / BW) | Маринов ⚭ Шаламанова (BG)
webtrees 2.0.10 | PHP 7.3 | MySQL 5.6 | Apache 2.4 | SunOS 5.10

Please Log in or Create an account to join the conversation.

Last edit: by ungeahnt.
Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 14 hours ago #9

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13716
> I'm on the landing page, but the pictures aren't there.

In webtrees 1.3, media files were stored (by default) in /media
In webtrees 2.0, they are stored (by default) in /data/media

Most likely, you just need to move the folder.

> So, I hit the Sign In link and get... "You do not have permission to view this page". Don't have permission to even try to sign in?

You can get this message if you are a non-admin and the tree is private, and you don't have access rights.

Are you sure that you logged in as an administrator?

Maybe check the database. There should be an entry in wt_user_setting for your user account with values "canadmin", "1".
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 13 hours ago #10

ungeahnt wrote: Now you try to access the old database with wtV1.7.17?
I suspect that this does not work.

The answer in #8 indicates that I was wrong and such a big version step is possible!

Amazing how backwards compatible the software is over several years!
Dieter
Schmidt ⚭ Schwab (Sudetenland) | Hauer ⚭ Bühler (Bayern / BW) | Маринов ⚭ Шаламанова (BG)
webtrees 2.0.10 | PHP 7.3 | MySQL 5.6 | Apache 2.4 | SunOS 5.10

Please Log in or Create an account to join the conversation.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 12 hours ago #11

  • cornell
  • cornell's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 16

fisharebest wrote: > I'm on the landing page, but the pictures aren't there.

In webtrees 1.3, media files were stored (by default) in /media
In webtrees 2.0, they are stored (by default) in /data/media

Most likely, you just need to move the folder.

> So, I hit the Sign In link and get... "You do not have permission to view this page". Don't have permission to even try to sign in?

You can get this message if you are a non-admin and the tree is private, and you don't have access rights.

Are you sure that you logged in as an administrator?

Maybe check the database. There should be an entry in wt_user_setting for your user account with values "canadmin", "1".


I looked in datamedia and the jpgs are there. I see there is also a data/media, only thumbs directory and .htaccess in there. I'll copy the jpgs there when I get back from my split shift.

I don't know that I'm logged in at all. The page does not say I'm me, or admin, it says "Sign in". I can't sign in, I don't have permission to access the sign in page. Could there be some vestigal thing in the database saying that I'm signed in, and some other part saying I'm not and hence is confused?

Please Log in or Create an account to join the conversation.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 12 hours ago #12

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13716
> Could there be some vestigal thing in the database saying that I'm signed in, and some other part saying I'm not and hence is confused?

Try deleting your cookies.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 12 hours ago #13

  • cornell
  • cornell's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 16

ungeahnt wrote:

fisharebest wrote: Assuming your 1.3.2 site is still functioning, use the "export" option in the control panel to update the file.

@cornell: I guess you couldn't access the ControlPanel in wt1.3 and therefore couldn't update the GEDCOM file. Is that correct?

Additionally I'm not sure I understand your following steps correctly:
You have
1) backed up the old database via phpmyAdmin
2) backed up the old wt files in your webspace.
3) uploaded the setup files of wt V1.7.17 to your webspace

Now you try to access the old database with wtV1.7.17?
I suspect that this does not work.

So my suggestion would be to create a local test installation on the PC (e.g. XAMPP) with the old PHP/MySQL versions and with your wt1.3 backups (webspace files and mysql backup).

This way you can create a up-to-date GEDCOM backup and then import it into a new wt2 on your webspace.

Alternatively you could try to update the local wt1.3 to the latest wt version step by step and then integrate it into the webspace.


Old versions of XAMPP can be found here:
sourceforge.net/projects/xampp/files/XAMPP%20Windows/


Correct, I could not access the control panel.

Also I've accomplished the three steps that you indicate.

I've concerns over database integrity or directory/file permissions

Please Log in or Create an account to join the conversation.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 12 hours ago #14

  • cornell
  • cornell's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 16
Would it help if I removed the offline.txt and provided a URL so you could go there and see for yourselves?

Please Log in or Create an account to join the conversation.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 12 hours ago #15

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13716

cornell wrote: Would it help if I removed the offline.txt and provided a URL so you could go there and see for yourselves?


Sure.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 9 hours ago #16

  • cornell
  • cornell's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 16

fisharebest wrote:

cornell wrote: Would it help if I removed the offline.txt and provided a URL so you could go there and see for yourselves?


Sure.


www.sternbergh.org/genealogy/webtrees/in...m&ged=Sternbergh.ged

Please Log in or Create an account to join the conversation.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 9 hours ago #17

  • cornell
  • cornell's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 16
I copied the files (*.jpg and thumbs directory) from backup to data/media, and the pictures are showing up.

Please Log in or Create an account to join the conversation.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 9 hours ago #18

  • cornell
  • cornell's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 16

fisharebest wrote: > Could there be some vestigal thing in the database saying that I'm signed in, and some other part saying I'm not and hence is confused?

Try deleting your cookies.


Cleared cookies, no apparent effect.

Please Log in or Create an account to join the conversation.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 9 hours ago #19

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13716
Your problem is caused by the "site access rules".

You have one (or more) rules in the table wt_site_access_rules which identify you (and me!) as a search engine.

Search engines are not allowed to access certain pages - including the login page.

Review the contents of this table.

Or delete it, and search the app/schema/xxx.php files to find the default/initial values.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

I'm at 1.3.2, how far can I upgrade at once? 2 weeks 7 hours ago #20

  • cornell
  • cornell's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 16

fisharebest wrote: Your problem is caused by the "site access rules".

You have one (or more) rules in the table wt_site_access_rules which identify you (and me!) as a search engine.

Search engines are not allowed to access certain pages - including the login page.

Review the contents of this table.

Or delete it, and search the app/schema/xxx.php files to find the default/initial values.


What I found was some 51 rows, 10 dated today or yesterday evening. Two have a rule "allow", the rest say "unknown".

In the migration*.php files, I found one that inserts and one that updates ##site_access_rule:

"INSERT IGNORE INTO `##site_access_rule` (user_agent_pattern, rule, comment) VALUES" .
" ('Mozilla/5.0 (%) Gecko/% %/%', 'allow', 'Gecko-based browsers')," .
" ('Mozilla/5.0 (%) AppleWebKit/% (KHTML, like Gecko)%', 'allow', 'WebKit-based browsers')," .
" ('Opera/% (%) Presto/% Version/%', 'allow', 'Presto-based browsers')," .
" ('Mozilla/% (compatible; MSIE %', 'allow', 'Trident-based browsers')," .
" ('Mozilla/5.0 (compatible; Konqueror/%', 'allow', 'Konqueror browser')"

The update appears to be a correction of the last insert, changing "compatible;" to "%":

"UPDATE `##site_access_rule` SET user_agent_pattern = 'Mozilla/5.0 (% Konqueror/%'" .
" WHERE user_agent_pattern='Mozilla/5.0 (compatible; Konqueror/%'"

Based upon this information, I'm thinking of deleting the contents of wt_site_access_rule and running this INSERT:

INSERT IGNORE INTO `wt_site_access_rule` (user_agent_pattern, rule, comment) VALUES
('Mozilla/5.0 (%) Gecko/% %/%', 'allow', 'Gecko-based browsers'),
('Mozilla/5.0 (%) AppleWebKit/% (KHTML, like Gecko)%', 'allow', 'WebKit-based browsers'),
('Opera/% (%) Presto/% Version/%', 'allow', 'Presto-based browsers'),
('Mozilla/% (compatible; MSIE %', 'allow', 'Trident-based browsers'),
('Mozilla/5.0 % Konqueror/%', 'allow', 'Konqueror browser');

Sound good?

Will this allow Chrome/Brave browsers to work?

Please Log in or Create an account to join the conversation.

Last edit: by cornell.
  • Page:
  • 1
  • 2
Powered by Kunena Forum