Before asking for help please read "How to request help" by clicking on that tab above here.
  • Page:
  • 1

TOPIC:

Error in upgrade to 2.0.10 6 days 4 hours ago #1

  • Knuth
  • Knuth's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 1
I tried an automatic upgrade to version 2.0.10, and received the attached error message. Is this a PHP issue? Should I try a fresh reinstall of Webtrees (while maintaining all data)? If so, is this something I can do without being the owner/operator of the server?
Attachments:

Please Log in or Create an account to join the conversation.

Error in upgrade to 2.0.10 6 days 3 hours ago #2

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13693
To fix this, you should do a manual upgrade.

webtrees.net/upgrade/manual/

Do you use any custom modules? If so, you should also check if these have upgrades available.
It is possible that the error is caused by an old module that is not compatible with 2.0.10
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Error in upgrade to 2.0.10 5 days 17 minutes ago #3

Hi,
I had similar error while updating and after startup webtrees I have alarm like in attachment.

I haven't used webtrees for very long time and don't remember what custom modules I've installed previously to check for their updates (I remember only vesta modules)
Attachments:

Please Log in or Create an account to join the conversation.

Error in upgrade to 2.0.10 4 days 23 hours ago #4

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13693
This error message suggests you have a mix of files from two different versions of webtrees.

When you upgraded, I guess you did not copy all the files.

Just copy them all again.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Error in upgrade to 2.0.10 4 days 22 hours ago #5

I tried 3 more times with overwriting files but still the same error message

Please Log in or Create an account to join the conversation.

Error in upgrade to 2.0.10 4 days 19 hours ago #6

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13693
The error message says that the file vendor/symfony/polyfill-intl-normalizer/bootstrap.php does not exist.

This file is included in webtrees-2.0.10.zip

Check that this file exists in your zip file.
Check that this file exists on your server.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Error in upgrade to 2.0.10 4 days 15 hours ago #7

Yes file exist in both: zip and on the server (localhost).

I also tried to put symfony folder to composer but result is same
Attachments:

Please Log in or Create an account to join the conversation.

Error in upgrade to 2.0.10 3 days 19 hours ago #8

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13693
The error message says that the file does not exist.

Your screenshot does not show the file.

I think you should check again.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 
  • Page:
  • 1
Powered by Kunena Forum