Before asking for help please read "How to request help" by clicking on that tab above here.
  • Page:
  • 1

TOPIC:

media files shown with jpg on red background if not logged in 2 weeks 4 days ago #1

  • Franz Frese
  • Franz Frese's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 40
If not logged in, media files are shown with a "jpg" text on red background.



There are some media files, that are already in the cache, which are shown.



How do I correctly clear the cache or perhaps rebuild.
What access should the Cache dirs have?
Perhaps you can give me a hint, how to correct resolve this behaviour.
Attachments:

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 2 weeks 4 days ago #2

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13892
Your server doesn't have the ability to create JPG files.

Probably an error in your GD or ImageMagick libraries.

There is an error message in the HTTP responses for the "red square" image.

If you don't know how to use the browser dev tools to find it, then just post the URL.

Also, check webtrees.net/faq/thumbnails/
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 2 weeks 4 days ago #3

  • Franz Frese
  • Franz Frese's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 40
But the images are shown, if I am logged in.

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 2 weeks 4 days ago #4

  • Franz Frese
  • Franz Frese's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 40
url is web.bild-raum.de

Search for Herman Fobbe born 1922 (is in cache)
Search for Willi Fobbe born 1905 (is not in cache)

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 2 weeks 4 days ago #5

  • Sir Peter
  • Sir Peter's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 66
None of these pictures load for me. Maybe some are still in your browser cache.
Peter

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 2 weeks 4 days ago #6

  • Franz Frese
  • Franz Frese's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 40
I cleared the browser cache, but there are still shown some pictures.

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 2 weeks 4 days ago #7

  • Sir Peter
  • Sir Peter's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 66
To be more precise: Your media list shows 87 media objects. None of these display correctly. 85 display a red .jpg box, 1 (Everstein Wappen) displays a red .png box and 1 (film 7990966, frame 00216) doesn't display anything.
Peter

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 2 weeks 4 days ago #8

  • Franz Frese
  • Franz Frese's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 40
So why is that so (I think when I started with webtrees some month ago all was ok)?
If I am logged in (I can do an account for) , there are more media files and all are displayed ok.

Or simply how can I start from scratch with all the media files, making every thing work ok? Webtrees is at the moment not my original source (of gedcom file)

Please Log in or Create an account to join the conversation.

Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 

media files shown with jpg on red background if not logged in 2 weeks 4 days ago #9

  • Sir Peter
  • Sir Peter's Avatar
  • Offline
  • New Member
  • New Member
  • Posts: 66

Greg said: Your server doesn't have the ability to create JPG files.


I am sorry, but I am NOT the best resource to analyze this issue. I am afraid you will have to wait for an expert.
Peter

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 2 weeks 4 days ago #10

  • bertkoor
  • bertkoor's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Greetings from Utrecht, Holland
  • Posts: 2167
Logged in users see the original image.
Visitors get the image with added watermark <-- this creation fails!
stamboom.BertKoor.nl runs on webtrees v1.7.13

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 2 weeks 4 days ago #11

  • Franz Frese
  • Franz Frese's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 40
may be, but it has been working.
what prevents them for being created?
why are not all media files seen, if not logged in?
what can I do?

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 2 weeks 4 days ago #12

  • Franz Frese
  • Franz Frese's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 40
So, I switched from php version 7.4 back to 7.3 .
Now the watermarked images are shown.

The real reason can not be figured out by me, cause my provider supplies the sql, php and the other stuff.
Someday 7.3 will be outdated and I have to change.

My provider also offers php 8. will that work?

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 2 weeks 4 days ago #13

  • norwegian_sardines
  • norwegian_sardines's Avatar
  • Offline
  • Elite Member
  • Elite Member
  • Posts: 1876
No PHP 8.0 will not work with the current release of webtrees. This is due to ongoing support of older PHP releases.
Ken

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 2 weeks 4 days ago #14

  • norwegian_sardines
  • norwegian_sardines's Avatar
  • Offline
  • Elite Member
  • Elite Member
  • Posts: 1876
No PHP 8.0 will not work with the current release of webtrees. This is due to ongoing support of older PHP releases.

www.webtrees.net/index.php/en/forum/help...-8-0-supported#81692
Ken

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 2 weeks 3 days ago #15

You know, I have seen this same problem. Be sure that your folder and file permissions, in /data are correct. I also delete the /data/thumbnail-cache if I have one.
Rob
www.skatekey.net ( beta GitHub)
PHP 7.4.6, MariaDB 10.1.44, Apache 2.4.43,
Hosted at tigertech.net

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 2 weeks 3 days ago #16

  • Franz Frese
  • Franz Frese's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 40
checked in advance, but the solution for me is permission independent.

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 1 week 1 day ago #17

  • Franz Frese
  • Franz Frese's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 40
I want to give 7.4 a new chance.
I checked ImageMagick and memory-limit. Both a identical in 7.3 and 7.4 installation.

I reduced the problem for just showing:
web.bild-raum.de/index.php?route=%2Ftree...sition=inline&mark=1

which is shown with the php 7.3 but not in 7.4

I' not firm in debugging. So if anyone can help me. I will let php 7.4 switched on for the next time.

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 1 week 1 day ago #18

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13892
The HTTP headers for this image include the error message:

Unable to read image from path (/mnt/web004/b0/69/5175769/htdocs/web/app/../resources/img/watermark.png

My guess is that your PHP 7.4 installation does not have gd or imagemagick (or the PNG driver for these).
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 1 week 1 day ago #19

  • Franz Frese
  • Franz Frese's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 40
I checked gd differences too, but there are none shown.

So what can I do next?

Please Log in or Create an account to join the conversation.

media files shown with jpg on red background if not logged in 1 week 1 day ago #20

  • bertkoor
  • bertkoor's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Greetings from Utrecht, Holland
  • Posts: 2167

Franz Frese wrote: So what can I do next?


Raise a support ticket with your hosting provider: ask for full imagemagick support under PHP7.4
stamboom.BertKoor.nl runs on webtrees v1.7.13

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum