Before asking for help please read "How to request help" by clicking on that tab above here.
  • Page:
  • 1

TOPIC:

Installing problem 2 weeks 18 hours ago #1

  • ks4647@live.dk
  • ks4647@live.dk's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 2
After installing Webtrees 2.011, and opening the browser I get the following and so on a whole page:

PDOException: SQLSTATE[23000]: Integrity constraint violation: 1048 Column 'ip_address' cannot be null in C:\inetpub\wwwroot\webtrees\vendor\doctrine\dbal\lib\Doctrine\DBAL\Driver\PDOStatement.php:117 Stack trace: #0 C:\inetpub\wwwroot\webtrees\vendor\doctrine\dbal\lib\Doctrine\DBAL\Driver\PDOStatement.php(117): PDOStatement->execute() #1 C:\inetpub\wwwroot\webtrees\vendor\illuminate\database\Connection.php(458): Doctrine\DBAL\Driver\PDOStatement->execute() #2 C:\inetpub\wwwroot\webtrees\vendor\illuminate\database\Connection.php(657): Illuminate\Database\Connection->Illuminate\Database\{closure}() #3 C:\inetpub\wwwroot\webtrees\vendor\illuminate\database\Connection.php(624): Illuminate\Database\Connection->runQueryCallback() #4 C:\inetpub\wwwroot\webtrees\vendor\illuminate\database\Connection.php(459): Illuminate\Database\Connection->run() #5 C:\inetpub\wwwroot\webtrees\vendor\illuminate\database\Connection.php(411): Illuminate\Database\Connection->statement() #6 C:\inetpub\wwwroot\webtrees\vendor\illuminate\database\Query\Builder.php(2646): Illuminate\Database\Connection->insert() #7 C:\inetpub\wwwroot\webtrees\app\SessionDatabaseHandler.php(95): Illuminate\Database\Query\Builder->insert() #8 [internal function]: Fisharebest\Webtrees\SessionDatabaseHandler->write() #9 C:\inetpub\wwwroot\webtrees\app\Session.php(104): session_write_close() #10 C:\inetpub\wwwroot\webtrees\app\Http

I am using IIS, MYSQL and php 7.4
I have used Webtrees 1.7.17 for a while without problems.

Help.

Knud Skovhus

Please Log in or Create an account to join the conversation.

Installing problem 1 week 6 days ago #2

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 14108
This was reported before.

The problem is that IIS is not sending a valid IP address.

www.webtrees.net/index.php/en/forum/help...h-network-identifier
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Installing problem 1 week 5 days ago #3

  • ks4647@live.dk
  • ks4647@live.dk's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 2
I changed to php 7.2, and now it works

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum