Before asking for help please read "Requesting Help and Suggestions" by clicking on that tab above here.
  • Page:
  • 1

TOPIC:

THANKS and geographical data ERROR 3 weeks 1 day ago #1

  • anjop
  • anjop's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 133
I just wanted to say a large THANK YOU after updating to v.2.0.15 and all the module I am using worked so smooth and nice and easy!!! A wonderful feeling! THANKS!!!

Then when working on geographical data I got a red error page (see attachment). Fortunately I could solve by "back" in Safari and "cancel".

There is a location "Middlewich Branch" (England) but without geographical data. When adding the data by "search" I got some, but after saving this data it does not appear but the yellow triangle signal still remains.

It happened when trying to:
- change the name of a location
- change the location name I searched for (Middlewich instead of Middlewich Branch)
- add a new location name

I could delete the location (Middlewich Branch) but I couldn't add a new one (Middlewich).

I have no idea what the problem could be. I disabled the module "Vesta Look and feel", but the error again appears.

Hope you can tell me any advice!
www.helmutpaul.at / www.paul-engl.at / www.komoot.de/user/anjop
----
webtrees 2.0.15; theme: colours; modules: Vesta Classic Look & Feel; Fancy Imagebar; Theme modifications (by Rob Peters);
PHP Version 7.4 (8.0 would be available by provider); mySQL 4.9.7; Mac OSX 10.15.7 with Safari
Attachments:

Please Log in or Create an account to join the conversation.

THANKS and geographical data ERROR 3 weeks 1 day ago #2

  • ddrury
  • ddrury's Avatar
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 310
You have corruption in the place location table. I would try the following

1. Export the geographic data (control panel - Geographic data - export file). I *think* the export and import routines will strip out invalid data
2. If that doesn't work and you have access to phpmyadmin or similar, run the following query on the wt_place_location table
update wt_place_location set parent_id = null WHERE parent_id = ''
this will remove the corruption mentioned in the error message you quote but *will* affect the place hierarchy of the corrupted entries, but at least you should be able to edit them
--
Dave

Local: Win 10 Pro/WSL Apache 2.4.41, PHP 7.4.16/8.0.3, MariaDB 10.4.10
Production: Apache 2.2, PHP 7.3.27, 10.3.18-MariaDB

Please Log in or Create an account to join the conversation.

Last edit: by ddrury.

THANKS and geographical data ERROR 3 weeks 1 day ago #3

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 14515
I think this is a bug.

I have recently made some fixes to this code, so I think it might have already been fixed.
Let me check.

> update `wt_place_location` set `parent_id` = null WHERE `parent_id` = ''

I do not think this will help. parent_id is a nullable integer field, so it cannot contain ''.
The empty-string/null mismatch looks like a coding error.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

THANKS and geographical data ERROR 3 weeks 1 day ago #4

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 14515
> Let me check.


Yes - it is a bug, and has already been fixed. Wait for 2.0.16
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

THANKS and geographical data ERROR 3 weeks 1 day ago #5

  • anjop
  • anjop's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 133
THX for your replies!
Now I don't do anything but waiting for 2.0.16 before I can go on with my work in this genealogy.
Hoping it will help!
www.helmutpaul.at / www.paul-engl.at / www.komoot.de/user/anjop
----
webtrees 2.0.15; theme: colours; modules: Vesta Classic Look & Feel; Fancy Imagebar; Theme modifications (by Rob Peters);
PHP Version 7.4 (8.0 would be available by provider); mySQL 4.9.7; Mac OSX 10.15.7 with Safari

Please Log in or Create an account to join the conversation.

THANKS and geographical data ERROR 1 week 4 days ago #6

  • anjop
  • anjop's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 133
Thousand thanks!
v 2.0.16 solved the problem!
I now could ad new geographical data without problems.
I hope it stays like this!
Have a good time and stay healthy!
Andreas
www.helmutpaul.at / www.paul-engl.at / www.komoot.de/user/anjop
----
webtrees 2.0.15; theme: colours; modules: Vesta Classic Look & Feel; Fancy Imagebar; Theme modifications (by Rob Peters);
PHP Version 7.4 (8.0 would be available by provider); mySQL 4.9.7; Mac OSX 10.15.7 with Safari

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum