Before asking for help please read "Requesting Help and Suggestions" by clicking on that tab above here.
  • Page:
  • 1

TOPIC:

2.0.16 two error messages 2 weeks 21 hours ago #1

  • dietmar
  • dietmar's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 39
I keep getting two error messages at once:

Argument 1 passed to Fisharebest\Webtrees\Elements\AbstractElement::__construct() must be of the type string, unknown given, called in …/app/Factories/ElementFactory.php on line 947
Argument 2 passed to Fisharebest\Webtrees\Elements\AbstractElement::__construct() must be of the type array or null, unknown given, called in …/app/Factories/ElementFactory.php on line 261

Thank you very much for help

Please Log in or Create an account to join the conversation.

Last edit: by dietmar.

2.0.16 two error messages 1 week 6 days ago #2

  • dietmar
  • dietmar's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 39
In the last 5 days, the two errors

Argument 1 passed to Fisharebest\Webtrees\Elements\AbstractElement::__construct() must be of the type string, unknown given, called in …/app/Factories/ElementFactory.php on line 947

and

Argument 2 passed to Fisharebest\Webtrees\Elements\AbstractElement::__construct() must be of the type array or null, unknown given, called in …/app/Factories/ElementFactory.php on line 261

appeared almost 1000 times in different actions (see webtrees-logs)

Thank you very much for help

hermsdoerfer.familyds.com/webtrees/
Attachments:

Please Log in or Create an account to join the conversation.

2.0.16 two error messages 1 week 6 days ago #3

  • norwegian_sardines
  • norwegian_sardines's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 2065
My guess would be that if this was a recent install of 2.0.16, you probably did not load all of the program to your website. try reinstalling again making sure all files are loaded!
Ken

Please Log in or Create an account to join the conversation.

2.0.16 two error messages 1 week 6 days ago #4

  • dietmar
  • dietmar's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 39
Webtrees 2.0.16 was installed 5 weeks ago and ran without problems for the first 4 weeks.

Please Log in or Create an account to join the conversation.

2.0.16 two error messages 1 week 6 days ago #5

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 14636
The error messages don't make any sense with the 2.0.16 code.

I agree with Ken. I would re-install.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

2.0.16 two error messages 1 week 6 days ago #6

  • bertkoor
  • bertkoor's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Greetings from Utrecht, Holland
  • Posts: 2330
Maybe before reinstalling first delete all php scripts & folders (except /data ofcourse!) so you're absolutely sure no old code is left over.
stamboom.BertKoor.nl runs on webtrees v1.7.13

Please Log in or Create an account to join the conversation.

2.0.16 two error messages 1 week 6 days ago #7

  • dietmar
  • dietmar's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 39
I delete all directories and files (except /data) from webtrees 2.0.16 and re-install 2.0.16.

I still get the two error messages!

I can send an account ID.

Thank you very much for help
Dietmar

hermsdoerfer.familyds.com/webtrees/

Please Log in or Create an account to join the conversation.

2.0.16 two error messages 1 week 5 days ago #8

  • dietmar
  • dietmar's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 39
Feedback: A new installation using the install script helped.
I replaced the newly created database in the config.ini with the old database name and deleted the newly created empty database.
Cause: Despite starting the Synology server several times, old content has apparently been cached !?

Please Log in or Create an account to join the conversation.

Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 

2.0.16 two error messages 6 days 18 hours ago #9

  • dietmar
  • dietmar's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 39
Solution: php cache deactivated

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum