Before asking for help please read "Requesting Help and Suggestions" by clicking on that tab above here.
  • Page:
  • 1

TOPIC:

How do you let new visitors see HTML block? 2 days 20 hours ago #1

  • tasker
  • tasker's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 4
Previously someone visiting my site for the first time saw the HTML block with a welcome message and the interactive tree. I have had to reinstall 2.0.17 from scratch after my hosting company went belly up and I now can't find how to reinstate this behaviour. I set the default blocks for a new tree to be HTML and Charts. Both of these have been set to be visible to visitors. When I am logged in as Admin, the Home page displays the HTML block and interactive chart correctly, but if you visit the site without logging in, all you see is the interactive chart and not the HTML block. I have tried clearing the cache and my browser cache - it makes no difference. What do I have to do to restore it to the way it was working before? Sorry this is such a basic question but I just can't figure out how to do it.
Attachments:

Please Log in or Create an account to join the conversation.

How do you let new visitors see HTML block? 2 days 20 hours ago #2

  • ungeahnt
  • ungeahnt's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 160
Hi,

do you have set the correct languages for the HTML block?
Dieter
Schmidt ⚭ Schwab (Sudetenland) | Hauer ⚭ Bühler (Bayern / BW) | Маринов ⚭ Шаламанова (BG)
webtrees 2.0.17 | PHP 7.4 | MariaDB 10.3.27 | Apache 2.4 | Debian 4.19.181-1 (2021-03-19) x86_64

Please Log in or Create an account to join the conversation.

How do you let new visitors see HTML block? 2 days 19 hours ago #3

  • tasker
  • tasker's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 4
Thanks for good suggestion. However, I have British English enabled in Modules and British English ticked in HTML block, so I don't think this is the problem.

Please Log in or Create an account to join the conversation.

How do you let new visitors see HTML block? 2 days 19 hours ago #4

  • tasker
  • tasker's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 4
Very strange. I played around with the languages and added American English as well as British English in Modules and ticked both in the HTML block. Then removed American English in Modules and it is working correctly. Something a bit strange with the coding maybe, but I am happy. Thanks for pointing me in this direction.

Please Log in or Create an account to join the conversation.

How do you let new visitors see HTML block? 2 days 19 hours ago #5

  • ungeahnt
  • ungeahnt's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 160

Very strange. I played around with the languages and added American English as well as British English in Modules and ticked both in the HTML block. Then removed American English in Modules and it is working correctly. Something a bit strange with the coding maybe, but I am happy. Thanks for pointing me in this direction.


The problem could be raised up due to your browser language settings. When you use no other languages in wt then (I think) it's better not to tick a language-box in the html block settings. So this block will always shown (indepent from any wt/browser-language settings).
Dieter
Schmidt ⚭ Schwab (Sudetenland) | Hauer ⚭ Bühler (Bayern / BW) | Маринов ⚭ Шаламанова (BG)
webtrees 2.0.17 | PHP 7.4 | MariaDB 10.3.27 | Apache 2.4 | Debian 4.19.181-1 (2021-03-19) x86_64

Please Log in or Create an account to join the conversation.

Last edit: by ungeahnt.

How do you let new visitors see HTML block? 2 days 19 hours ago #6

  • ungeahnt
  • ungeahnt's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 160
Dieter
Schmidt ⚭ Schwab (Sudetenland) | Hauer ⚭ Bühler (Bayern / BW) | Маринов ⚭ Шаламанова (BG)
webtrees 2.0.17 | PHP 7.4 | MariaDB 10.3.27 | Apache 2.4 | Debian 4.19.181-1 (2021-03-19) x86_64

Please Log in or Create an account to join the conversation.

How do you let new visitors see HTML block? 2 days 18 hours ago #7

  • tasker
  • tasker's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 4
Yes - my mistake was ticking the language box in the HTML block. Many thanks.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum