Before asking for help please read "Requesting Help and Suggestions" by clicking on that tab above here.
  • Page:
  • 1

TOPIC:

Installation problems with version 2.0.19 2 weeks 19 hours ago #1

  • jdobson
  • jdobson's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 10
I've been trying to do a 'clean' Webtrees reinstall and can't get past the database initialization step. I've used cPanel to create a new database and database user and associated the user with the database which I've verified as being successful as a database with zero tables. The initialization step fails with the following error message -

'SQLSTATE[28000] [1045] Access denied for user 'myrellie_dbuser'@'localhost' (using password: YES)'

So obviously the problem is connecting to the pristine database, I've checked the 'myrellie_dbuser' password many times, so I don't believe that's the problem.

What have I forgotten / need to change ?
John Dobson

webtrees v2.0.2 - www.my-rellies.com

Please Log in or Create an account to join the conversation.

Installation problems with version 2.0.19 2 weeks 15 hours ago #2

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 15173
Is your database on the same server as your webserver?
If so, then you need to create a "network user", not a "localhost user".

Also, MySQL 8 uses a password encryption algorithm that isn't supported by older versions of PHP (or any version?). So, you to select the old algorithm when creating the user.

Other than that, it's hard to guess.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum