Before asking for help please read "Requesting Help and Suggestions" by clicking on that tab above here.
  • Page:
  • 1

TOPIC:

Don't require login to view tree 2 weeks 4 days ago #1

  • alacritas
  • alacritas's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 5
I have my tree, and I can view it with my administrator account. However, I would like to make my tree visible to everyone with the url without requiring them to register for a visitor account. Is there a way to do this?

Please Log in or Create an account to join the conversation.

Don't require login to view tree 2 weeks 3 days ago #2

Go to "My pages -> Control panel -> Family trees", select the tree you intend to share, go to "Privacy" and allow "visitors" to all entries.
Ansgar
Webtrees 2.0.19, PHP7.4

Please Log in or Create an account to join the conversation.

Don't require login to view tree 2 weeks 3 days ago #3

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 15173
The documentation for the privacy settings is here:

webtrees.net/user/privacy/
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Don't require login to view tree 2 weeks 3 days ago #4

  • alacritas
  • alacritas's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 5
I gave a look at the privacy settings. I set my privacy settings on the tree to all be available to visitors as can be seen below.

imgur.com/iNtqmet

Then when I try to visit the tree by copying the link for the default chart into a new browser, I get the following

imgur.com/ytFaUu3

Please Log in or Create an account to join the conversation.

Last edit: by alacritas. Reason: clarify wording

Don't require login to view tree 2 weeks 3 days ago #5

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 15173
> imgur.com/undefined

I think you need to post this link again...
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Don't require login to view tree 2 weeks 3 days ago #6

  • alacritas
  • alacritas's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 5
I just edited my last post to fix the links

Please Log in or Create an account to join the conversation.

Don't require login to view tree 2 weeks 3 days ago #7

  • bertkoor
  • bertkoor's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Greetings from Utrecht, Holland
  • Posts: 2549
Looks like you set access granted to members only.
Change it to Visitors, and don't forget to press Save at the bottom of the page.
stamboom.BertKoor.nl runs on webtrees v1.7.13

Please Log in or Create an account to join the conversation.

Last edit: by bertkoor.

Don't require login to view tree 2 weeks 3 days ago #8

  • alacritas
  • alacritas's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 5
Where are you seeing that, bertkoor?

Please Log in or Create an account to join the conversation.

Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 

Don't require login to view tree 2 weeks 3 days ago #9

  • alacritas
  • alacritas's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 5
I downgraded to 2.0.19 and re-uploaded my tree, and this resolved the issue.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum