Before asking for help please read "Requesting Help and Suggestions" by clicking on that tab above here.
  • Page:
  • 1

TOPIC:

Problems with media file (photos) import 6 days 15 hours ago #1

  • bengtfalke
  • bengtfalke's Avatar Topic Author
  • Away
  • New Member
  • New Member
  • Posts: 3
Hello and thank you for this amazing app. I have just installed it on my web server and all seems to work fine with one exception… the media files. You can find my server here biom.se/webtrees

I imported the gedcom file from my local Windows comp from this file:
d:\Gen\Falke.ged
d:\Gen\Falke_Photos is the folder containing my photos.

During the import I tried to understand the remarks about ignoring the naming convention in Windows and added just Falke_Photos as the path for the media files. When I look at a person in Webtree now the photo is missing and there is just a pink square with 404 in it.

I also tried to FTP the Falke_Photos folder manually to the webtree folder on the server but no luck?

Is this problem possible to solve or should I redo the import with different settings?
Best regards/Bengt Falke

Please Log in or Create an account to join the conversation.

Problems with media file (photos) import 4 days 18 hours ago #2

  • bengtfalke
  • bengtfalke's Avatar Topic Author
  • Away
  • New Member
  • New Member
  • Posts: 3
The gedfile is exported from My Heritage and it seems it contains hard links to a folder on my local computer as in d:\Gen\Falke_Photos\p142.jpg.
That hard path is also imported into webtrees and as I understand it is the reason for my missing media files.
I tried to copy the photo files to the server in webtrees/app/../media/Falke_Photos and the did a search and replace all in my Falke.ged from d:\Gen\Falke_Photos\p142.jpg to Falke_Photos/p142.jpg before importing it to webtrees.
However still no luck! I am hoping for a hint on what paths I should use or if I can do a search and replace in MySQL?

Please Log in or Create an account to join the conversation.

Problems with media file (photos) import 4 days 14 hours ago #3

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 16208
The import page has an option to remove the media path prefix
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Problems with media file (photos) import 4 days 13 hours ago #4

  • bengtfalke
  • bengtfalke's Avatar Topic Author
  • Away
  • New Member
  • New Member
  • Posts: 3
It seems I managed to solv this with a lot of experimentation... lol
Now the photos shows up in the trees but not in manage media.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum