Before asking for help please read "Requesting Help and Suggestions" by clicking on that tab above here.
  • Page:
  • 1

TOPIC:

500 error after upgrading to 2.1.7 1 week 3 days ago #1

  • maxjacobi
  • maxjacobi's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 4
I upgraded to 2.1.7 today, and everything went fine (installation on webpage was successful), but when I tried navigating to other parts of the website, it gave me an http 500 error.
I followed the instructions on the bottom of this page (webtrees.net/faq/500/) to enable output of PHP errors. After that I got this, trying to request any page of the website:

Warning: require(/www/htdocs/w01b4a32/genealogie.maxjacobi.com/vendor/composer/../symfony/polyfill-php81/bootstrap.php): failed to open stream: No such file or directory in /www/htdocs/w01b4a32/genealogie.maxjacobi.com/vendor/composer/autoload_real.php on line 55

Warning: require(/www/htdocs/w01b4a32/genealogie.maxjacobi.com/vendor/composer/../symfony/polyfill-php81/bootstrap.php): failed to open stream: No such file or directory in /www/htdocs/w01b4a32/genealogie.maxjacobi.com/vendor/composer/autoload_real.php on line 55

Fatal error: require(): Failed opening required '/www/htdocs/w01b4a32/genealogie.maxjacobi.com/vendor/composer/../symfony/polyfill-php81/bootstrap.php' (include_path='.:/usr/share/php:..') in /www/htdocs/w01b4a32/genealogie.maxjacobi.com/vendor/composer/autoload_real.php on line 55

Any help on this?

Thanks.

Please Log in or Create an account to join the conversation.

500 error after upgrading to 2.1.7 1 week 3 days ago #2

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 16321
These errors suggest missing files.

Try copying all the files to the server again.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

500 error after upgrading to 2.1.7 1 week 3 days ago #3

  • maxjacobi
  • maxjacobi's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 4
Did that, didn't fix it. Or are these files also missing in the downloaded 2.1.7 zip file? This is the directory they should be located in:
Attachments:

Please Log in or Create an account to join the conversation.

500 error after upgrading to 2.1.7 1 week 3 days ago #4

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 16321
The error says you are missing this file:

vendor/symfony/polyfill-php81/bootstrap.php
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum