TOPIC: Impossible de se connecter

Impossible de se connecter 5 years 10 months ago #1

  • Lisa67
  • Lisa67's Avatar
SQLSTATE[HY000] [1045] Access denied for user

Bonjour, voici le message qui s'affiche, je ne comprend pas config.ini.php est juste. La semaine dernière je me suis connectée dans problème
que faut t'il faire ? D'avance merci
Lisa
The administrator has disabled public write access.

Impossible de se connecter 5 years 10 months ago #2

  • ToyGuy
  • ToyGuy's Avatar
  • Offline
  • Moderator
  • Live like it's Christmas every day - Santa Stephen
  • Posts: 4925
Google the error and get tons of suggestions, all to do with misconfiguration of your SQL access. If you already have a config.ini.php file, what does it specify for USER? Bonjour? I doubt that is your SQL username.

You can remove the config.ini.php and the system will allow you to recreate one using setup.php.

Here's one of the Drupal error helps, but it would be similar:
From the error, it looks like
Posted by jscoble on May 23, 2011 at 7:17pm
From the error, it looks like you haven't specified a valid mysql user. Note the error message says Access denied for user :'@localhost'

The user string should be 'username@localhost', if a mysql user was specified. You can still get an access denied when a username is specified. In that case, it would mean that you need to grant the specified username adequate permissions to the database in question so that the update script can do what it needs to do. The database user you created for Drupal should already have the permissions needed and I'd use that username/password combination.
Santa Stephen the Fabled Santa
Latest webtrees at MyArnolds.com
Hosted by webtreesonline.com, a division of GeneHosts LLC
MacOS 10.6.8, Apache 2.2+, PHP 5.4.16, MySQL 5.5.28
The administrator has disabled public write access.
Powered by Kunena Forum