This Help forum is for issues relates to the latest release (1.4.6). For issues related to beta or git version please use their own Help forum.
Before asking for help please read "How to request help" by clicking on that tab above here.

TOPIC: Media address Problem 2

Media address Problem 2 3 years 11 months ago #21

  • Jackie
  • Jackie's Avatar
  • Offline
  • Platinum
  • Posts: 4691
Hello Peter,

Just to say that there is no website at the URL address you provided in your first post. It shows a 404 error.

gentzsch-wiesbaden.de/webtrees/webtrees/
Last Edit: 3 years 11 months ago by Jackie.
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #22

  • Jackie
  • Jackie's Avatar
  • Offline
  • Platinum
  • Posts: 4691
Hello Peter,

Perhaps nothing to do with your media issue..

At step 7 of the installation "Create a family tree", the help says:
This option creates a new family tree. The name you give it will be used to generate URLs and filenames, so you should choose something short, simple, and avoid punctuation.

So, why did you name your gedcom file? : Familie%20Gentzsch&cb=41e37ed0_

file.ged is not the name of your website. It would be sufficient if you name it: gentzsch

EDIT: wiki.webtrees.net/de/Installation#Einen_Stammbaum_erstellen
Diese Option legt einen neuen Familiestammbaum an. Der von Ihnen vergebene Name wird verwendet, um Internet-Adressen (URLs) und Dateinamen zu erzeugen. Vergeben Sie daher bitte einen kurzen, einfachen Namen und vermeiden Sie Satzzeichen.
Last Edit: 3 years 11 months ago by Jackie.
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #23

  • Peter37
  • Peter37's Avatar
Hello Jackie,
I really appreciate the effort you are putting in trying to understand my problem.
I will try to anwer all your questions:
1. The complete address of my webtrees is:
gentzsch-wiesbaden.de/webtrees/webtrees/index.php - at least it worked, when I just tried it.
2. Server: The server is run by a web hosting service in Berlin. My webtrees is located within my own private Homepage which I run since a couple of years.
3. Number of folders/subfolders: as I said: " re 1: If I remember correctly, the long path for 1. was generated by the program, but I am not certain. - By the way, the same path is suggested under Thumbs. - Also, I do not understand why webtrees should be looking here because I thought that the Gedcom media path was removed in transfer."
4. Name of the Gedcom file: This is generated by my Family Tree Software on my PC. It actually is: Gentzsch Familienstammbaum.ged. - This has never caused a problem, so I did not see a reason to change.
5. Name of the family tree: It is "Familie Gentzsch". I think this is pretty straightforward. - But I am open for simplifications, - if it helps.
6. Pictures in two places: If was not trying to suggest that this is a must. I am still not clear where they should be though. - So I thought it does not hurt to have them in two places.
7. If you plan to test the Family Tree. - The pictures are only for the "Default Individual".
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #24

  • Peter37
  • Peter37's Avatar
Sorry, the http in front of the webtrees-address got removed during submittal.
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #25

  • Jackie
  • Jackie's Avatar
  • Offline
  • Platinum
  • Posts: 4691
Peter37 wrote:
Sorry, the http in front of the webtrees-address got removed during submittal.

Hello Peter,

This is normal. Don't worry, the link is effective. I visited your website and when I listed your media objects(403), I got that:




Please visit your :

Administration -> Media -> by default "Local files" is ticked.

Do you see your media there?

If not, tick the "Unused files". Do you see any media there?
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #26

  • Jackie
  • Jackie's Avatar
  • Offline
  • Platinum
  • Posts: 4691
Hello Peter,

Administration -> Media ->

When you will see your media objects, please tell me what path is displayed?


The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #27

  • Peter37
  • Peter37's Avatar
A miracle:
I see my pictures!! - Even twice, because I have includes the subfolders in the search.
Unfortunately the are all in "Unused files". - The "Local files" show the listing all pictures that I should have uploaded eventually
How do I get them to be used?
Thanks, sofar
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #28

  • Peter37
  • Peter37's Avatar
The path to the unused pictures is:

D:/Daten/Ahnen/Ahnenforschung/Gentzsch-Ahnenblatt/Gentzsch Familienstammbaum/gentzsch-peter-sw-a-2006.jpg
File size: 60 KB
Image dimensions: 1,266 × 1,259 pixels


gentzsch-peter-1941-02-07.jpg
File size: 28 KB
Image dimensions: 526 × 728 pixels

These are two typical ones if I include the subfolders

The path of the local files is: /home/www/web1786/html/webtrees/webtrees/data/media/
The administrator has disabled public write access.
Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 

Media address Problem 2 3 years 11 months ago #29

  • ToyGuy
  • ToyGuy's Avatar
  • Offline
  • Moderator
  • Live like it's Christmas every day - Santa Stephen
  • Posts: 4922
Peter
Where is this path recorded? This is a local drive (D) path. For webtrees, paths are relative to the installation.

If your family tree file (GEDCOM) actually contains the line

1 FILE D:/Daten/Ahnen/Ahnenforschung/Gentzsch-Ahnenblatt/Gentzsch Familienstammbaum/gentzsch-peter-sw-a-2006.jpg

then you need to remove that path prefix from your file name, up to the name of the file within the /data/media folder

If this is the case, you could use Batch Update > Search & replace

first field:
1 FILE D:/Daten/Ahnen/Ahnenforschung/Gentzsch-Ahnenblatt/Gentzsch Familienstammbaum/
and second field:
1 FILE (there is a space here following the FILE)

and then your family tree file should read

1 FILE gentzsch-peter-sw-a-2006.jpg
Santa Stephen the Fabled Santa
Latest webtrees at MyArnolds.com
Hosted by webtreesonline.com, a division of GeneHosts LLC
MacOS 10.6.8, Apache 2.2+, PHP 5.4.16, MySQL 5.5.28
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #30

  • Peter37
  • Peter37's Avatar
Hello ToyGuy,
as I stated about 18 Hrs ago, my Gedcom lines start with a 2 !
My understanding sofar is that the path prefix is removed during transfer by the Gedcom Media Path.
In the mean time I had some discussions with "Jackie" which seem to have led very close to the problem and a solution.
Would you care to comment on that discussion?
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #31

  • ToyGuy
  • ToyGuy's Avatar
  • Offline
  • Moderator
  • Live like it's Christmas every day - Santa Stephen
  • Posts: 4922
Not really. Too many cooks spoil the broth. 1 FILE/2 FILE the answer is the same on how to remove a superfluous path.

Extra paths can be removed during a reimport, but that is not necessary if the path prefix is all the same. Batch Update works well too assuming you have enough memory and processor power.
Santa Stephen the Fabled Santa
Latest webtrees at MyArnolds.com
Hosted by webtreesonline.com, a division of GeneHosts LLC
MacOS 10.6.8, Apache 2.2+, PHP 5.4.16, MySQL 5.5.28
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #32

  • Jackie
  • Jackie's Avatar
  • Offline
  • Platinum
  • Posts: 4691
Peter37 wrote:
Hello ToyGuy,
as I stated about 18 Hrs ago, my Gedcom lines start with a 2 !
My understanding sofar is that the path prefix is removed during transfer by the Gedcom Media Path. It is usually the case BUT not in yours
In the mean time I had some discussions with "Jackie" which seem to have led very close to the problem and a solution.
Would you care to comment on that discussion?

Hello Peter,

Stephen is correct. You need to remove those extra parts of the path refering to the folder in your computer.

Thank you for confirming the path where are "physically" stored your images. /home/www/web1786/html/webtrees/webtrees/data/media/

NO, we clearly see that the path prefix was not removed during the first import of your original GEDCOM file.
Why?
We don't exactly know how you uploaded the gedcom, I guess you ticked the checkbox when you should not have done it?


Last Edit: 3 years 11 months ago by Jackie.
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #33

  • Jackie
  • Jackie's Avatar
  • Offline
  • Platinum
  • Posts: 4691
Hello Peter,

Your post #23 above:
Familie%20Gentzsch&cb=41e37ed0_
4. Name of the Gedcom file: This is generated by my Family Tree Software on my PC. It actually is: Gentzsch Familienstammbaum.ged. - This has never caused a problem, so I did not see a reason to change.

This has never caused a problem in your computer but what would happen if used in other systems?

As you can see in the URLs generated, webtrees wrote Familie%20Gentzsch&cb=41e37ed0_
not Gentzsch_Familienstammbaum.ged

Greg would be better than me to explain technical reasons why webtrees tells you:
The name you give it will be used to generate URLs and filenames, so you should choose something short, simple, and avoid punctuation.

EDIT:
Last Edit: 3 years 11 months ago by Jackie.
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #34

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 10250
Jackie wrote:
Greg would be better than me to explain technical reasons why webtrees tells you:
The name you give it will be used to generate URLs and filenames, so you should choose something short, simple, and avoid punctuation.

You can use any characters you like. BUT, anything other than simple ascii characters will get encoded, and look ugly/unreadable when the URL is written down, e.g. when you are emailing a link to someone. Also, it is very difficult for people to type letters with accents or non-latin characters.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #35

  • Peter37
  • Peter37's Avatar
Thank you all for your efforts and the input you have given. - The conclusion now sound plausible to me.
To summarize my unterstanding, here are the next steps I plan to do:
1. Verify again that I cannot manipulate my PC-Software such that it issues a different Gedcom
2. Rename the Gedcom with a shorter name - probably Gentzsch.ged
3. Eliminate the path prefix in the Gedcom the way ToyBoy has suggested
4. Generate a new Family Tree - Also with a simpler name. - Certainly without blanks!
5. Import the new Gedcom file
6. Upload the pictures to data/media
7. Pray that it all works

I may need a couple of days to complete this exercise, but you certainly will hear from me when I'm done.
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #36

  • Peter37
  • Peter37's Avatar
Sorry guys, I am back again.
I now have done the following:
1. Reexport a gedcom file from my PC-software using gen.ged as a name
2. Removed the path prefixes as proposed. A typical media-line now is:
1 FILE Gentzsch-Peter-2001.jpg
3. Removed the complete path referring to the path prefixes in data/media including the pictures I had put there.
4. Generated a new family tree named "Gentzsch"
5. Imported gen.ged without ticking the checkbox
6. Set Default individual and privacy. - Confirmed that there is no Gedcom media path shown.
7. Still did not find any pictures in my family tree!!
8. confirmed that the pictures are still in media. - Media still lists them as "unused".
9. Tried to upload individual picture: File already exists.
10. I find it strange that the individual page still is looking for the pictures under: gentzsch-wiesbaden.de/webtrees/webtrees/mediafirewall.php?mid=M5756&ged=Familie%20Gentzsch&cb=75c7703a
I thought that "Familie Gentzsch" should not be used anymore in this new family tree
11. Finally I have repeated the same exercise in a completely new webtrees installation, but no different result!!
Did I miss anything?
Any suggestion what I could try next??
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #37

  • ToyGuy
  • ToyGuy's Avatar
  • Offline
  • Moderator
  • Live like it's Christmas every day - Santa Stephen
  • Posts: 4922
Peter
It is virtually impossible for us to tell what is contained in your family tree file (GEDCOM) or your configuration without seeing it.
Why don't you zip up the GEDCOM and send me a copy and I'll review it for possible problems?
Otherwise, I would need admin access to your tree, FTP access to your drives and PhpMyAdmin access to your SQL with usernames and passwords.

I am afraid you may not be familiar enough with GEDCOM or with operating a webserver to be able to manage this yourself. More realistically, you are a prime candidate for one of the several specialized webtrees hosting services. Running your own server is not for the faint of heart, nor is the added burden of the webtrees resource demands common to low end hosts.
Santa Stephen the Fabled Santa
Latest webtrees at MyArnolds.com
Hosted by webtreesonline.com, a division of GeneHosts LLC
MacOS 10.6.8, Apache 2.2+, PHP 5.4.16, MySQL 5.5.28
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #38

  • hermann
  • hermann's Avatar
  • Offline
  • New
  • Posts: 97
Hi Peter,
up to point 9 everything seems to be ok (only a remark on point 2 "1 FILE Gentzsch-Peter-2001.jpg": I'm avoiding small and capital letters in file names because sometimes Unix and Windows hosts have problems with them, but this not the reason for your problem).
Your Point "9. Tried to upload individual picture: File already exists." is ok, because even if the file is unused, it is there, so you cannot upload it with the same file name. What happens if you upload a new file? Is it used in the correct manner?
In your Point 10 "ged=Familie%20Gentzsch" is strange. Please open the administration menu, click on the main topic "Family trees". Then you should see one box "Family tree" and direct below (!) these two words there is in green color the name of your tree which should be used in the "ged=" part.
webtrees 1.7.9 (many additional modules); PHP 7.0.15;
ahnen.hartenthaler.eu/
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #39

  • Peter37
  • Peter37's Avatar
Hello ToyGuy,
thank you for offering to review my Gedcom.
Attached is the "cleaned" Gedcom which I used as input for webtrees.
The administrator has disabled public write access.

Media address Problem 2 3 years 11 months ago #40

  • Peter37
  • Peter37's Avatar
Hello Hermann,
as suggested, I have uploaded one more picture. This is uploaded to the media folder, but is not recognized by the family tree.
I also went to admin: as expected, there are now to boxes with family trees: "Familie Gentzsch" and "Gentzsch" with Familie Gentzsch on first place. - To me this seems correct since I did not delete my first family tree
The administrator has disabled public write access.
Moderators: makitso
Powered by Kunena Forum