This Help forum is for issues relates to the latest release (1.5.x). For issues related to beta or github version please use their own Help forum.
Before asking for help please read "How to request help" by clicking on that tab above here.

TOPIC: Blank Pedigree page before & after upgrade to 1.3

Blank Pedigree page before & after upgrade to 1.3 4 years 9 months ago #1

  • worsin
  • worsin's Avatar
We have a problem with our Pedigree pages. When you click on Pedigree and then select one of the people listed the content section of that page ends up blank.

No error message or anything is displayed.

One thing i can expand on to help point you in the right direction is that when i try to approve some actions i get a message that says "This information is private and cannot be shown." This never happened before and i am logged in as admin.

Please instruct how we can either fix this problem or find more information for you to assist us in a resolution.

Thanks in advance!
Last Edit: 4 years 9 months ago by worsin.
The administrator has disabled public write access.

Blank Pedigree page before & after upgrade to 1.3 4 years 9 months ago #2

  • fisharebest
  • fisharebest's Avatar
  • Online
  • Administrator
  • Posts: 11149
Can you post the URL of a page with the problems?
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Blank Pedigree page before & after upgrade to 1.3 4 years 9 months ago #3

  • worsin
  • worsin's Avatar
The administrator has disabled public write access.

Blank Pedigree page before & after upgrade to 1.3 4 years 9 months ago #4

  • fisharebest
  • fisharebest's Avatar
  • Online
  • Administrator
  • Posts: 11149
Thanks. Your problem is apache/mod_security.

See the entry for "The pages for individuals are blank, but other pages are OK " at wiki.webtrees.net/en/Frequently_Asked_Questions
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Blank Pedigree page before & after upgrade to 1.3 4 years 9 months ago #5

  • worsin
  • worsin's Avatar
Ok ty we will try this out.
The administrator has disabled public write access.

Blank Pedigree page before & after upgrade to 1.3 4 years 9 months ago #6

  • worsin
  • worsin's Avatar
Got this to work thanks for the fix!
Last Edit: 4 years 9 months ago by worsin.
The administrator has disabled public write access.

Blank Pedigree page before & after upgrade to 1.3 4 years 9 months ago #7

  • fisharebest
  • fisharebest's Avatar
  • Online
  • Administrator
  • Posts: 11149
Your webserver is blocking files with the word "cookie" in their names.

This blocks the popular and widely used "jquery.cookie.js" plugin.

So, you must

(a) rename this file on the server to something without the letters c-o-o-k-i-e in the name.
(b) change references to this file wherever it occurs in the code. Currently this is just the individual.php script.

You could also

(c) email your tech support, asking them to update their ruleset for apache/mod-security, to anything issued after 2010.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Blank Pedigree page before & after upgrade to 1.3 4 years 9 months ago #8

  • worsin
  • worsin's Avatar
Yup just edited my post...got it to work thanks!
The administrator has disabled public write access.
Do you need a web hosting solution for your webtrees site?
If you prefer a host that specialises in webtrees, the following page lists some suppliers able to provide one for you: 
Powered by Kunena Forum