This Help forum is for issues relates to the latest release (1.5.x). For issues related to beta or github version please use their own Help forum.
Before asking for help please read "How to request help" by clicking on that tab above here.
  • Page:
  • 1

TOPIC: Referrer problem

Referrer problem 5 years 7 months ago #1

  • Forscher
  • Forscher's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 18
Hello,

when I click on the save button for changing the "My page"-site for a user, no referrer is send after loading. So I have to reload the site before I can change the blocks for an other user.

admin -> Users -> Username -> plus -> Change the blocks on this page -> save -> no referrer


Cheers

Please Log in or Create an account to join the conversation.

Referrer problem 5 years 7 months ago #2

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 12925
It works for me. What are the exact steps? What browser?
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Referrer problem 5 years 7 months ago #3

  • Forscher
  • Forscher's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 18
exact steps:
admin -> Users -> Username -> plus -> "Change the blocks on this page" -> save -> no referrer -> again "Change the blocks on this page" -> save -> no changes on the my-Page-Site

here the image




Browser:
Firefox 32.0.3
Add-Ons (all actual): AdblockPlus, BetterPrivacy, ClassicThemeRestorer, CookieMonster, Disconnect, gui:config, FoxyProxy, Https-everywhere, noscript, prefbar, refcontrol, TabMixPlus
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by Forscher.

Referrer problem 5 years 7 months ago #4

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 12925
The "referer" headers are being sent. This is what I see.

The three requests are

GET admin_users.php (fetch the row, after the green (+) is clicked)
GET index_edit.php (the dialog box)
POST index_edit.php (save the updates)

The referer header is included.



If I repeat the process - and edit the details again, it works OK.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
Attachments:

Please Log in or Create an account to join the conversation.

Referrer problem 5 years 7 months ago #5

  • Forscher
  • Forscher's Avatar Topic Author
  • Offline
  • New
  • New
  • Posts: 18
ok, then I have no idea what it could be

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum