This Help forum is for issues relates to the latest release (1.6.x). For issues related to beta or github version please use their own Help forum.
Before asking for help please read "How to request help" by clicking on that tab above here.
  • Page:
  • 1

TOPIC:

webtrees under NGINX 5 years 10 months ago #1

  • fa10175
  • fa10175's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 334
Je voudrais connaître si quelqu'un a installé "webtrees 1.6.2" sur un serveur "NGINX".
Quand je tapes "http://localhost/", il me réponds
Impossible d'afficher ce siteweb
Le sites Web "https://localhost:80/login.php?url=index.php%3F" semble indisponible l'erreur précise est SSL handshake failed
je ne travailles pas en SSL. Je n'ai pas converti le site pour être accessible en https.
Que faut-il faire dans nginx.conf ou dans default (sites-available) ou ailleurs pour ne pas avoir ce problème.
Merci
Fa10175

I would like to know if anyone has installed "webtrees 1.6.2" on a "NGINX" server.
When I tapes "http: // localhost /", he answer me
Can not display this WebSite
The website "https: // localhost: 80 / login.php url = index.php% 3F" seems unavailable precise error SSL handshake failed
I do not work with SSL. I have not converted the site to be accessible in https.
What should we do in nginx.conf or default (sites-available) or elsewhere for not having this problem.
Thanks
Fa10175
- nginx 1.14.2 - PHP 7.3.9- - MariaDB 10.3.17-MariaDB-
- Local server -
- webtrees - SVN - latest
- webtrees 1.7.17

Please Log in or Create an account to join the conversation.

webtrees under NGINX 5 years 10 months ago #2

  • fisharebest
  • fisharebest's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 14491

I would like to know if anyone has installed "webtrees 1.6.2" on a "NGINX" server.


The demo server uses NGINX. e.g. dev.webtrees.net/demo-stable/

The website "https: // localhost: 80 / login.php url = index.php% 3F" seems unavailable precise error SSL handshake failed

I have not converted the site to be accessible in https.


Your server is telling webtrees that it is configured to use HTTPS and port 80.

Create a file phpinfo.php, containing
<?php phpinfo(INFO_VARIABLES); ?>

and view the file using http://localhost/phpinfo.php

What info do you see?
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

webtrees under NGINX 5 years 10 months ago #3

  • fa10175
  • fa10175's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 334
Thanks Greg
I do nothing to configure in https.
For me I say http.
Here the result asked: http://localhost/phpinfo.php

I don't know if this help you to give me a solution
- nginx 1.14.2 - PHP 7.3.9- - MariaDB 10.3.17-MariaDB-
- Local server -
- webtrees - SVN - latest
- webtrees 1.7.17
Attachments:

Please Log in or Create an account to join the conversation.

webtrees under NGINX 5 years 10 months ago #4

  • Jackie
  • Jackie's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 4755
Bonjour fa10175,

Vérifiez la table wt_site_setting de votre MySQL database. Vous devez supprimer la ligne LOGIN_URL
webtrees n'a pas besoin d'une URL spécifique sauf pour une connexion https/

Please Log in or Create an account to join the conversation.

webtrees under NGINX 5 years 10 months ago #5

  • fa10175
  • fa10175's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 334
Merci Jackie
je n'ai pas cette variable dans wt_site_setting.

Thanks Jackie
i don' have this variable in wt_site_setting.
- nginx 1.14.2 - PHP 7.3.9- - MariaDB 10.3.17-MariaDB-
- Local server -
- webtrees - SVN - latest
- webtrees 1.7.17

Please Log in or Create an account to join the conversation.

webtrees under NGINX 5 years 10 months ago #6

  • fisharebest
  • fisharebest's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 14491
Your server has set the "HTTPS" variable:

$_SERVER["HTTPS"]

It is normal to set this variable only when a server is using HTTPS.

This is causing webtrees to think that the server is using https://
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

[Solved-Resolu]webtrees under NGINX 5 years 10 months ago #7

  • fa10175
  • fa10175's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 334
Thanks Greg
in the file Fastcgi_params
fastcgi_param HTTPS is declared i suppose during the installationg Fastcgi .
I put # to comment and it's OK
Thanks again
- nginx 1.14.2 - PHP 7.3.9- - MariaDB 10.3.17-MariaDB-
- Local server -
- webtrees - SVN - latest
- webtrees 1.7.17

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum