This Help forum is for issues relates to the latest release (1.6.x). For issues related to beta or github version please use their own Help forum.
Before asking for help please read "How to request help" by clicking on that tab above here.
  • Page:
  • 1

TOPIC:

migrate site from 1.3.2 to 1.6.2 5 years 9 months ago #1

  • frogola
  • frogola's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 15
I have an old webtrees site version 1.3.2 with PHP 5.3.2 and apache 2.2.14 running on an old ubuntu VM. I want to migrate the site to a new AWS EC2 machine running more modern OS and software. Ideally I would jump to version 1.6.2 of webtrees.

Is there a recommended procedure for migrating? I am thinking of the following:

1. install mysql, apache and php on the new server
2. backup the webtrees mysql database and restore to the new server
3. copy the existing webtree files from old to new server
4. try to login to webtrees on the new server
5. if it works, run 'upgrade to webtrees 1.6.2' from the admin page

Just to make things more interesting, I'm planning on running mysql and apache in linked docker containers.

Since this upgrade jumps three versions I'm not very confident this will work. Any advice, known 'gotchas' or other recommendations?

Thank you for your attention.
-Frank

Please Log in or Create an account to join the conversation.

migrate site from 1.3.2 to 1.6.2 5 years 9 months ago #2

  • Jackie
  • Jackie's Avatar
  • Offline
  • Platinum Member
  • Platinum Member
  • Posts: 4755
Hi,

As publish in the Wiki = wiki.webtrees.net/en/Upgrading, it is not recommended to jump from v1.3.2 to v.1.6.2
There was a major change in media handling in version 1.4.0 and you should read wiki.webtrees.net/en/Media_Firewall

Please Log in or Create an account to join the conversation.

migrate site from 1.3.2 to 1.6.2 5 years 9 months ago #3

  • fisharebest
  • fisharebest's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 14491
> it is not recommended to jump from v1.3.2 to v.1.6.2

This is true. One of the upgrade steps relied on some old code that no longer exists.

But, this should be fixed in 1.7.0 - which I plan to release later today - so you should be able to upgrade directly to 1.7.0

The comments about the changes in the "media firewall" in 1.4.0 still apply. See wiki.webtrees.net/en/Media_Firewall
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum