This Help forum is for issues relates to the latest release (1.7.10/11/12). For issues related to development versions please use their own Help forum.
Before asking for help please read "How to request help" by clicking on that tab above here."

TOPIC: [SOLVED] MacOS - Catalina - MAMP

MacOS - Catalina - MAMP 2 weeks 18 hours ago #1

  • dhwtrees
  • dhwtrees's Avatar
  • Offline
  • New
  • Posts: 34
I am using localhost through MAMP on an iMac. Simply, MAMP now has problems and I am interested to know if anyone has the same issues?

1. On the MAMP panel the green radio button for Apache Server remains active. The Apache server can be halted, the machine restarted and the button remains lit. Whatever, localhost flags connection errors.

2.Swap to Nginx, the panel continues to show Apache but localhost will now respond.

3. Switch the server off/on - no change, always Apache even though Preferences are set to Nginx. Nginx is running even though Apache is flagged.

It would appear that the switching logic has problems in MAMP when using Catalina. Never failed with Mojave OS. I can use webtrees but it takes persistence, working from the MAMP panel, flipping between servers + restarts to get a stable localhost. After some time Nginx is running with a correctly labelled green radio button but would that persist through a cold start? Using 'Stop Servers' or closing the Panel has an apparently unpredictable outcome. Firing up MySQL+Server from Terminal or a shell script then I have the same connection issues - the panel at least shows the Apache - Nginx - on/off confusion.

Thanks Dave
The administrator has disabled public write access.

[SOLVED] MacOS - Catalina - MAMP 1 week 6 days ago #2

  • dhwtrees
  • dhwtrees's Avatar
  • Offline
  • New
  • Posts: 34
Problem solved.
Well, at least, partially solved.
The MAMP UI panel has problems in identifying which server is running or even if any server is running. Came back to using an applescript which with adjustments to detecting the server and some bulit in delay, mostly works.
Last Edit: 1 week 6 days ago by dhwtrees. Reason: Comment re. fix.
The administrator has disabled public write access.
Powered by Kunena Forum