This Help forum is for issues relates to the latest release (1.7.10/11/12). For issues related to development versions please use their own Help forum.
Before asking for help please read "How to request help" by clicking on that tab above here."

TOPIC: [SOLVED] No media objects displayed when part of source

No media objects displayed when part of source 4 weeks 1 day ago #1

  • Rick
  • Rick's Avatar
  • Offline
  • New
  • Posts: 12
Hi all,

As an unauthenticated user I cannot see media objects in the Facts and Events tab when the media objects are placed in a source citation like this:
2 SOUR @S78@
3 OBJE @M210@
3 PAGE Archief van de Gemeente Brielle, (1811-1950), archiefnummer 084, inventarisnummer 258, aktenummer 13

When the media object has no source citation as above then the media object is displayed:
2 OBJE @M209@
2 SOUR @S77@
3 PAGE nr 1003, jaargang 18

(I forgot to place the media object under the source like above, that's how I noticed the difference)

However, in the tab Media all items are displayed for unauthenticated users.

I'd expect to see media objects in the Facts and Events tab as well in this case.
Question is: is this by design, an issue in 1.7.14, or lack of knowledge on my part how source citations and media objects are handled for an unauthenticated user in the Facts and Events tab?

Regards,
Rick
The administrator has disabled public write access.

No media objects displayed when part of source 4 weeks 1 day ago #2

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Posts: 11556
> As an unauthenticated user I cannot see media objects in the Facts and Events tab when the media objects are placed in a source citation like this:

This is probably because the unauthenticated user does not have permission to view the source - and therefore cannot see the source-citation or the media object that is part of the source citation.

> When the media object has no source citation as above then the media object is displayed:

In this example, the media object is linked to the *event*, not to the source-citation.

> Question is: is this by design

Yes. It is the privacy rules working as designed.

If you want your visitors to see these source citations, you must make the sources public.

If you don't know how the privacy rules work, then ask.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

No media objects displayed when part of source 4 weeks 1 day ago #3

  • Rick
  • Rick's Avatar
  • Offline
  • New
  • Posts: 12
Thank you for your explanation.

I changed the rules under Privacy restrictions in the Control Panel -> Manage Family Tree section accordingly (Source and Repository both visible to Visitors instead of Members) and it works.

Regards,
Rick
The administrator has disabled public write access.

[SOLVED] No media objects displayed when part of source 4 weeks 1 day ago #4

  • Rick
  • Rick's Avatar
  • Offline
  • New
  • Posts: 12
Problem solved.
The administrator has disabled public write access.
Powered by Kunena Forum