This Help forum is for issues relates to the latest release (1.7.2). For issues related to beta or github version please use their own Help forum.
Before asking for help please read "How to request help" by clicking on that tab above here."
  • Page:
  • 1
  • 2

TOPIC:

Accessing media through my face tagging addon 5 years 2 weeks ago #21

  • Shemwell
  • Shemwell's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 206
I get the tab and the face icon, but when I click on it all I get is a pop up box with "Drop your image here" or a "select from disk" icon that when clicked gives me an error : D:\Webserver\data\localweb\webtrees-dev\includes\session.php:193 D:\Webserver\data\localweb\webtrees-dev\app\Module\face_tagging\face-detect.php:193 Undefined variable: err
#0 \app\Module\face_tagging\face-detect.php:193 ErrorException("D:\Webserver\data\localweb\webtrees-dev\app\Module\face_tagging\face-detect.php:193 Undefined variable: err")
Barry

Please Log in or Create an account to join the conversation.

Accessing media through my face tagging addon 5 years 2 weeks ago #22

  • lambosprit
  • lambosprit's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 12
Thanks. I'll take a look and get back to you.

Please Log in or Create an account to join the conversation.

Accessing media through my face tagging addon 5 years 1 week ago #23

  • lambosprit
  • lambosprit's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 12
Give this version a try.

face_tagging.zip

Please Log in or Create an account to join the conversation.

Accessing media through my face tagging addon 5 years 1 week ago #24

  • Shemwell
  • Shemwell's Avatar
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 206
Ok... nothing but a box that says "Uploading" ...I'll wager it's that I have no clue how to install OpenCV, I just extracted it into the webtrees main directory. If it's more complicated than any other module I'm lost.
Barry

Please Log in or Create an account to join the conversation.

Accessing media through my face tagging addon 5 years 6 days ago #25

  • lambosprit
  • lambosprit's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 12
Well that's more like it.

So the part of the opencv install you've missed is you have to set its location in the environment variables.
type the following in a cmd prompt. Run the first line if you're running 32bit windows or the second line if 64bit. These should work in windows 7 or 10. Replace the part in italics with the directory where you put opencv.

setx -m OPENCV_DIR opencv directory\Build\x86\vc11
setx -m OPENCV_DIR opencv directory\Build\x64\vc11


you should then get the uploading but after a while the picture should return with the faces tagged.

If it doesn't work try right clicking on the explorer window and selecting inspect. The developer window will come up and should show any errors in the bottom half of the screen.

Please Log in or Create an account to join the conversation.

Last edit: by lambosprit.
  • Page:
  • 1
  • 2
Powered by Kunena Forum