This Help forum is for issues relates to the latest release (1.7.8). For issues related to beta or github version please use their own Help forum.
Before asking for help please read "How to request help" by clicking on that tab above here."
  • Page:
  • 1

TOPIC:

Error: escapeshellarg() disabled 3 years 11 months ago #1

  • jprause
  • jprause's Avatar Topic Author
  • Offline
  • Junior
  • Junior
  • Posts: 184
My website is configured like this:
Sending email > Messages = 'use PHP mail to send messages',
Users' preferred contact method = 'Internal messaging with emails';

When sending a message to a webtrees user I get an error message (in the website error log):
Mail: /data/web/virtuals/37758/virtual/www/subdom/fami/vendor/swiftmailer/swiftmailer/lib/classes/Swift/Transport/MailTransport.php:252 escapeshellarg() has been disabled for security reasons

My webhosting's staff say they can't enable escapeshellarg() function for security reasons.
Is there any sensible way how to deal with this issue?
Thanks.
Josef

webhosting:-- webtrees 2.0.10, PHP version 7.4.11, MySQL 5.7.21, testing webtrees 2.0.10
local desktop:-- webtrees 2.0.10, PHP version 7.4.3, MySQL 8.0.21, Apache2 2.4.29, Linux Ubuntu 20.04 64bit

Please Log in or Create an account to join the conversation.

Error: escapeshellarg() disabled 3 years 11 months ago #2

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13693
The function "escapeshellarg()" is NOT a security risk. It is a very simple string function. It does approximately the same as this:
function escapeshellarg($input) {
  return "'" . str_replace('\'', '\\\'', $input) . "'";
}

> My webhosting's staff say they can't enable escapeshellarg() function for security reasons.

I would disagree with this. /sigh.

> Is there any sensible way how to deal with this issue?

Use SMTP mail instead? Does your webhost provide SMTP?
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Error: escapeshellarg() disabled 3 years 11 months ago #3

  • jprause
  • jprause's Avatar Topic Author
  • Offline
  • Junior
  • Junior
  • Posts: 184
Instead of presumably hopeless discussion with my webhost I've set
Sending email > Messages = 'use SMTP to send messages' and used my Google mail account.
The hint at the bottom of SMTP mail server section is very useful.
Now it works fine, thank you.
Josef

webhosting:-- webtrees 2.0.10, PHP version 7.4.11, MySQL 5.7.21, testing webtrees 2.0.10
local desktop:-- webtrees 2.0.10, PHP version 7.4.3, MySQL 8.0.21, Apache2 2.4.29, Linux Ubuntu 20.04 64bit

Please Log in or Create an account to join the conversation.

Last edit: by jprause.

[SOLVED] Error: escapeshellarg() disabled 3 years 11 months ago #4

  • jprause
  • jprause's Avatar Topic Author
  • Offline
  • Junior
  • Junior
  • Posts: 184
Problem solved.
Josef

webhosting:-- webtrees 2.0.10, PHP version 7.4.11, MySQL 5.7.21, testing webtrees 2.0.10
local desktop:-- webtrees 2.0.10, PHP version 7.4.3, MySQL 8.0.21, Apache2 2.4.29, Linux Ubuntu 20.04 64bit

Please Log in or Create an account to join the conversation.

[SOLVED] Error: escapeshellarg() disabled 3 years 11 months ago #5

  • fisharebest
  • fisharebest's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 13693
The swiftmailer library has just been updated. It no longer uses the escapeshellarg function.

I will include this update in the next release of webtrees.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Powered by Kunena Forum