This Help forum is for issues relates to the latest release (1.7.9). For issues related to beta or github version please use their own Help forum.
Before asking for help please read "How to request help" by clicking on that tab above here."

TOPIC: In manage family trees, when selecting import

In manage family trees, when selecting import 5 months 6 days ago #1

  • mboucher
  • mboucher's Avatar
  • Offline
  • New
  • Posts: 53
In manage family trees with multiple trees, when selecting import, the selection of a family file to import into changes and it switches to a previous or first file listed in the menu. It is difficult to figure out how to work with this.
I have restarted the browser, changed browsers, rebooted the computer, but the issue remains. Eventually it will stick and I can import a new file to the correct database.
I use both Firefox and Chrome (latest versions for Windows 10).
Anyone else noticed this?
Michael Boucher
php7.1.20
mySQL5.5
wt version 1.7.11
www.mike-boucher.com/webtrees1.7
www.mike-boucher.com/BBunchwt (version 1.7)
The administrator has disabled public write access.

In manage family trees, when selecting import 5 months 6 days ago #2

  • fisharebest
  • fisharebest's Avatar
  • Online
  • Administrator
  • Posts: 10445
> the selection of a family file to import into changes and it switches to a previous or first file listed in the menu.

Do you mean the list of .GED files in the /data folder?

The last file that you imported into this tree should be selected by default.

Are you saying that the default selection is wrong?

> Anyone else noticed this?

No...
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

In manage family trees, when selecting import 5 months 6 days ago #3

  • mboucher
  • mboucher's Avatar
  • Offline
  • New
  • Posts: 53
No the database being imported into changes on selecting import or export.
So you would be importing into the wrong database.
Michael Boucher
php7.1.20
mySQL5.5
wt version 1.7.11
www.mike-boucher.com/webtrees1.7
www.mike-boucher.com/BBunchwt (version 1.7)
The administrator has disabled public write access.

In manage family trees, when selecting import 5 months 5 days ago #4

  • Tel
  • Tel's Avatar
  • Offline
  • New
  • Posts: 39
I don't normally use this method of importing, but have just tried what Michael suggested and agree this does appear to be an issue.

So for example, I have four family trees:
- Forder
- Gray
- Grint
- Skipper

If I navigate to Family Trees > Manage Family Trees > Import webtrees displays the default Family Tree (which happens to be Grint in my case) whether I Import from Forder, Gray, Grint or Skipper.

The issue appears to be that the Import (from a file on your server) option sets the page title to the default family tree, rather than the tree you are importing in to. Where no family tree is set as the default webtrees selects the first tree from the list. However, the form action indicates the GEDCOM will be imported into the correct Family Tree (denoted by the URL query string eg. yourdomainname.com/admin_trees_manage.php?action=importform&gedcom_id=9). In this example 'GEDCOM_ID=9' corresponds to 'Skipper' family, not 'Grint', so the GEDCOM will be imported into the correct family tree - despite the page title. I've never noticed this before but as the import works identically whether importing from a file on the server or from a file on your computer I believe it will import the GEDCOM into the correct family tree.

This does appear to be a bug in the way the page title is displayed. You can temporarily change the default family tree to the one you want to import to (which may provide some assurance), but this doesn't actually effect the import as far as I can see, only the page title displayed on screen.
Terry
running webtrees 1.7.11 at mynorfolkancestors.net
on PHP 7.2, MySQL 5.6.
Last Edit: 5 months 5 days ago by Tel. Reason: Added clarification where no default tree is selected
The administrator has disabled public write access.

In manage family trees, when selecting import 5 months 4 days ago #5

  • mboucher
  • mboucher's Avatar
  • Offline
  • New
  • Posts: 53
Glad I am not having pilot error. Thanks for letting me know it wasn't just me.
Michael Boucher
php7.1.20
mySQL5.5
wt version 1.7.11
www.mike-boucher.com/webtrees1.7
www.mike-boucher.com/BBunchwt (version 1.7)
The administrator has disabled public write access.

In manage family trees, when selecting import 5 months 2 days ago #6

  • Luenissla
  • Luenissla's Avatar
  • Offline
  • Junior
  • Posts: 127
I have not yet discovered this problem when importing. It would be very bad too. I always have an import from a file on my PC and not from a file on the server.

I found a similar problem when I need to add an unlinked person. She has landed in another tree. I can prevent this by first positioning myself exactly on this file and only then switching to the administration.
Best regards
Hans-Joachim (Lünenschloß)
The administrator has disabled public write access.
Powered by Kunena Forum