This Help forum is for issues relates to the latest release (1.7.9). For issues related to beta or github version please use their own Help forum.
Before asking for help please read "How to request help" by clicking on that tab above here."

TOPIC: [SOLVED] Install hanging

Install hanging 1 week 1 day ago #1

  • philld
  • philld's Avatar
  • Offline
  • New
  • Posts: 25
I want to setup a new "install" for a friend. Have downloaded v1.7.9 (which is what I am currently running for my own tree) but am having a problem with the wizard hanging when doing the install.

It does the configuration check and all is okay there - the problem comes on the next step - the database connection. I get the "Setup wizard for webtrees" line but that is all that appears on the screen. Tried different browers (firefox, chrome) and both are displaying the same situation.

The config that I am working with is: webtrees v1.7.9; php 5.6.29; mysql 10.1.26-MariaDB - PCLinuxOS MariaDB Server

Is there something else needed OR a way to install without the wizard?
The administrator has disabled public write access.

Install hanging 1 week 1 day ago #2

  • fisharebest
  • fisharebest's Avatar
  • Online
  • Administrator
  • Posts: 10299
> I get the "Setup wizard for webtrees" line but that is all that appears on the screen.

Most likely, it is trying to connect to the database, but is getting a fatal error, and your
webserver is configured not to show error messages.

1) Check the webserver error logs for any messages.
2) View the page source (typically CTRL-U in your browser) to see if there are any error messages concealed in the HTML.
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Install hanging 1 week 1 day ago #3

  • philld
  • philld's Avatar
  • Offline
  • New
  • Posts: 25
This is what I found in the error log - not a php guru - is that line 100 in the Database.php module?

[Sat Jul 07 13:25:25 2018] [error] [client xx.xxx.xxx.102] PHP Fatal error: Uncaught exception 'ErrorException' with message 'date(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in /home/admin/wwwool/app/Database.php:100\nStack trace:\n#0 [internal function]: Fisharebest\\Webtrees\\{closure}(2, 'date(): It is n...', '/home/admin/www...', 100, Array)\n#1 /home/admin/wwwool/app/Database.php(100): date('P')\n#2 /home/admin/wwwool/setup.php(251): Fisharebest\\Webtrees\\Database::createInstance('localhost', '3306', '', '', '')\n#3 {main}\n thrown in /home/admin/wwwool/app/Database.php on line 100, referer: xxx.duckdns.org/setup.php
Last Edit: 1 week 1 day ago by philld. Reason: mask url
The administrator has disabled public write access.

Install hanging 1 week 1 day ago #4

  • fisharebest
  • fisharebest's Avatar
  • Online
  • Administrator
  • Posts: 10299
Set the timezone in the php.ini file on your server, using a line like this:

date.timezone = UTC
Greg Roach - This email address is being protected from spambots. You need JavaScript enabled to view it. - fisharebest.webtrees.net
The administrator has disabled public write access.

Install hanging 1 week 1 day ago #5

  • philld
  • philld's Avatar
  • Offline
  • New
  • Posts: 25
Thanks - that did the trick!
The administrator has disabled public write access.

[SOLVED] Install hanging 1 week 1 day ago #6

  • philld
  • philld's Avatar
  • Offline
  • New
  • Posts: 25
Problem solved.
The administrator has disabled public write access.
Powered by Kunena Forum