Web based family history software

Question webtrees 2.2.0-dev

  • Peter_S
  • Topic Author
  • Offline
  • Premium Member
  • Premium Member
More
1 year 1 month ago #1 by Peter_S
webtrees 2.2.0-dev was created by Peter_S
Where can I download the current development release?

Best regards
Peter

Peter

webtrees 2.1.20, vesta modules, chart modules of magicsunday, extended family and imprint of hartenthaler
PHP 8.2.18, MariaDB 10.3.39
Webhosting: genonline.de

Please Log in or Create an account to join the conversation.

  • bertkoor
  • Offline
  • Platinum Member
  • Platinum Member
  • Greetings from Utrecht, Holland
More
1 year 1 month ago #2 by bertkoor
Replied by bertkoor on topic webtrees 2.2.0-dev
Development is done with git in branches, see
github.com/fisharebest/webtrees/branches

I don't see anything related to 2.2. Work on 2.1 isn't finished yet, me thinks it exists in concept (roadmap) only.

stamboom.BertKoor.nl runs on webtrees v1.7.13

Please Log in or Create an account to join the conversation.

  • Peter_S
  • Topic Author
  • Offline
  • Premium Member
  • Premium Member
More
1 year 1 month ago #3 by Peter_S
Replied by Peter_S on topic webtrees 2.2.0-dev
What‘s about dev.webtrees.net/demo-dev/tree/demo ? Welcome to the webtrees 2.2.0-dev demo server. Isn‘t it 2.2.0?

Peter

webtrees 2.1.20, vesta modules, chart modules of magicsunday, extended family and imprint of hartenthaler
PHP 8.2.18, MariaDB 10.3.39
Webhosting: genonline.de

Please Log in or Create an account to join the conversation.

  • bertkoor
  • Offline
  • Platinum Member
  • Platinum Member
  • Greetings from Utrecht, Holland
More
1 year 1 month ago #4 by bertkoor
Replied by bertkoor on topic webtrees 2.2.0-dev
Then 2.2 is branch "main"?

stamboom.BertKoor.nl runs on webtrees v1.7.13

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #5 by photon flip
Replied by photon flip on topic webtrees 2.2.0-dev
Check out main.app.webtrees.php line 146 public const VERSION = '2.2.0' . self::STABILITY

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #6 by makitso
Replied by makitso on topic webtrees 2.2.0-dev
The code on the github site does not contain the vendor folder. You need to install and run composer to generate this folder. Check the README.md file for more details.

Rob
www.skatekey.net ( webtrees 2.1 beta GitHub)
webtrees forum admin
Author custom css module
PHP 8.1.21
Hosted at tigertech.net

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #7 by ddrury
Replied by ddrury on topic webtrees 2.2.0-dev
... and install node/npm to install and compile all the modules found in package.json (npm install) and run webpack.mix (npm run production)

--
Dave

Local: Win 11 Pro, WSL2/Ubuntu20.04.4, Apache 2.4.51, PHP 7.4.26/8.1.7, MySQL 8.0.27
Production: Litespeed 8.0.1, PHP 8.1.9, MySQL 8.0.26

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #8 by makitso
Replied by makitso on topic webtrees 2.2.0-dev
Dave, I may be wrong but if he just wants to run the latest code and not do any development he doesn't need node/npm?

Rob
www.skatekey.net ( webtrees 2.1 beta GitHub)
webtrees forum admin
Author custom css module
PHP 8.1.21
Hosted at tigertech.net

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago - 1 year 1 month ago #9 by ddrury
Replied by ddrury on topic webtrees 2.2.0-dev
[strike]You use npm to run webpack.mix.js which compiles the javascript and css found in node_modules and /resources and put the results in /public which is where webtrees looks to find them, without doing this you don't have the key scripts (eg vendor.min.js & webtrees.min.js) and css (vendor.min.css, webtrees.min.css and all the css for the themes[/strike]

Sorry Rob, Looks like you're correct - I didn't realise Greg puts the stuff in /public - mea culpa

--
Dave

Local: Win 11 Pro, WSL2/Ubuntu20.04.4, Apache 2.4.51, PHP 7.4.26/8.1.7, MySQL 8.0.27
Production: Litespeed 8.0.1, PHP 8.1.9, MySQL 8.0.26
Last edit: 1 year 1 month ago by ddrury.

Please Log in or Create an account to join the conversation.

  • Peter_S
  • Topic Author
  • Offline
  • Premium Member
  • Premium Member
More
1 year 1 month ago #10 by Peter_S
Replied by Peter_S on topic webtrees 2.2.0-dev
@makitso is right. I just wanted to install the development version 2.2.0 additionally to see what new developments are in the pipeline. Unfortunately, I can't participate in further developments or customer modules due to my lack of PHP knowledge. I assumed that development versions can also be downloaded and installed similar to the current stable versions. But this is apparently not the case. Nevertheless many thanks to all for your valuable hints.

Best regards
Peter

Peter

webtrees 2.1.20, vesta modules, chart modules of magicsunday, extended family and imprint of hartenthaler
PHP 8.2.18, MariaDB 10.3.39
Webhosting: genonline.de

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #11 by fisharebest
Replied by fisharebest on topic webtrees 2.2.0-dev
There are no new features or changes in 2.2.

There are only changes to the third-party libraries.

Many have dropped support for PHP 7.4 and 8.0 - which means that webtrees must also drop support for these versions of PHP.

Some of these libraries are quite large, and contain a lot of features that we don't need.
I'm looking at a simpler/smaller replacement for them.

Greg Roach - greg@subaqua.co.uk - @fisharebest@phpc.social - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

  • norwegian_sardines
  • Offline
  • Platinum Member
  • Platinum Member
More
1 year 1 month ago #12 by norwegian_sardines
Replied by norwegian_sardines on topic webtrees 2.2.0-dev

Greg Said:
Many have dropped support for PHP 7.4 and 8.0 - which means that webtrees must also drop support for these versions of PHP.


My Synology web server has yet to support anything beyond v8.0 of PHP and there is no indication that they will support v8.1 or v8.2 in the near future. Will webtrees v2.2 require features not available in v8.0 of PHP?

Ken

Please Log in or Create an account to join the conversation.

More
1 year 1 month ago #13 by fisharebest
Replied by fisharebest on topic webtrees 2.2.0-dev
> Will webtrees v2.2 require features not available in v8.0 of PHP?

Yes. But updates will be back-ported into 2.1 for as long as is practical.

Greg Roach - greg@subaqua.co.uk - @fisharebest@phpc.social - fisharebest.webtrees.net

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum
}