Bienvenue, Invité
Nom d'utilisateur : Mot de passe :
Please do NOT post requests for help here. Use the Help forum for that.
  • Page :
  • 1

SUJET : webtrees 1.7.9

webtrees 1.7.9 il y a 3 ans 5 mois #1

  • fisharebest
  • Portrait de fisharebest Auteur du sujet
  • Hors Ligne
  • Administrator
  • Administrator
  • Messages : 12895
webtrees 1.7.9 is now available for download. As well as the usual translation updates and bug-fixes, this release includes new German census templates and improvements to the relationship calculator. You can now search for relationships via direct ancestors only, which is much faster on large/complex trees.

Note that downloads are now available from the GitHub server at github.com/fisharebest/webtrees/releases
The Launchpad server is no longer used.

As always, thank-you to everyone who has contributed - whether by updating translations, reporting issues, helping others on the forum, etc.

PHP 7.1 was released at the start of the month, and we can see in the statistics that a few sites are now using it. A few compatibility issues were discovered, which have been fixed. However one issue exists in a third-party library (pclzip) which will affect the auto-upgrade. To work around this, PHP 7.1 users will need to change the "memory_limit" setting in the PHP.INI to specify *bytes*, rather than megabytes. e.g. use "128000000" instead of "128M".

This is one symptom of a much larger problem. It is becoming increasingly difficult to write code that runs on many different versions of PHP. Currently, we support 5.3, 5.4, 5.5, 5.6, 7.0 and 7.1.

For this reason, I have decided that the next major release of webtrees (1.8.0) will require PHP 5.6 or higher.

If you use PHP 5.3, 5.4 or 5.5, then you really should upgrade to a supported version . If you (or your web host) cannot upgrade, then continue using webtrees 1.7.x.

The 1.7 branch will receive fixes for security issues, major bugs and updated translations - for as long as a significant number of people are using it.
Greg Roach - Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser. - fisharebest.webtrees.net

Connexion ou Créer un compte pour participer à la conversation.

webtrees 1.7.9 il y a 3 ans 5 mois #2

  • bertkoor
  • Portrait de bertkoor
  • Hors Ligne
  • Gold
  • Gold
  • Greetings from Utrecht, Holland
  • Messages : 1856
Many thanks! Upgrading now...

Very brave btw to release it just before Christmas. Fingers crossed you don't need to do much support on this release.

And a Happy New Year!
stamboom.BertKoor.nl runs on webtrees v1.7.13

Connexion ou Créer un compte pour participer à la conversation.

webtrees 1.7.9 il y a 3 ans 5 mois #3

Great that you released a new version just a few hours before christmas!

I use plesk to manage my webservers. Here it is not possible to enter "128000000" instead of "128M" for the PHP memory. If I try so, I get: "bad entry - try to enter the correct value followed by K, M, or G".
Workaround here: switch to PHP 7.0, make the upgrade, switch to 7.1...
My homepage: www.weiland24.de
My webtrees: webtrees.weiland24.de

Connexion ou Créer un compte pour participer à la conversation.

webtrees 1.7.9 il y a 3 ans 5 mois #4

  • fisharebest
  • Portrait de fisharebest Auteur du sujet
  • Hors Ligne
  • Administrator
  • Administrator
  • Messages : 12895
Then the automatic upgrade will fail for you. For the next upgrade, you must copy the files manually.
Greg Roach - Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser. - fisharebest.webtrees.net

Connexion ou Créer un compte pour participer à la conversation.

webtrees 1.7.9 il y a 3 ans 5 mois #5

Thanks to all who contributed to this upgrade!

Connexion ou Créer un compte pour participer à la conversation.

webtrees 1.7.9 il y a 3 ans 5 mois #6

Good work, as always. Happy Holidays!
webtrees 2.0.4 patched at visitusinmaputo.com/webtree PHP 7.2.9
webtrees 2.0 dev on local WampServer PHP 7.3.1

Connexion ou Créer un compte pour participer à la conversation.

webtrees 1.7.9 il y a 3 ans 4 mois #7

Hi all

Before upgrading to 1.79 on my local machine I thought I'd better check that I am doing the right thing.

A warning comes up regarding my my custom themes with red crosses next to them:

You should consult the theme’s author to confirm compatibility with this version of webtrees.
— You can re-enable these themes after the upgrade.
— Caution: old themes may not work, or they may prevent webtrees from working.

Has anything chnaged in 1.79 that would cause them, done in 1.78, not to work?

Re-abling them means, once upgraded, choosing the appropriate theme from Manage family trees > Preferences > User preferences - Default theme , right?

Thanks.
Novice in all webtrees matters and in every respect

Connexion ou Créer un compte pour participer à la conversation.

webtrees 1.7.9 il y a 3 ans 4 mois #8

  • fisharebest
  • Portrait de fisharebest Auteur du sujet
  • Hors Ligne
  • Administrator
  • Administrator
  • Messages : 12895
> Has anything chnaged in 1.79 that would cause them, done in 1.78, not to work?

Nothing intentional !

It is 99.99% that it will work OK. But it is impossible to guarantee 100%.

> Re-abling them means, once upgraded, choosing the appropriate theme from Manage family trees > Preferences > User preferences - Default theme , right?

Yes
Greg Roach - Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser. - fisharebest.webtrees.net

Connexion ou Créer un compte pour participer à la conversation.

Avez-vous besoin d'une solution d'hébergement web pour votre site webtrees ?
Si vous préférez un hébergeur spécialisé de webtrees, la page suivante en liste quelques-uns capables de vous offrir ce type de service :

webtrees 1.7.9 il y a 3 ans 4 mois #9

Thanks Greg,

Upgraded and themes re-anabled without any problems.

Cheers.
Novice in all webtrees matters and in every respect

Connexion ou Créer un compte pour participer à la conversation.

webtrees 1.7.9 il y a 3 ans 4 mois #10

I just want to say thank you!
Automatic upgrade worked without any problems.

Connexion ou Créer un compte pour participer à la conversation.

webtrees 1.7.9 il y a 2 ans 5 mois #11

Which php version 5.6 or 7.1 recommended for 1.7.9 usage?

Connexion ou Créer un compte pour participer à la conversation.

Dernière édition: par UksusoFF.

webtrees 1.7.9 il y a 2 ans 5 mois #12

  • fisharebest
  • Portrait de fisharebest Auteur du sujet
  • Hors Ligne
  • Administrator
  • Administrator
  • Messages : 12895
5,3, 5.4, 5.5, 5.6 or 7.0

7.0 gives better performance.

7.1 will also work - except for .ZIP files. (i.e. download .ZIP, upgrade wizard).
Greg Roach - Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser. - fisharebest.webtrees.net

Connexion ou Créer un compte pour participer à la conversation.

webtrees 1.7.9 il y a 2 ans 5 mois #13

fisharebest écrit: 5,3, 5.4, 5.5, 5.6 or 7.0

7.0 gives better performance.

7.1 will also work - except for .ZIP files. (i.e. download .ZIP, upgrade wizard).

Thanks. Trying to use with 7.1

Connexion ou Créer un compte pour participer à la conversation.

webtrees 1.7.9 il y a 2 ans 5 mois #14

using 7.2 with .opcache-Acceleration.
super speed!

Connexion ou Créer un compte pour participer à la conversation.

Dernière édition: par madargel.

webtrees 1.7.9 il y a 1 an 5 jours #15

i have choose v 7.0 and WORK !!!!! WORK !!!

Connexion ou Créer un compte pour participer à la conversation.

webtrees 1.7.9 il y a 1 an 4 jours #16

Hi,
in latest versions of webtrees and PHP 7 it works for me, too. But I switched away from Plesk, so I can not test it in a Plesk environment.
My homepage: www.weiland24.de
My webtrees: webtrees.weiland24.de

Connexion ou Créer un compte pour participer à la conversation.

  • Page :
  • 1
Propulsé par Kunena