Bienvenue, Invité
Nom d'utilisateur : Mot de passe :
Before asking for help please read "How to request help" by clicking on that tab above here.
  • Page :
  • 1

SUJET : [SOLVED] Add-on / Modules compatible for 2.0+

Add-on / Modules compatible for 2.0+ il y a 7 mois 1 semaine #1

Is there a list of which modules are compatible with webtrees 2.0+?
Also where there are located? It seems most modules/add-on/Themes are only for 1.7x and older
Trying to plan if i need to build reports/modules from scratch

Thanks, Kevin

Connexion ou Créer un compte pour participer à la conversation.

Add-on / Modules compatible for 2.0+ il y a 7 mois 1 semaine #2

  • fisharebest
  • Portrait de fisharebest
  • Hors Ligne
  • Administrator
  • Administrator
  • Messages : 12895
Modules written for 1.7 will not work with 2.0. The code is totally different.

Since the code is still changing (slightly), I expect module authors to wait for the final 2.0 release before they work on updated versions.
Greg Roach - Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser. - fisharebest.webtrees.net

Connexion ou Créer un compte pour participer à la conversation.

[SOLVED] Add-on / Modules compatible for 2.0+ il y a 7 mois 1 semaine #3

Problem solved.

Connexion ou Créer un compte pour participer à la conversation.

Add-on / Modules compatible for 2.0+ il y a 7 mois 1 semaine #4

Thank you. That makes sense -- is there an ETA for when 2.0 when be completed?

Connexion ou Créer un compte pour participer à la conversation.

Add-on / Modules compatible for 2.0+ il y a 7 mois 1 semaine #5

fisharebest écrit: Modules written for 1.7 will not work with 2.0. The code is totally different.

Since the code is still changing (slightly), I expect module authors to wait for the final 2.0 release before they work on updated versions.


My modules are available for 2.x already. I have updated descriptions in the Add-Ons section to indicate this. Is this still the preferred place to list custom modules?
Richard

webtrees 2.0.4 at cissee.de/webtrees2
Custom modules for 1.7.x and 2.x (Extended Relationships, Gov4Webtrees, Shared Places, Compact Themes Adjuster) available at cissee.de

Connexion ou Créer un compte pour participer à la conversation.

Add-on / Modules compatible for 2.0+ il y a 7 mois 1 semaine #6

Thanks Richard.

I guess I am little confused when modules say 1.7.x+, if there are truly compatible (at the current time) with 2.0+. Also, if all modules should go in the v4 path or would some still go in the v3 path folder.

Connexion ou Créer un compte pour participer à la conversation.

Add-on / Modules compatible for 2.0+ il y a 7 mois 1 semaine #7

kevyNC écrit: I guess I am little confused when modules say 1.7.x+, if there are truly compatible (at the current time) with 2.0+

Very likely not, unless it's stated explicitly.
As Greg mentioned, modules have to be re-implemented completely for 2.x. The '+' usually only indicates a minimally required (or tested) version.

kevyNC écrit: Also, if all modules should go in the v4 path or would some still go in the v3 path folder.

There is no v3 path in webtrees 2.x, so all 2.x modules go into the v4 path (Putting 1.x modules there won't work unless they somehow support both versions from a single codebase, which again is unlikely).
Richard

webtrees 2.0.4 at cissee.de/webtrees2
Custom modules for 1.7.x and 2.x (Extended Relationships, Gov4Webtrees, Shared Places, Compact Themes Adjuster) available at cissee.de

Connexion ou Créer un compte pour participer à la conversation.

Dernière édition: par ric2015.
  • Page :
  • 1
Propulsé par Kunena