Bienvenue, Invité
Nom d'utilisateur : Mot de passe :


This Help forum is for issues relates to the latest release (1.7.10/11/12). For issues related to development versions please use their own Help forum.
Before asking for help please read "How to request help" by clicking on that tab above here."
  • Page :
  • 1
  • 2

SUJET : [SOLVED] Could not upgrade since 1.7.9

Could not upgrade since 1.7.9 il y a 4 mois 2 semaines #1

  • vbke
  • Portrait de vbke
  • Hors Ligne
  • New
  • Messages : 16
I am running webtrees since 2012, but since 1.7.9 I am alwas struggling to upgrade, I get error messages, but I am far from an IT specialist, don't have knowledge of php to understand the error messages, ...
With 1.7.14 I would like to give it another serious try.
As backup, I exported the ged-file, saved the db in sql file.
I checked that the PHP version = 7.3.

What is the best way?
* delete everything except the \data folder and then copy the 1.7.14 over it?
* try the auto upgrade (never got this successfull working without error messages)
All suggestions are welcome.
L'administrateur a désactivé l'accès en écriture pour le public.

Could not upgrade since 1.7.9 il y a 4 mois 2 semaines #2

  • fisharebest
  • Portrait de fisharebest
  • Hors Ligne
  • Administrator
  • Messages : 11556
> * delete everything except the \data folder and then copy the 1.7.14 over it?

No need to delete anything.

Just copy the 1.7.14 files over the 1.7.9 files - replacing any that have the same name.
Greg Roach - Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser. - fisharebest.webtrees.net
L'administrateur a désactivé l'accès en écriture pour le public.

Could not upgrade since 1.7.9 il y a 4 mois 2 semaines #3

  • vbke
  • Portrait de vbke
  • Hors Ligne
  • New
  • Messages : 16
Didn't delete anything and copied full 1.7.14 over 1.7.9.
I get a blanc screen, no errors or fault messages. The index.php is realy there on that location

the site is at vandenboschpatrick.be/stamboom/webtrees/index.php

I compaired the old (1.7.9) index.php with the (1.7.14) index.php and the only difference was the copyright year (2018 vs 2019)

I checked my hosting stuff, saw that PHP error messages was "on", but I have no clue where I can find those PHP error logs.
Dernière édition: il y a 4 mois 2 semaines par vbke.
L'administrateur a désactivé l'accès en écriture pour le public.

Could not upgrade since 1.7.9 il y a 4 mois 2 semaines #4

  • fisharebest
  • Portrait de fisharebest
  • Hors Ligne
  • Administrator
  • Messages : 11556
> I compaired the old (1.7.9) index.php with the (1.7.14) index.php and the only difference was the copyright year (2018 vs 2019)

There are only a small number of changes between 1.7.9 and 1.7.14.
These are mostly just for compatibility with new versions of PHP.

> I checked my hosting stuff, saw that PHP error messages was "on", but I have no clue where I can find those PHP error logs.

It is normal for webhosts to provide access and error logs.

If you can't find them, then perhaps you can open a support ticket with your host?

> I get a blanc screen, no errors or fault messages.

Perhaps create a simple PHP test file (e.g. test.php) which contains this:
Hello <?php echo "world"; ?>

If you copy this file to your server, does it run? It should give the message "Hello world".
Greg Roach - Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser. - fisharebest.webtrees.net
L'administrateur a désactivé l'accès en écriture pour le public.

Could not upgrade since 1.7.9 il y a 4 mois 2 semaines #5

  • vbke
  • Portrait de vbke
  • Hors Ligne
  • New
  • Messages : 16
>Perhaps create a simple PHP test file (e.g. test.php) which contains this:
Hello <?php echo "world"; ?>

that worked perfect!

>It is normal for webhosts to provide access and error logs.
>If you can't find them, then perhaps you can open a support ticket with your host?

They requested me add the following 2 lines of code in the index.php file just after the first line <?php
error_reporting(E_ALL);
ini_set('display_errors', 1);

then I get error msg: Fatal error:
Namespace declaration statement has to be the very first statement or after any declare call in the script in /customers/b/5/9/vandenboschpatrick.be/httpd.www/stamboom/webtrees/index.php on line 18

the index.php looks like (with line 18= "namespace Fisharebest\Webtrees;":
<?php
error_reporting(E_ALL);
ini_set('display_errors', 1);
/**
* webtrees: online genealogy
* Copyright (C) 2019 webtrees development team
* This program is free software: you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
* the Free Software Foundation, either version 3 of the License, or
* (at your option) any later version.
* This program is distributed in the hope that it will be useful,
* but WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
* GNU General Public License for more details.
* You should have received a copy of the GNU General Public License
* along with this program. If not, see <www.gnu.org/licenses/>.
*/
namespace Fisharebest\Webtrees;
/**
* Defined in session.php
*
* @global Tree $WT_TREE
*/
global $WT_TREE;

use Fisharebest\Webtrees\Controller\AjaxController;
use Fisharebest\Webtrees\Controller\PageController;
use Fisharebest\Webtrees\Functions\Functions;
use Fisharebest\Webtrees\Functions\FunctionsDb;

define('WT_SCRIPT_NAME', 'index.php');
require './includes/session.php';

I hope I don't look to nurdish for not understanding what's going wrong.
L'administrateur a désactivé l'accès en écriture pour le public.

Could not upgrade since 1.7.9 il y a 4 mois 2 semaines #6

  • fisharebest
  • Portrait de fisharebest
  • Hors Ligne
  • Administrator
  • Messages : 11556
move the two lines down, just after the line that starts "namespace"
Greg Roach - Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser. - fisharebest.webtrees.net
L'administrateur a désactivé l'accès en écriture pour le public.

Could not upgrade since 1.7.9 il y a 4 mois 2 semaines #7

  • vbke
  • Portrait de vbke
  • Hors Ligne
  • New
  • Messages : 16
just did it. Now it blanc again.
L'administrateur a désactivé l'accès en écriture pour le public.

Could not upgrade since 1.7.9 il y a 4 mois 1 semaine #8

  • vbke
  • Portrait de vbke
  • Hors Ligne
  • New
  • Messages : 16
I openend a ticket at the hosting site and got following answer:

Hello there,

Thank you for patiently waiting!

As per our technical team, based on the error message it isn't related to a server based issue. We advise that you contact the developer of the application that you are using instead or you may purchase and try to use backup and restore to restore your site in a previous working state.


I also already removed every possible spaces from the index.php file, tried downgrading from php 7.3 to 7.1, all without succes.

Anybody some ideas left over?
L'administrateur a désactivé l'accès en écriture pour le public.
Avez-vous besoin d'une solution d'hébergement web pour votre site webtrees ?
Si vous préférez un hébergeur spécialisé de webtrees, la page suivante en liste quelques-uns capables de vous offrir ce type de service :

Could not upgrade since 1.7.9 il y a 4 mois 1 semaine #9

  • fisharebest
  • Portrait de fisharebest
  • Hors Ligne
  • Administrator
  • Messages : 11556
> based on the error message it isn't related to a server based issue

What error message?

Your problem is that you cannot access the error logs, and cannot see any error message...

What is puzzling is that you site gives a "200" (success) response.

> Anybody some ideas left over?

Remove the extra lines that you added to index.php.

Add some debug code. For example, add this line just before the line "include session.php".

echo "OK HERE"; exit;

If the program displays the message and stops, then move this line just after the include line.

If it fails, then the issue is in the session file.

Do the same there. Add the debug line in various places and try to find the place where the error happens.
Greg Roach - Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser. - fisharebest.webtrees.net
L'administrateur a désactivé l'accès en écriture pour le public.

Could not upgrade since 1.7.9 il y a 4 mois 1 semaine #10

  • vbke
  • Portrait de vbke
  • Hors Ligne
  • New
  • Messages : 16
thank you much for the assistance and patience. I'll keep you informed.
L'administrateur a désactivé l'accès en écriture pour le public.

Could not upgrade since 1.7.9 il y a 4 mois 1 semaine #11

  • vbke
  • Portrait de vbke
  • Hors Ligne
  • New
  • Messages : 16
last working line was LINE 174 in \include\sessions = just after "define('WT_BASE_URL', $base_uri);"
then I got
OK HERE (\include\sessions just after LINE173 = define('WT_BASE_URL', vandenboschpatrick.be/stamboom/webtrees/);

I goes wrong when I put something just before LINE177 = set_error_handler(function ($errno, $errstr, $errfile, $errline) {
then I get following error msg:
Notice: Undefined variable: errno in /customers/b/5/9/vandenboschpatrick.be/httpd.www/stamboom/webtrees/includes/session.php on line 176 Notice: Undefined variable: errstr in /customers/b/5/9/vandenboschpatrick.be/httpd.www/stamboom/webtrees/includes/session.php on line 176 Notice: Undefined variable: errfile in /customers/b/5/9/vandenboschpatrick.be/httpd.www/stamboom/webtrees/includes/session.php on line 176 Notice: Undefined variable: errline in /customers/b/5/9/vandenboschpatrick.be/httpd.www/stamboom/webtrees/includes/session.php on line 176 OK HERE (\include\sessions LINE177 = set_error_handler(function (, , , ) {

Hopefully this pinpoints its a bit more.
L'administrateur a désactivé l'accès en écriture pour le public.

Could not upgrade since 1.7.9 il y a 4 mois 1 semaine #12

  • fisharebest
  • Portrait de fisharebest
  • Hors Ligne
  • Administrator
  • Messages : 11556
I leave for my holiday in an hour or so - and have no more time.

There are other PHP programmers here. Perhaps somone else can help....
Greg Roach - Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser. - fisharebest.webtrees.net
L'administrateur a désactivé l'accès en écriture pour le public.

Could not upgrade since 1.7.9 il y a 4 mois 1 semaine #13

  • vbke
  • Portrait de vbke
  • Hors Ligne
  • New
  • Messages : 16
enjoy the holiday
L'administrateur a désactivé l'accès en écriture pour le public.

Could not upgrade since 1.7.9 il y a 4 mois 1 semaine #14

  • ddrury
  • Portrait de ddrury
  • Hors Ligne
  • Senior
  • Messages : 260
Couple of things
1. Are you entering the "OK Here" line exactly as Greg mentioned, if so you should see a blank page except for the text OK HERE on it (see attached)
2. Don't put this line within the set_error_handler and set_exception_handler sections, I suggest trying just before lines

232 (// Load our configuration file, so we can connect to the database)
251 (// What is the remote client's IP address)
259 (// Connect to the database)
280 (// The config.ini.php file must always be in a fixed location.)
290 (// Request more resources - if we can/want to)
301 ($rule = Database::prepare( ....
331 (// Store our session data in the database.)
373 (Session::start(array(...)
387 (// Set the tree for the page; (1) the request, (2) the session, (3) the site default, (4) any tree)
395 (// No chosen tree? Use any one.)

etc. I'm sure you get the gist for lines beyond this

Dave
Pièces jointes :
--
Dave

Local: Win 10 Pro, Apache 2.4.17 virtual hosts, PHP 5.4.21, 5.5.15, 5.6.16 & 7.0.0, Mysql 5.7.9 all 64bit
Production: linux 2.6.32.21-grsec #5 SMP, Apache 2.2, PHP 5.6.15, Mysql 5.5.28-29.1
L'administrateur a désactivé l'accès en écriture pour le public.

Could not upgrade since 1.7.9 il y a 4 mois 1 semaine #15

  • vbke
  • Portrait de vbke
  • Hors Ligne
  • New
  • Messages : 16
The trick with extra "echo" code of line showed that last successful appearance was at Line 288 just before // Request more resources

I commented Line 290 => 299 and it works again!

Thank you all for assitance and patience. Without that I would never have managed it.
L'administrateur a désactivé l'accès en écriture pour le public.

[SOLVED] Could not upgrade since 1.7.9 il y a 4 mois 1 semaine #16

  • vbke
  • Portrait de vbke
  • Hors Ligne
  • New
  • Messages : 16
Problem solved.
L'administrateur a désactivé l'accès en écriture pour le public.

[SOLVED] Could not upgrade since 1.7.9 il y a 4 mois 1 semaine #17

  • ddrury
  • Portrait de ddrury
  • Hors Ligne
  • Senior
  • Messages : 260
Well, not really!

You've come up with a work-around but webtrees shouldn't fail with this bit of code.

I suggest that you check that the values for Memory limit & PHP time limit in Control panel|website preferences are valid and reasonable - try deleting them for now so you see the defaults of 128M & 120.

If they seem ok try inserting the following at about line 288
var_dump(ini_get('safe_mode'), strpos(ini_get('disable_functions'), 'ini_set'));
You should see two lines each (hopefully) ending in false on your pages (probably more than once)

If all the above is true, it would seem that your host although indicating that webtrees is allowed to make changes to PHP's environment isn't actually letting it do so!
--
Dave

Local: Win 10 Pro, Apache 2.4.17 virtual hosts, PHP 5.4.21, 5.5.15, 5.6.16 & 7.0.0, Mysql 5.7.9 all 64bit
Production: linux 2.6.32.21-grsec #5 SMP, Apache 2.2, PHP 5.6.15, Mysql 5.5.28-29.1
L'administrateur a désactivé l'accès en écriture pour le public.

Could not upgrade since 1.7.9 il y a 4 mois 1 semaine #18

  • vbke
  • Portrait de vbke
  • Hors Ligne
  • New
  • Messages : 16
Hi Dave,

In the website preferences, I found the following filled in:
Memory limit 128M
PHP timelimit 120

I hope I did wright by letting this unchanged.
I added your proposed line to Line 280 and then I got a screen reply "bool(false) bool(false".

Did I understood well, that the issue is at my hosting site? For me it's all a bit hocus spocus, but what could I ask them to get this fixed?
L'administrateur a désactivé l'accès en écriture pour le public.

Could not upgrade since 1.7.9 il y a 4 mois 1 semaine #19

  • ddrury
  • Portrait de ddrury
  • Hors Ligne
  • Senior
  • Messages : 260
Looks like it but try the following:

first comment out lines 293 - 295 (set the memory limit) if that doesn't fix anything comment out lines 297-299 (setting the max execution time)

If you still have the problem I suggest you go back to your support people and ask them why that bit of code should be causing the site to fail

Dave
--
Dave

Local: Win 10 Pro, Apache 2.4.17 virtual hosts, PHP 5.4.21, 5.5.15, 5.6.16 & 7.0.0, Mysql 5.7.9 all 64bit
Production: linux 2.6.32.21-grsec #5 SMP, Apache 2.2, PHP 5.6.15, Mysql 5.5.28-29.1
L'administrateur a désactivé l'accès en écriture pour le public.

Could not upgrade since 1.7.9 il y a 4 mois 1 semaine #20

  • vbke
  • Portrait de vbke
  • Hors Ligne
  • New
  • Messages : 16
commenting out 293-295 => no improvement.
commenting out 297-299 =>no improvement.

Is it line 291 -300 that I should submit to my hosting?

if (!ini_get('safe_mode')) {
$memory_limit = Site::getPreference('MEMORY_LIMIT');
if ($memory_limit && strpos(ini_get('disable_functions'), 'ini_set') === false) {
ini_set('memory_limit', $memory_limit);
}
$max_execution_time = Site::getPreference('MAX_EXECUTION_TIME');
if ($max_execution_time && strpos(ini_get('disable_functions'), 'set_time_limit') === false) {
set_time_limit($max_execution_time);
}
}
L'administrateur a désactivé l'accès en écriture pour le public.
  • Page :
  • 1
  • 2
Propulsé par Kunena