Bienvenue, Invité
Nom d'utilisateur : Mot de passe :


This Help forum is for issues relates to the latest release (1.7.10/11/12). For issues related to development versions please use their own Help forum.
Before asking for help please read "How to request help" by clicking on that tab above here."

SUJET : gedcom upload failed with error

gedcom upload failed with error il y a 2 semaines 2 jours #1

  • guidovanharten
  • Portrait de guidovanharten
  • Hors Ligne
  • New
  • Messages : 21
When I upload a gedcom to my webtrees website: SQLSTATE[22001]: String data, right truncated: 1406 Data too long for column 'm_titl' at row 1
In another topic on this forum I read about the length of gedcom lines.
The longest line is 256 characters
3 NOTE followed by a string of 249 characters
What can be another reason of the mentioned error?

Kind regards,
Guido
L'administrateur a désactivé l'accès en écriture pour le public.

gedcom upload failed with error il y a 2 semaines 1 jour #2

  • fisharebest
  • Portrait de fisharebest
  • en ligne
  • Administrator
  • Messages : 11221
Which version of webtrees?

This looks like a problem that was fixed in 1.7.9
Greg Roach - Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser. - fisharebest.webtrees.net
L'administrateur a désactivé l'accès en écriture pour le public.

gedcom upload failed with error il y a 2 semaines 1 jour #3

  • guidovanharten
  • Portrait de guidovanharten
  • Hors Ligne
  • New
  • Messages : 21
I am working with 1.7.14.
L'administrateur a désactivé l'accès en écriture pour le public.

gedcom upload failed with error il y a 2 semaines 1 jour #4

  • fisharebest
  • Portrait de fisharebest
  • en ligne
  • Administrator
  • Messages : 11221
You have a media title that is longer than 255 characters.
You have a GEDCOM file with "inline media" instead of "media objects".
You have enabled strict mode on your database.

These three things combine to cause the error.

Create an issue on github and I will fix it for the next release.
Greg Roach - Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser. - fisharebest.webtrees.net
L'administrateur a désactivé l'accès en écriture pour le public.

gedcom upload failed with error il y a 2 semaines 1 jour #5

  • guidovanharten
  • Portrait de guidovanharten
  • Hors Ligne
  • New
  • Messages : 21
Thanks for your reply!
fisharebest écrit:
You have a media title that is longer than 255 characters.

No it is isn't. in my first post I wrote the longest line is 256 (including the "3 NOTE"). None of the lines of 256 characters are media files.
You have a GEDCOM file with "inline media" instead of "media objects".

Is there a 'simple' way to convert the inline media to media objects?
You have enabled strict mode on your database.

Can you explain me how to disable the strict mode?
Create an issue on github and I will fix it for the next release.

I will take a look about how to create an issue on github.

Kind regards,
Guido
L'administrateur a désactivé l'accès en écriture pour le public.

gedcom upload failed with error il y a 2 semaines 1 jour #6

  • guidovanharten
  • Portrait de guidovanharten
  • Hors Ligne
  • New
  • Messages : 21
I tried it on another way.

I deleted my database and my website and I setup my domain again from scratch.
Underwhile I was creating a gedcom with media objects.
The import of the gedcom now completes without an error.

Kind regards,
Guido
L'administrateur a désactivé l'accès en écriture pour le public.
Propulsé par Kunena