Bienvenue, Invité
Nom d'utilisateur : Mot de passe :


This Help forum is for issues relates to the latest release (1.7.10/11/12). For issues related to development versions please use their own Help forum.
Before asking for help please read "How to request help" by clicking on that tab above here."

SUJET : [SOLVED] white page after change http to https

white page after change http to https il y a 2 mois 2 semaines #1

  • heikea
  • Portrait de heikea
  • Hors Ligne
  • New
  • Messages : 16
Hi to all,

my provider has changed my site from http to https. Now I see a white page only. Version: 1.7.12|1.0.0

I found something about setting the url in the admin section. However, I'm not able to login.

I checked config.php, some database tables, without seeing however, where/how I'd be able to fix this.

Any suggestion where/what I should have to change in order to retrieve the landing page?

Thanks and regards
Heike

heikeelashi.de/webtrees
L'administrateur a désactivé l'accès en écriture pour le public.

white page after change http to https il y a 2 mois 2 semaines #2

  • fisharebest
  • Portrait de fisharebest
  • Hors Ligne
  • Administrator
  • Messages : 10909
Greg Roach - Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser. - fisharebest.webtrees.net
L'administrateur a désactivé l'accès en écriture pour le public.

white page after change http to https il y a 2 mois 2 semaines #3

  • heikea
  • Portrait de heikea
  • Hors Ligne
  • New
  • Messages : 16
Thanks Greg.

I've checked /data permissions, it looks like everything is fine there. Also there is enough space available.

My provider showed me where to find the error log file. It shows this information:

PHP message: PHP Fatal error: Uncaught exception 'Exception' with message 'No Connection Established' in /home/users/heikeelashi/www/webtrees/app/Database.php:275
Stack trace:
#0 /home/users/heikeelashi/www/webtrees/app/Log.php(49): Fisharebest\\Webtrees\\Database::prepare('INSERT INTO `##...')
#1 /home/users/heikeelashi/www/webtrees/app/Log.php(106): Fisharebest\\Webtrees\\Log::addLog('/home/users/hei...', 'error')
#2 /home/users/heikeelashi/www/webtrees/includes/session.php(228): Fisharebest\\Webtrees\\Log::addErrorLog('/home/users/hei...')
#3 [internal function]: Fisharebest\\Webtrees\\{closure}(Object(ErrorException))
#4 {main}
thrown in /home/users/heikeelashi/www/webtrees/app/Database.php on line 275

The section in Database.php including line 275 reads
/**
* Prepare an SQL statement for execution.
*
* @param $sql
*
* @throws \Exception
*
* @return Statement
*/
public static function prepare($sql)
{
if (!self::$pdo instanceof PDO) {
throw new \Exception("No Connection Established");
}
$sql = str_replace('##', WT_TBLPREFIX, $sql);

$hash = md5($sql);
if (!array_key_exists($hash, self::$prepared)) {
self::$prepared[$hash] = new Statement(self::$pdo->prepare($sql));
}

return self::$prepared[$hash];
}

I checked config.ini.php in the /data folder.
user / password / database name are correct.
Further information:
dbhost="localhost"
dbport="3306"

Hope this helps solving the cause.

Regards
Heike
L'administrateur a désactivé l'accès en écriture pour le public.

white page after change http to https il y a 2 mois 2 semaines #4

  • fisharebest
  • Portrait de fisharebest
  • Hors Ligne
  • Administrator
  • Messages : 10909
Thanks for this information.

It shows that webtrees is trying to store the error message in the database - but the error happens before we connect to the database.

Can you edit the file includes/session.php and change line 228 from this

Log::addErrorLog($message);

to this

var_dump($message);exit;

Then try to visit your site again. This time, the error should be displayed on the screen.
Greg Roach - Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser. - fisharebest.webtrees.net
L'administrateur a désactivé l'accès en écriture pour le public.

white page after change http to https il y a 2 mois 2 semaines #5

  • heikea
  • Portrait de heikea
  • Hors Ligne
  • New
  • Messages : 16
The error message:

string(354) "/home/users/heikeelashi/www/webtrees/includes/session.php:234 parse_ini_file() has been disabled for security reasons #0 unknown:unknown ErrorException("parse_ini_file() has been disabled for security reasons") #1 /includes/session.php:234 parse_ini_file('/home/users/heikeelashi/www/we…') #2 /index.php:31 require('/home/users/heikeelashi/www/we…') "
L'administrateur a désactivé l'accès en écriture pour le public.

white page after change http to https il y a 2 mois 2 semaines #6

  • fisharebest
  • Portrait de fisharebest
  • Hors Ligne
  • Administrator
  • Messages : 10909
> parse_ini_file() has been disabled for security reasons

Your host has disabled a harmless PHP function...

There are absolutely *NO* security implications from using the function "parse_ini_file()".

It is just a shortcut for something that could be written manually in about 20 lines of code.

There are reasons to block other PHP functions, such as "ini_set()".
Maybe they just blocked everything with "ini" in the name...

Ask your host to re-enable it.
Greg Roach - Cette adresse e-mail est protégée contre les robots spammeurs. Vous devez activer le JavaScript pour la visualiser. - fisharebest.webtrees.net
L'administrateur a désactivé l'accès en écriture pour le public.

white page after change http to https il y a 2 mois 2 semaines #7

  • heikea
  • Portrait de heikea
  • Hors Ligne
  • New
  • Messages : 16
Thanks Greg, I'll contact my provider.
Regards
Heike
L'administrateur a désactivé l'accès en écriture pour le public.

white page after change http to https il y a 2 mois 1 semaine #8

  • heikea
  • Portrait de heikea
  • Hors Ligne
  • New
  • Messages : 16
Hi Greg,
my provider stated that the only change was from http to https.
However after having authorized me for the parse_ini_files my webtrees is in working order again.
So thanks, problem solved.
Regards
Heike
L'administrateur a désactivé l'accès en écriture pour le public.
Avez-vous besoin d'une solution d'hébergement web pour votre site webtrees ?
Si vous préférez un hébergeur spécialisé de webtrees, la page suivante en liste quelques-uns capables de vous offrir ce type de service :

[SOLVED] white page after change http to https il y a 2 mois 1 semaine #9

  • heikea
  • Portrait de heikea
  • Hors Ligne
  • New
  • Messages : 16
Problem solved.
L'administrateur a désactivé l'accès en écriture pour le public.
Propulsé par Kunena